aboutsummaryrefslogtreecommitdiff
path: root/lang/python/Makefile
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2004-07-09 17:18:00 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2004-07-09 17:18:00 +0000
commit90c653ebbfee158880bc5fc4eb15ad057288510a (patch)
tree6ae0144fc961163f30ad286f617000b7d94189a8 /lang/python/Makefile
parentf9f6bca24258ac903bc7eb64601bfe0a066694e2 (diff)
downloadports-90c653ebbfee158880bc5fc4eb15ad057288510a.tar.gz
ports-90c653ebbfee158880bc5fc4eb15ad057288510a.zip
Allow to install and use 3rd party packages in X11BASE.
${X11BASE}/lib/{python2.3{,/site-packages},site-python} will be added to your python's sys.path if each directory exists. Suggested by: marcus
Notes
Notes: svn path=/head/; revision=113294
Diffstat (limited to 'lang/python/Makefile')
-rw-r--r--lang/python/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 9591ae05d10a..be8add20da11 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -7,6 +7,7 @@
PORTNAME= python
PORTVERSION= 2.3.4
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -121,6 +122,9 @@ pre-patch:
${REINPLACE_CMD} -e \
's,/usr/doc/python-docs-,${PREFIX}/share/doc/python,g' \
${WRKSRC}/Lib/pydoc.py
+ ${REINPLACE_CMD} -e \
+ 's|^\(prefixes = .*\)\]$$|\1, "${X11BASE}"]|g' \
+ ${WRKSRC}/Lib/site.py
post-configure: ${STACKLESS_POST_CONFIGURE}
@# prepare a subdir for shared build