aboutsummaryrefslogtreecommitdiff
path: root/lang/python/Makefile
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2004-08-07 07:00:18 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2004-08-07 07:00:18 +0000
commitf0c20c8b696ebffbd2c36315316636c41712351a (patch)
tree29ce213eb602cf9c4d0da6cb8555ba7b7b70b725 /lang/python/Makefile
parentbbc1787d3dcc16278efe26af444758780e97c118 (diff)
downloadports-f0c20c8b696ebffbd2c36315316636c41712351a.tar.gz
ports-f0c20c8b696ebffbd2c36315316636c41712351a.zip
- Allow to disable IPv6 support [1]
- Add checksum for 2.4a2 PR: 69950 [1] Submitted by: Marcus Grando <marcus@corp.grupos.com.br>
Notes
Notes: svn path=/head/; revision=115551
Diffstat (limited to 'lang/python/Makefile')
-rw-r--r--lang/python/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index ceac8f7cc0fa..080969a76ebd 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -41,7 +41,8 @@ TOOLSDIR= ${PREFIX}/share/${PYTHON_VERSION}
OPTIONS= THREADS "Enable thread support" on \
HUGE_STACK_SIZE "Use a larger thread stack" off \
UCS4 "Use UCS4 for unicode support" on \
- PYMALLOC "Uses python's internal malloc" on
+ PYMALLOC "Use python's internal malloc" on \
+ IPV6 "Enable IPv6 support" on
.include <bsd.port.pre.mk>
@@ -96,7 +97,7 @@ CONFIGURE_ARGS+= --with-libs='-lxpg4'
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
-.if ${OSVERSION} >= 400014
+.if !defined(WITHOUT_IPV6) && ${OSVERSION} >= 400014
CONFIGURE_ARGS+= --enable-ipv6
.else
CONFIGURE_ARGS+= --disable-ipv6