aboutsummaryrefslogtreecommitdiff
path: root/lang/python22
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2004-04-14 06:49:21 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2004-04-14 06:49:21 +0000
commit9e1cf1197820ca234a3d09f6997703a58f0755a2 (patch)
treefe2b4e05b6207af8fb9eaa70fcc6853ac8c4d1b7 /lang/python22
parentf04d1caa47275fa4fa52733b3bb321621b583fa8 (diff)
downloadports-9e1cf1197820ca234a3d09f6997703a58f0755a2.tar.gz
ports-9e1cf1197820ca234a3d09f6997703a58f0755a2.zip
Fixed a bug where the configure script couldn't detect getaddrinfo()
properly if the KAME stack had SCTP support. Submitted by: suz
Notes
Notes: svn path=/head/; revision=106995
Diffstat (limited to 'lang/python22')
-rw-r--r--lang/python22/Makefile2
-rw-r--r--lang/python22/files/patch-configure10
2 files changed, 11 insertions, 1 deletions
diff --git a/lang/python22/Makefile b/lang/python22/Makefile
index 1ddb3c24e2f8..c8a4818d4722 100644
--- a/lang/python22/Makefile
+++ b/lang/python22/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python
PORTVERSION= 2.2.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python22/files/patch-configure b/lang/python22/files/patch-configure
new file mode 100644
index 000000000000..1ed245321f04
--- /dev/null
+++ b/lang/python22/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Wed Apr 14 15:29:28 2004
++++ configure Wed Apr 14 15:30:25 2004
+@@ -5523,6 +5523,7 @@
+ hints.ai_family = AF_UNSPEC;
+ hints.ai_flags = passive ? AI_PASSIVE : 0;
+ hints.ai_socktype = SOCK_STREAM;
++ hints.ai_protocol = IPPROTO_TCP;
+ if ((gaierr = getaddrinfo(NULL, "54321", &hints, &aitop)) != 0) {
+ (void)gai_strerror(gaierr);
+ goto bad;