aboutsummaryrefslogtreecommitdiff
path: root/lang/python26/Makefile
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2004-08-07 06:36:57 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2004-08-07 06:36:57 +0000
commit03cd3fd2e0043400d07b0696a4cf5291b64ef440 (patch)
tree80b403283f3e5e98f12265e9ed632700319b1661 /lang/python26/Makefile
parenta09c1bb5235612382cc1ebac761cb6cbc4fedbf0 (diff)
downloadports-03cd3fd2e0043400d07b0696a4cf5291b64ef440.tar.gz
ports-03cd3fd2e0043400d07b0696a4cf5291b64ef440.zip
- Update to 2.4a2
- Add IPV6 option [1] PR: 69950 [1] Submitted by: Marcus Grando <marcus@corp.grupos.com.br> [1]
Notes
Notes: svn path=/head/; revision=115547
Diffstat (limited to 'lang/python26/Makefile')
-rw-r--r--lang/python26/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index f36ec2035a9f..18cd9a6e2ab0 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= python
-PORTVERSION= 2.4.a1
-PORTREVISION= 1
+PORTVERSION= 2.4.a2
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -40,7 +39,8 @@ TOOLSDIR= ${PREFIX}/share/${PYTHON_VERSION}
OPTIONS= THREADS "Enable thread support" on \
HUGE_STACK_SIZE "Use a larger thread stack" off \
UCS4 "Use UCS4 for unicode support" on \
- PYMALLOC "Uses python's internal malloc" on
+ PYMALLOC "Use python's internal malloc" on \
+ IPV6 "Enable IPv6 support" on
.include <bsd.port.pre.mk>
@@ -95,7 +95,7 @@ CONFIGURE_ARGS+= --with-libs='-lxpg4'
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
-.if ${OSVERSION} >= 400014
+.if !defined(WITHOUT_IPV6) && ${OSVERSION} >= 400014
CONFIGURE_ARGS+= --enable-ipv6
.else
CONFIGURE_ARGS+= --disable-ipv6