aboutsummaryrefslogtreecommitdiff
path: root/lang/python2
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2013-08-18 15:25:24 +0000
committerMarcus von Appen <mva@FreeBSD.org>2013-08-18 15:25:24 +0000
commit50bb471eff62999150a66062b43aa9a5e61a60a1 (patch)
tree08a2f18bdbefddb1f468c74b133fb51bc176f7d3 /lang/python2
parent5b80249cd727cb7ce41a0f02ffcadc7e310ceaac (diff)
downloadports-50bb471eff62999150a66062b43aa9a5e61a60a1.tar.gz
ports-50bb471eff62999150a66062b43aa9a5e61a60a1.zip
- Avoid circular dependencies due to the previous bsd.python.mk change
Notes
Notes: svn path=/head/; revision=324925
Diffstat (limited to 'lang/python2')
-rw-r--r--lang/python2/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/lang/python2/Makefile b/lang/python2/Makefile
index 99b47276cc13..1e0448e61aa8 100644
--- a/lang/python2/Makefile
+++ b/lang/python2/Makefile
@@ -13,6 +13,7 @@ COMMENT= The "meta-port" for version 2 of the Python interpreter
USE_PYTHON_RUN= yes
PYTHON_VERSION= ${PYTHON_DEFAULT_VERSION}
NO_BUILD= yes
+PYTHON_NO_DEPENDS= yes
PLIST_FILES= bin/2to3-${PYTHON_MAJOR_VER} \
bin/idle${PYTHON_MAJOR_VER} \
@@ -25,6 +26,8 @@ PLIST_FILES= bin/2to3-${PYTHON_MAJOR_VER} \
.include <bsd.port.pre.mk>
+RUN_DEPENDS+= ${PYTHON_CMD}:${PYTHON_PORTSDIR}
+
do-install:
.for file in idle pydoc python python-shared
${LN} -sf ${PREFIX}/bin/${file}${PYTHON_VER} ${PREFIX}/bin/${file}${PYTHON_MAJOR_VER}