aboutsummaryrefslogtreecommitdiff
path: root/lang/python2
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2014-08-04 05:49:35 +0000
committerMarcus von Appen <mva@FreeBSD.org>2014-08-04 05:49:35 +0000
commit9db59e212556ffec663e1b25675d383f892f606f (patch)
tree6adeea64720ead72099ea4f443a3d29a703473e4 /lang/python2
parent474ce0fa3d8926e6a3282d9fa0d9bbf9865b9615 (diff)
downloadports-9db59e212556ffec663e1b25675d383f892f606f.tar.gz
ports-9db59e212556ffec663e1b25675d383f892f606f.zip
- Fix and remove stale symlinks after the lang/python* cleanup
Reported by: Scott Allendorf <scott-allendorf@uiowa.edu>
Notes
Notes: svn path=/head/; revision=363965
Diffstat (limited to 'lang/python2')
-rw-r--r--lang/python2/Makefile11
1 files changed, 2 insertions, 9 deletions
diff --git a/lang/python2/Makefile b/lang/python2/Makefile
index 7cd14d341c37..7cb83c9fedd4 100644
--- a/lang/python2/Makefile
+++ b/lang/python2/Makefile
@@ -2,7 +2,7 @@
PORTNAME= python2
PORTVERSION= ${PYTHON_MAJOR_VER}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang python ipv6
MASTER_SITES= # empty
DISTFILES= # empty
@@ -21,9 +21,6 @@ PLIST_FILES= bin/2to3-${PYTHON_MAJOR_VER} \
bin/pydoc${PYTHON_MAJOR_VER} \
bin/python${PYTHON_MAJOR_VER} \
bin/python${PYTHON_MAJOR_VER}-config \
- bin/python-shared${PYTHON_MAJOR_VER} \
- bin/python-shared${PYTHON_MAJOR_VER}-config \
- bin/smtpd${PYTHON_MAJOR_VER}.py \
libdata/pkgconfig/python${PYTHON_MAJOR_VER}.pc
.include <bsd.port.pre.mk>
@@ -31,18 +28,14 @@ PLIST_FILES= bin/2to3-${PYTHON_MAJOR_VER} \
RUN_DEPENDS+= ${PYTHON_CMD}:${PYTHON_PORTSDIR}
do-install:
-.for file in idle pydoc python python-shared
+.for file in idle pydoc python
${LN} -sf ${file}${PYTHON_VER} \
${STAGEDIR}${PREFIX}/bin/${file}${PYTHON_MAJOR_VER}
.endfor
${LN} -sf 2to3-${PYTHON_VER} \
${STAGEDIR}${PREFIX}/bin/2to3-${PYTHON_MAJOR_VER}
- ${LN} -sf smtpd${PYTHON_VER}.py \
- ${STAGEDIR}${PREFIX}/bin/smtpd${PYTHON_MAJOR_VER}.py
${LN} -sf python${PYTHON_VER}-config \
${STAGEDIR}${PREFIX}/bin/python${PYTHON_MAJOR_VER}-config
- ${LN} -sf python-shared${PYTHON_VER}-config \
- ${STAGEDIR}${PREFIX}/bin/python-shared${PYTHON_MAJOR_VER}-config
${LN} -sf python-${PYTHON_VER}.pc \
${STAGEDIR}${PREFIX}/libdata/pkgconfig/python${PYTHON_MAJOR_VER}.pc