aboutsummaryrefslogtreecommitdiff
path: root/lang/python32
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2000-01-06 11:46:19 +0000
committerThomas Gellekum <tg@FreeBSD.org>2000-01-06 11:46:19 +0000
commit07223f8ddaa8cc8c3abc60bf58a4e8091c870e93 (patch)
tree79d4edee3585dc0dae67116238a8fa2c38cfbc3f /lang/python32
parentb4e731e713669cb752d0541a93a1049aa8549591 (diff)
downloadports-07223f8ddaa8cc8c3abc60bf58a4e8091c870e93.tar.gz
ports-07223f8ddaa8cc8c3abc60bf58a4e8091c870e93.zip
- Install python-mode.el.
PR: 15702 Submitted by: "Dmitry S. Sivachenko" <dima@Chg.RU> - Only use Tk support if X11 is installed. PR: 15910 Submitted by: Nathan Dorfman <nathan@rtfm.net>
Notes
Notes: svn path=/head/; revision=24476
Diffstat (limited to 'lang/python32')
-rw-r--r--lang/python32/Makefile6
-rw-r--r--lang/python32/pkg-plist2
2 files changed, 7 insertions, 1 deletions
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index fe715b119522..3cc135b675b2 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -32,9 +32,11 @@ MAN1= python.1
SETUP_FILE= Setup
#
-# Support for Tk is compiled in by default.
+# Support for Tk is compiled in by default only if X11 is installed.
#
+.if exists(${X11_BASE})
WITH_TK?= yes
+.endif
.if defined(WITH_TK) && $(WITH_TK) == yes
TK_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82
SETUP_LOCAL= Setup.tk
@@ -104,6 +106,8 @@ pre-install:
post-install:
strip ${PREFIX}/bin/python
@${MKDIR} ${PREFIX}/share/doc/python
+ @${MKDIR} ${PREFIX}/share/emacs/site-lisp
+ ${INSTALL_DATA} ${WRKSRC}/Misc/python-mode.el ${PREFIX}/share/emacs/site-lisp
${INSTALL_DATA} ${WRKSRC}/Misc/COPYRIGHT ${PREFIX}/share/doc/python
@${MKDIR} ${PREFIX}/lib/python1.5/site-packages
.if defined(WITH_TOOLS) && ${WITH_TOOLS} == yes
diff --git a/lang/python32/pkg-plist b/lang/python32/pkg-plist
index 2360c6ba0f0d..58ef1c97477d 100644
--- a/lang/python32/pkg-plist
+++ b/lang/python32/pkg-plist
@@ -1,6 +1,7 @@
bin/python1.5
bin/python
share/doc/python/COPYRIGHT
+share/emacs/site-lisp/python-mode.el
include/python1.5/Python.h
include/python1.5/abstract.h
include/python1.5/bitset.h
@@ -995,3 +996,4 @@ lib/python1.5/xmllib.pyo
@dirrm lib/python1.5
@exec mkdir -p %D/lib/python1.5/site-packages
@dirrm share/doc/python
+@unexec rmdir share/emacs/site-lisp 2>/dev/null || true