aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1998-05-07 08:22:13 +0000
committerThomas Gellekum <tg@FreeBSD.org>1998-05-07 08:22:13 +0000
commit82deb06f149e88df99a78938cc7aeb0679cf298a (patch)
tree065735930736735ae41a149607226a7b95a3cbad /lang/python
parent36e4ff9e75efc95becabcb02d5936639da324eb1 (diff)
downloadports-82deb06f149e88df99a78938cc7aeb0679cf298a.tar.gz
ports-82deb06f149e88df99a78938cc7aeb0679cf298a.zip
Don't throw away OS version number, some scripts need it. Pick up
latest official patches while I'm here.
Notes
Notes: svn path=/head/; revision=10893
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/Makefile26
-rw-r--r--lang/python/distinfo4
-rw-r--r--lang/python/pkg-plist42
3 files changed, 54 insertions, 18 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index d80ca7071ec3..2888f6dd650d 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -3,7 +3,7 @@
# Date created: 08 August 1995
# Whom: jkh
#
-# $Id: Makefile,v 1.28 1998/04/29 07:15:39 tg Exp $
+# $Id: Makefile,v 1.29 1998/05/05 08:53:27 tg Exp $
#
DISTNAME= pyth151
@@ -16,8 +16,8 @@ EXTRACT_SUFX= .tgz
PATCH_SITES= http://www.python.org/1.5/patches-1.5.1/
PATCHFILES= _tkinter.1.txt bltinmodule.1.txt configure.2.txt \
fileobject.1.txt freeze.1.txt imaplib.1.txt object.1.txt \
- parsermodule.1.txt pcre.1.txt string.1.txt timemodule.1.txt \
- urllib.1.txt zlibmodule.1.txt
+ parsermodule.1.txt pcre.1.txt sgmllib.1.txt string.1.txt \
+ timemodule.1.txt urllib.1.txt urllib.2.txt zlibmodule.1.txt
MAINTAINER= tg@FreeBSD.org
@@ -66,13 +66,33 @@ CONFIGURE_ENV= LDFLAGS="-pthread ${LDFLAGS}"
SETUP_LOCAL+= Setup.gmp
.endif
+post-extract:
+ cd ${WRKSRC}/Lib; ${SH} ${FILESDIR}/plat-freebsd2.sh; \
+ ${SH} ${FILESDIR}/plat-freebsd3.sh
+
post-configure:
${CP} ${FILESDIR}/${SETUP_FILE} ${WRKSRC}/Modules/Setup
.for file in ${SETUP_LOCAL}
${CAT} ${FILESDIR}/${file} >> ${WRKSRC}/Modules/Setup.local
.endfor
+OSVERSION!= sysctl -n kern.osreldate
+
+pre-install:
+.if ${OSVERSION} < 300000
+ ${MKDIR} ${PREFIX}/lib/python1.5/plat-freebsd3
+ ${INSTALL_DATA} ${WRKSRC}/Lib/plat-freebsd3/* ${PREFIX}/lib/python1.5/plat-freebsd3
+.else
+ ${MKDIR} ${PREFIX}/lib/python1.5/plat-freebsd2
+ ${INSTALL_DATA} ${WRKSRC}/Lib/plat-freebsd2/* ${PREFIX}/lib/python1.5/plat-freebsd2
+.endif
+
post-install:
+.if ${OSVERSION} < 300000
+ ${INSTALL_SCRIPT} ${PREFIX}/lib/python1.5/plat-freebsd2/regen ${PREFIX}/lib/python1.5/plat-freebsd3
+.else
+ ${INSTALL_SCRIPT} ${PREFIX}/lib/python1.5/plat-freebsd3/regen ${PREFIX}/lib/python1.5/plat-freebsd2
+.endif
strip ${PREFIX}/bin/python
.include <bsd.port.mk>
diff --git a/lang/python/distinfo b/lang/python/distinfo
index 77dea01a2380..23d0076be25e 100644
--- a/lang/python/distinfo
+++ b/lang/python/distinfo
@@ -2,13 +2,15 @@ MD5 (python/pyth151.tgz) = eb8ef6e37e543058a2d47996ecf62427
MD5 (python/_tkinter.1.txt) = 7298bfd731a613a28e2cb72ad8e3e266
MD5 (python/bltinmodule.1.txt) = c1edf803162860802d45c32d9799daaa
MD5 (python/configure.2.txt) = a51d521cf899a74b234f5b0fc1a2207c
-MD5 (python/fileobject.1.txt) = 71185aaf77552a7321cddd9ab4ec5ec9
+MD5 (python/fileobject.1.txt) = 20ebd260276bdf6c3723c62a370e1c8c
MD5 (python/freeze.1.txt) = 7cb9266ba6db670cd019cf27c77468ef
MD5 (python/imaplib.1.txt) = ece2e50e69e7ec86c1a9cc310d5ae220
MD5 (python/object.1.txt) = f03bad9c3d67190232fce407b0c0fa51
MD5 (python/parsermodule.1.txt) = 24e41667e705fbe310e8d8dd85da706d
MD5 (python/pcre.1.txt) = 19808acd1f64eec95266210ff01e3ea4
+MD5 (python/sgmllib.1.txt) = e5ef0538266ff97efd830dfdcc2fcdd5
MD5 (python/string.1.txt) = 581f5dc5c173e8f9927a5a71f7c2b0cc
MD5 (python/timemodule.1.txt) = 7f53c69797c03c7db56f117514790e0d
MD5 (python/urllib.1.txt) = d8b46f39d521d5d6738fe4c6e905a313
+MD5 (python/urllib.2.txt) = e0189571f5b40a87be4c20ad13a02e62
MD5 (python/zlibmodule.1.txt) = 7d8dfda5f91fd370e001d1f544afd279
diff --git a/lang/python/pkg-plist b/lang/python/pkg-plist
index a5880efa510c..5a5deec6b88d 100644
--- a/lang/python/pkg-plist
+++ b/lang/python/pkg-plist
@@ -464,19 +464,32 @@ lib/python1.5/pickle.pyo
lib/python1.5/pipes.py
lib/python1.5/pipes.pyc
lib/python1.5/pipes.pyo
-lib/python1.5/plat-freebsd/FCNTL.py
-lib/python1.5/plat-freebsd/FCNTL.pyc
-lib/python1.5/plat-freebsd/FCNTL.pyo
-lib/python1.5/plat-freebsd/IN.py
-lib/python1.5/plat-freebsd/IN.pyc
-lib/python1.5/plat-freebsd/IN.pyo
-lib/python1.5/plat-freebsd/SOCKET.py
-lib/python1.5/plat-freebsd/SOCKET.pyc
-lib/python1.5/plat-freebsd/SOCKET.pyo
-lib/python1.5/plat-freebsd/TERMIOS.py
-lib/python1.5/plat-freebsd/TERMIOS.pyc
-lib/python1.5/plat-freebsd/TERMIOS.pyo
-lib/python1.5/plat-freebsd/regen
+lib/python1.5/plat-freebsd2/FCNTL.py
+lib/python1.5/plat-freebsd2/FCNTL.pyc
+lib/python1.5/plat-freebsd2/FCNTL.pyo
+lib/python1.5/plat-freebsd2/IN.py
+lib/python1.5/plat-freebsd2/IN.pyc
+lib/python1.5/plat-freebsd2/IN.pyo
+lib/python1.5/plat-freebsd2/SOCKET.py
+lib/python1.5/plat-freebsd2/SOCKET.pyc
+lib/python1.5/plat-freebsd2/SOCKET.pyo
+lib/python1.5/plat-freebsd2/TERMIOS.py
+lib/python1.5/plat-freebsd2/TERMIOS.pyc
+lib/python1.5/plat-freebsd2/TERMIOS.pyo
+lib/python1.5/plat-freebsd2/regen
+lib/python1.5/plat-freebsd3/FCNTL.py
+lib/python1.5/plat-freebsd3/FCNTL.pyc
+lib/python1.5/plat-freebsd3/FCNTL.pyo
+lib/python1.5/plat-freebsd3/IN.py
+lib/python1.5/plat-freebsd3/IN.pyc
+lib/python1.5/plat-freebsd3/IN.pyo
+lib/python1.5/plat-freebsd3/SOCKET.py
+lib/python1.5/plat-freebsd3/SOCKET.pyc
+lib/python1.5/plat-freebsd3/SOCKET.pyo
+lib/python1.5/plat-freebsd3/TERMIOS.py
+lib/python1.5/plat-freebsd3/TERMIOS.pyc
+lib/python1.5/plat-freebsd3/TERMIOS.pyo
+lib/python1.5/plat-freebsd3/regen
lib/python1.5/poly.py
lib/python1.5/poly.pyc
lib/python1.5/poly.pyo
@@ -890,7 +903,8 @@ lib/python1.5/zmod.pyo
man/man1/python.1.gz
@dirrm lib/python1.5/test/output
@dirrm lib/python1.5/test
-@dirrm lib/python1.5/plat-freebsd
+@dirrm lib/python1.5/plat-freebsd2
+@dirrm lib/python1.5/plat-freebsd3
@dirrm lib/python1.5/lib-tk
@dirrm lib/python1.5/lib-stdwin
@dirrm lib/python1.5/lib-dynload