aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1998-03-03 08:05:04 +0000
committerThomas Gellekum <tg@FreeBSD.org>1998-03-03 08:05:04 +0000
commit98753c4bbb7af53798d29dafa53fc6b0bf125816 (patch)
treeaf8a3672e076dd16a6327e11d41dc965464318f3 /lang/python
parent2aec5e482c6a251baf4de1abe8d2f8bf143475ea (diff)
downloadports-98753c4bbb7af53798d29dafa53fc6b0bf125816.tar.gz
ports-98753c4bbb7af53798d29dafa53fc6b0bf125816.zip
Use -D_THREAD_SAFE when compiling the threaded version.
Notes
Notes: svn path=/head/; revision=10007
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 90703f216167..80ec47f185c8 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -3,7 +3,7 @@
# Date created: 08 August 1995
# Whom: jkh
#
-# $Id: Makefile,v 1.21 1998/02/24 21:43:19 jseger Exp $
+# $Id: Makefile,v 1.22 1998/02/27 10:21:32 tg Exp $
#
DISTNAME= python1.5
@@ -48,6 +48,7 @@ SETUP_LOCAL= Setup.tk
WITH_THREADS?= yes
.if exists(/usr/lib/libc_r.a) && defined(WITH_THREADS) && ${WITH_THREADS} == yes
CONFIGURE_ARGS+= --with-thread
+CFLAGS+= -D_THREAD_SAFE
.endif
#