aboutsummaryrefslogtreecommitdiff
path: root/lang/rexx-regina/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-06-18 03:49:55 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-06-18 03:49:55 +0000
commit6928fccd693fb0d12ee8abbd929c96e9e3744a39 (patch)
tree9e6052da51bbb139898b0ce2bd5aab5c6e7617e1 /lang/rexx-regina/Makefile
parent52173306855b7d6bfa7be70566cabdb2f3c06e8a (diff)
downloadports-6928fccd693fb0d12ee8abbd929c96e9e3744a39.tar.gz
ports-6928fccd693fb0d12ee8abbd929c96e9e3744a39.zip
- Update to 3.8
PR: 191095
Notes
Notes: svn path=/head/; revision=358203
Diffstat (limited to 'lang/rexx-regina/Makefile')
-rw-r--r--lang/rexx-regina/Makefile35
1 files changed, 21 insertions, 14 deletions
diff --git a/lang/rexx-regina/Makefile b/lang/rexx-regina/Makefile
index 9f3f72a8215c..3c83180bc04e 100644
--- a/lang/rexx-regina/Makefile
+++ b/lang/rexx-regina/Makefile
@@ -2,34 +2,41 @@
# $FreeBSD$
PORTNAME= regina
-PORTVERSION= 3.7
+PORTVERSION= 3.8
CATEGORIES= lang
MASTER_SITES= SF/${PORTNAME}-rexx/${PORTNAME}-rexx/${PORTVERSION}
PKGNAMEPREFIX= rexx-
DISTNAME= Regina-REXX-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A Rexx interpreter
+COMMENT= Rexx interpreter
-CONFLICTS= rexx-imc-* oorexx-[0-9]*
+LICENSE= LGPL21 # (or later)
-USE_OPENSSL= yes
+USES= gmake iconv
+USE_RC_SUBR= rxstack
GNU_CONFIGURE= yes
-USES= gmake
+CONFIGURE_ENV= ac_cv_c_char_unsigned=yes
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
-USE_RC_SUBR= rxstack
-post-patch:
- @${REINPLACE_CMD} -e "s|-pthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
+DATADIR= ${PREFIX}/share/Regina-REXX
-post-configure:
- @${REINPLACE_CMD} -e "s|-xchar=unsigned||g" ${WRKSRC}/Makefile
+CONFLICTS= rexx-imc-[0-0]* oorexx-[0-9]*
-.include <bsd.port.pre.mk>
+BROKEN_powerpc= Does not link on powerpc
-.if ${ARCH} == "powerpc"
-BROKEN= Does not link on powerpc
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == i386
+CONFIGURE_ARGS+= --enable-32bit
.endif
-.include <bsd.port.post.mk>
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/$${CFLAGS}/s|^|#| ; \
+ s|"-lpthread"|"-pthread"|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ '/$$(sysconfdir)/s|^|#|' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>