aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby16_static
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-01-29 09:19:45 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-01-29 09:19:45 +0000
commit310947301967ef18b865110fb86c32183db76f13 (patch)
tree013939f6fa8fc66d5c6f89e2ef324bf2510de269 /lang/ruby16_static
parent29ab188f02685b2100a6ea8e8b013aa28300f68e (diff)
downloadports-310947301967ef18b865110fb86c32183db76f13.tar.gz
ports-310947301967ef18b865110fb86c32183db76f13.zip
Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;
the ECHO macro is set to "echo" by default, but it is set to "true" if make(1) is invoked with the -s option while ECHO_CMD is always set to the echo command.
Notes
Notes: svn path=/head/; revision=53946
Diffstat (limited to 'lang/ruby16_static')
-rw-r--r--lang/ruby16_static/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/ruby16_static/Makefile b/lang/ruby16_static/Makefile
index 8b0fffe75c24..bf17e78ff910 100644
--- a/lang/ruby16_static/Makefile
+++ b/lang/ruby16_static/Makefile
@@ -80,9 +80,9 @@ do-extract:
${CP} -RPp $$extdir ${WRKSRC}/ext/
.endfor
.if defined(STATIC)
- ${ECHO} "option nodynamic" > ${WRKSRC}/ext/Setup
+ ${ECHO_CMD} "option nodynamic" > ${WRKSRC}/ext/Setup
.else
- ${ECHO} "#option nodynamic" > ${WRKSRC}/ext/Setup
+ ${ECHO_CMD} "#option nodynamic" > ${WRKSRC}/ext/Setup
.endif
(cd ${WRKSRC}/ext && \
for x in *; do [ -d $$x ] && echo $$x >> Setup; done)