aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby18
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-02-18 11:24:59 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-02-18 11:24:59 +0000
commit54af146904c6bfaf435dd0e716b6ead7e06682c1 (patch)
tree3ae1f777cbb741bb39cad40a3c1655fd2e884ac9 /lang/ruby18
parent5b505bcf4327c1da8075d0d9aebe32e5f0c51f8b (diff)
downloadports-54af146904c6bfaf435dd0e716b6ead7e06682c1.tar.gz
ports-54af146904c6bfaf435dd0e716b6ead7e06682c1.zip
Touch configure in the pre-configure stage lest the timestamp of
configure.in be ahead of that of configure and autoconf thus be demanded. Submitted: kris, bento
Notes
Notes: svn path=/head/; revision=75796
Diffstat (limited to 'lang/ruby18')
-rw-r--r--lang/ruby18/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index baa79ab69494..2681751fbffc 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -104,12 +104,12 @@ post-extract:
${MV} ${WRKSRC}/ext/dl/h2rb ${WRKSRC}/bin/
post-patch:
- ${FIND} ${WRKSRC} -name '*.orig' -delete
+ ${FIND} ${PATCH_WRKSRC} -name '*.orig' -delete
.for d in Win32API
- ${RM} -rf ${WRKSRC}/ext/${d}
+ ${RM} -rf ${BUILD_WRKSRC}/ext/${d}
.endfor
.for d in gdbm iconv tcltklib tk
- ${MV} ${WRKSRC}/ext/${d} ${WRKDIR}/
+ ${MV} ${BUILD_WRKSRC}/ext/${d} ${WRKDIR}/
.endfor
pre-configure:
@@ -118,6 +118,7 @@ pre-configure:
./configure; \
${MAKE} -f Makefile ${RUBY_VER:S/.//} RUBYDIR=${WRKSRC}
.endif
+ ${TOUCH} ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
post-install:
.if defined(STRIP) && ${STRIP} == -s