aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby18
diff options
context:
space:
mode:
authorAndrey Slusar <anray@FreeBSD.org>2006-05-02 12:15:24 +0000
committerAndrey Slusar <anray@FreeBSD.org>2006-05-02 12:15:24 +0000
commitdbfc1f7400708e5fac302149ee198caa60ef620e (patch)
tree937dcd7c3bc45f65b860ec62a46e433588e65d41 /lang/ruby18
parent7a83adbd4f679185cbf86fc9456c5ef8ec345c06 (diff)
downloadports-dbfc1f7400708e5fac302149ee198caa60ef620e.tar.gz
ports-dbfc1f7400708e5fac302149ee198caa60ef620e.zip
Wrong type of integer argument to ioctl(2) cause ruby18 to produce lots
of sign-extension noises through console / kernel log on FreeBSD/amd64. PR: ports/94088 Submitted by: ariff
Notes
Notes: svn path=/head/; revision=161190
Diffstat (limited to 'lang/ruby18')
-rw-r--r--lang/ruby18/Makefile2
-rw-r--r--lang/ruby18/files/patch-io.c22
2 files changed, 23 insertions, 1 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index a65b19786f91..ff1eb90b9b62 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ruby
PORTVERSION= ${RUBY_PORTVERSION}
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 1
CATEGORIES= lang ruby ipv6
MASTER_SITES= ${MASTER_SITE_RUBY}
diff --git a/lang/ruby18/files/patch-io.c b/lang/ruby18/files/patch-io.c
new file mode 100644
index 000000000000..2d26a4634ec0
--- /dev/null
+++ b/lang/ruby18/files/patch-io.c
@@ -0,0 +1,22 @@
+--- io.c.orig Thu Mar 2 22:15:47 2006
++++ io.c Thu Mar 2 22:16:58 2006
+@@ -4682,8 +4682,9 @@
+ #if !defined(MSDOS) && !defined(__human68k__)
+ static int
+ io_cntl(fd, cmd, narg, io_p)
+- int fd, cmd, io_p;
++ int fd, io_p;
+ long narg;
++ unsigned long cmd;
+ {
+ int retval;
+
+@@ -4713,7 +4714,7 @@
+ int io_p;
+ {
+ #if !defined(MSDOS) && !defined(__human68k__)
+- int cmd = NUM2ULONG(req);
++ unsigned long cmd = NUM2ULONG(req);
+ OpenFile *fptr;
+ long len = 0;
+ long narg = 0;