aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby19
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-01-11 22:05:13 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-01-11 22:05:13 +0000
commitf0bbc5549847636f4855a852391d983d21ba36b9 (patch)
tree59e939c7f40e98b12bb2925e7f40b77cf109f817 /lang/ruby19
parentb7899c7f1914fe429a1cb3ad0d80697907d811df (diff)
downloadports-f0bbc5549847636f4855a852391d983d21ba36b9.tar.gz
ports-f0bbc5549847636f4855a852391d983d21ba36b9.zip
- update remaining ruby@ maintained ports to new options framework
- trim historical header where applicable Reviewed by: swills@ (ruby@)
Notes
Notes: svn path=/head/; revision=310250
Diffstat (limited to 'lang/ruby19')
-rw-r--r--lang/ruby19/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/lang/ruby19/Makefile b/lang/ruby19/Makefile
index cd18d92ef063..7b368496edd4 100644
--- a/lang/ruby19/Makefile
+++ b/lang/ruby19/Makefile
@@ -44,8 +44,9 @@ MAKE_JOBS_UNSAFE= yes
NO_LATEST_LINK= yes
-OPTIONS= RDOC "Build and install Rdoc indexes" off \
- DEBUG "Compile-in debug info" off
+OPTIONS_DEFINE= RDOC DEBUG
+RDOC_DESC= Build and install Rdoc indexes
+DEBUG_DESC= Compile-in debug info
.include <bsd.port.pre.mk>
@@ -66,7 +67,7 @@ LDFLAGS+= ${PTHREAD_LIBS} # libraries dependent op libpthread.
#
# Disable doc generation if requested or docs disabled at all
#
-.if defined(WITH_RDOC) && !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MRDOC} && ${PORT_OPTIONS:MDOCS}
CONFIGURE_ARGS+= --enable-install-doc
.else
CONFIGURE_ARGS+= --disable-install-doc
@@ -180,7 +181,7 @@ post-install:
. endfor
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
# Create all dirs required (":u" isn't avaiable in STABLE yet :-()
${MKDIR} ${EXTSAMPLES:C,^([^/]+)/.*,\1,:S,^,${RUBY_EXAMPLESDIR}/,}
${MKDIR} ${EXTDOCS:C,^([^/]+)/.*,\1,:S,^,${RUBY_DOCDIR}/,}