aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby22
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:08:37 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:08:37 +0000
commita9dcad2fffcc27906b85c5a15fdb3e50fdc1e2e2 (patch)
tree23607acdfffe977946d3c7bb877bab60e64640e7 /lang/ruby22
parent4e1b79a0a61f4973df8b4b0864d22086c769e219 (diff)
downloadports-a9dcad2fffcc27906b85c5a15fdb3e50fdc1e2e2.tar.gz
ports-a9dcad2fffcc27906b85c5a15fdb3e50fdc1e2e2.zip
Remove ${PORTSDIR}/ from dependencies, categories h, i, j, k, and l.
With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=412347
Diffstat (limited to 'lang/ruby22')
-rw-r--r--lang/ruby22/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/lang/ruby22/Makefile b/lang/ruby22/Makefile
index 2c136ffbbf46..b396d6ad0e5e 100644
--- a/lang/ruby22/Makefile
+++ b/lang/ruby22/Makefile
@@ -19,9 +19,9 @@ LICENSE_FILE_BSD2CLAUSE=${WRKSRC}/BSDL
LICENSE_FILE_RUBY= ${WRKSRC}/COPYING
# Using LIB_DEPENDS finds the libffi from gcc which causes problems
-BUILD_DEPENDS= libffi>=0:${PORTSDIR}/devel/libffi
-LIB_DEPENDS= libyaml.so:${PORTSDIR}/textproc/libyaml
-RUN_DEPENDS= libffi>=0:${PORTSDIR}/devel/libffi
+BUILD_DEPENDS= libffi>=0:devel/libffi
+LIB_DEPENDS= libyaml.so:textproc/libyaml
+RUN_DEPENDS= libffi>=0:devel/libffi
CONFIGURE_ARGS= ${RUBY_CONFIGURE_ARGS} \
--disable-rpath \
@@ -60,17 +60,17 @@ RDOC_DESC= Build and install Rdoc indexes
EDIT_DESC= Which line editing lib to use
LIBEDIT_DESC= Use libedit
READLINE_DESC= Use libreadline
-CAPIDOCS_BUILD_DEPENDS= doxygen>0:${PORTSDIR}/devel/doxygen \
- dot:${PORTSDIR}/graphics/graphviz
+CAPIDOCS_BUILD_DEPENDS= doxygen>0:devel/doxygen \
+ dot:graphics/graphviz
CAPIDOCS_CONFIGURE_ENABLE= install-capi
GMP_CONFIGURE_WITH= gmp
-GMP_LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
+GMP_LIB_DEPENDS= libgmp.so:math/gmp
LIBEDIT_CONFIGURE_ON= --enable-libedit --with-libedit-dir=${LOCALBASE}
LIBEDIT_USES= libedit
RDOC_CONFIGURE_ENABLE= install-rdoc
-READLINE_BUILD_DEPENDS= readline>=0:${PORTSDIR}/devel/readline
+READLINE_BUILD_DEPENDS= readline>=0:devel/readline
READLINE_CONFIGURE_ON= --disable-libedit --with-readline-dir=${LOCALBASE}
-READLINE_RUN_DEPENDS= readline>=0:${PORTSDIR}/devel/readline
+READLINE_RUN_DEPENDS= readline>=0:devel/readline
CPE_VENDOR= ruby-lang
CPE_VERSION= ${RUBY_RELVERSION}