aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-08-15 19:53:08 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-08-15 19:53:08 +0000
commit1a7fa933db5ace4b98b222d064642c0b3dafccec (patch)
treeeb25bc70a1db100bdb7fd5182834323551a66c7a /lang/ruby
parent583984e19bb536ae0b3fe9f33570eb15bb58a93e (diff)
downloadports-1a7fa933db5ace4b98b222d064642c0b3dafccec.tar.gz
ports-1a7fa933db5ace4b98b222d064642c0b3dafccec.zip
Install Emacs Lisp files (*.el) to share/emacs/site-lisp/ and
lib/xemacs/site-lisp so Emacs/XEmacs can easily find them to load. Instruct users how to use them.
Notes
Notes: svn path=/head/; revision=31672
Diffstat (limited to 'lang/ruby')
-rw-r--r--lang/ruby/Makefile11
-rw-r--r--lang/ruby/pkg-message22
-rw-r--r--lang/ruby/pkg-plist8
3 files changed, 41 insertions, 0 deletions
diff --git a/lang/ruby/Makefile b/lang/ruby/Makefile
index 8cb8924bb6d4..5ed40558ffcc 100644
--- a/lang/ruby/Makefile
+++ b/lang/ruby/Makefile
@@ -32,6 +32,11 @@ BRANCH_NAME= 1.4
DOCDIR= ${PREFIX}/share/doc/ruby
EXAMPLESDIR= ${PREFIX}/share/examples/ruby
+ELISP_FILES= inf-ruby.el ruby-mode.el rubydb3x.el
+
+EMACSLISPDIR= ${PREFIX}/share/emacs/site-lisp
+XEMACSLISPDIR= ${PREFIX}/lib/xemacs/site-lisp
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 400014
@@ -50,6 +55,12 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/sample/* ${EXAMPLESDIR}
${MKDIR} ${EXAMPLESDIR}/misc
${INSTALL_DATA} ${WRKSRC}/misc/* ${EXAMPLESDIR}/misc
+ ${MKDIR} ${EMACSLISPDIR}
+ ${MKDIR} ${XEMACSLISPDIR}
+.for f in ${ELISP_FILES}
+ ${LN} -sf ${EXAMPLESDIR}/misc/${f} ${EMACSLISPDIR}/
+ ${LN} -sf ${EXAMPLESDIR}/misc/${f} ${XEMACSLISPDIR}/
+.endfor
${MKDIR} ${EXAMPLESDIR}/curses
${INSTALL_DATA} ${WRKSRC}/ext/curses/hello.rb ${WRKSRC}/ext/curses/rain.rb ${WRKSRC}/ext/curses/view.rb ${EXAMPLESDIR}/curses
${MKDIR} ${EXAMPLESDIR}/pty
diff --git a/lang/ruby/pkg-message b/lang/ruby/pkg-message
index 564cf52f2485..743115d2f064 100644
--- a/lang/ruby/pkg-message
+++ b/lang/ruby/pkg-message
@@ -1,4 +1,26 @@
====
+To use ruby-mode, inf-ruby and rubydb in Emacs/XEmacs, add the
+following lines to your ~/.emacs:
+
+;; Taken from the comment section in inf-ruby.el
+
+(setq ruby-program-name "/usr/local/bin/ruby")
+
+(autoload 'ruby-mode "ruby-mode"
+ "Mode for editing ruby source files")
+(add-to-list 'auto-mode-alist '("\\.rb$" . ruby-mode))
+(add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
+
+(autoload 'run-ruby "inf-ruby"
+ "Run an inferior Ruby process")
+(autoload 'inf-ruby-keys "inf-ruby"
+ "Set local key defs for inf-ruby in ruby-mode")
+(add-hook 'ruby-mode-hook
+ '(lambda ()
+ (inf-ruby-keys)
+ ))
+
+====
NOTE: This package does NOT contain irb (the interactive Ruby)
and Ruby/Tk (an interface to Tk GUI toolkits); You need to
install separate packages to use them.
diff --git a/lang/ruby/pkg-plist b/lang/ruby/pkg-plist
index e4eb7b019122..88a53e321aaf 100644
--- a/lang/ruby/pkg-plist
+++ b/lang/ruby/pkg-plist
@@ -174,3 +174,11 @@ share/examples/ruby/pty/shl.rb
@dirrm share/examples/ruby/curses
@dirrm share/examples/ruby/pty
@dirrm share/examples/ruby
+share/emacs/site-lisp/inf-ruby.el
+share/emacs/site-lisp/ruby-mode.el
+share/emacs/site-lisp/rubydb3x.el
+lib/xemacs/site-lisp/inf-ruby.el
+lib/xemacs/site-lisp/ruby-mode.el
+lib/xemacs/site-lisp/rubydb3x.el
+@unexec rmdir -p %D/share/emacs/site-lisp 2>/dev/null || true
+@unexec rmdir -p %D/lib/xemacs/site-lisp 2>/dev/null || true