aboutsummaryrefslogtreecommitdiff
path: root/lang/sbcl/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-10-08 18:21:19 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-10-08 18:21:19 +0000
commita78a2ee16ea74ec727f58f63578cd273b7eb165a (patch)
tree3ecf9a95c474f932d5bccde52c69962a83a0590c /lang/sbcl/Makefile
parent1463bafedaf3522aa1f281a0163ae3593ea07063 (diff)
downloadports-a78a2ee16ea74ec727f58f63578cd273b7eb165a.tar.gz
ports-a78a2ee16ea74ec727f58f63578cd273b7eb165a.zip
- Update to 0.9.5
PR: ports/87123 Submitted by: Paul Ledbetter <aeacides@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=144591
Diffstat (limited to 'lang/sbcl/Makefile')
-rw-r--r--lang/sbcl/Makefile27
1 files changed, 23 insertions, 4 deletions
diff --git a/lang/sbcl/Makefile b/lang/sbcl/Makefile
index ef23f1882982..628bdbdea792 100644
--- a/lang/sbcl/Makefile
+++ b/lang/sbcl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sbcl
-PORTVERSION= 0.8.17
+PORTVERSION= 0.9.5
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sbcl
@@ -36,6 +36,16 @@ ONLY_FOR_ARCHS= i386
MAN1= sbcl.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502124
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-contrib_asdf-install_installer.lisp
+.endif
+
+.if ${OSVERSION} >= 600022
+BUILD_DEPENDS+= gtar:${PORTSDIR}/archivers/gtar
+.endif
+
post-extract:
(${FIND} ${WRKSRC} -type d -name CVS -print0 | ${XARGS} -0 ${RM} -rf)
@@ -47,9 +57,18 @@ do-install:
MAN_DIR=${PREFIX}/man DOC_DIR=${DOCSDIR} \
INFO_DIR=${DOCSDIR}/info NO_DOCS=${NO_DOCS} \
${SH} install.sh)
-.if defined(NOPORTDOCS)
# sbcl creates these directories even when they're not needed
- ${RMDIR} ${DOCSDIR}/html ${DOCSDIR}/info
+.if defined(NOPORTDOCS)
+ ${RMDIR} ${DOCSDIR}/html
.endif
+ # we do not build the documentation
+ # perhaps this should be configurable
+ ${RMDIR} ${DOCSDIR}/info
+
+test:
+ (cd ${WRKSRC}/tests && ${SH} run-tests.sh)
+
+post-patch:
+ ${FIND} ${WRKSRC} -name '*.orig' -delete
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>