aboutsummaryrefslogtreecommitdiff
path: root/lang/scala/Makefile
diff options
context:
space:
mode:
authorJulien Laffaye <jlaffaye@FreeBSD.org>2011-06-09 13:29:58 +0000
committerJulien Laffaye <jlaffaye@FreeBSD.org>2011-06-09 13:29:58 +0000
commita8e515d775d6f6d7bfd38742e8c49c24720cb467 (patch)
tree2df5638a6627d097c9e1ae9e2c60ed4a6b8fa91c /lang/scala/Makefile
parentf92f96a2244ddfab70588c5277006fc57ec46021 (diff)
downloadports-a8e515d775d6f6d7bfd38742e8c49c24720cb467.tar.gz
ports-a8e515d775d6f6d7bfd38742e8c49c24720cb467.zip
Update to 2.9.0.1
Fix the do-install target to not install temporary files. While I am here, use for loops and COPYTREE_SHARE instead of find. PR: ports/157705 Submitted by: Mitsuru YOSHIDA <mitsururike@gmail.com> (maintainer) Approved by: bapt (mentor)
Notes
Notes: svn path=/head/; revision=275276
Diffstat (limited to 'lang/scala/Makefile')
-rw-r--r--lang/scala/Makefile42
1 files changed, 25 insertions, 17 deletions
diff --git a/lang/scala/Makefile b/lang/scala/Makefile
index f8f127d2e3ca..99c749290ec4 100644
--- a/lang/scala/Makefile
+++ b/lang/scala/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= scala
-PORTVERSION= 2.8.1
-DISTVERSIONSUFFIX= .final
+PORTVERSION= 2.9.0.1
CATEGORIES= lang java
MASTER_SITES= http://www.scala-lang.org/downloads/distrib/files/ \
LOCAL/glarkin
@@ -16,6 +15,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= mitsururike@gmail.com
COMMENT= The Scala Programming Language
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+
NO_BUILD= yes
USE_JAVA= yes
JAVA_VERSION= 1.5+
@@ -24,6 +25,13 @@ MAN1= fsc.1 sbaz.1 scala.1 scalac.1 scaladoc.1 scalap.1
SCALA_HOME?= ${PREFIX}/share/${PORTNAME}-${PORTVERSION}
SCALA_SHRDIRS= lib meta misc
+SCALA_BINS= fsc \
+ sbaz \
+ sbaz-setup \
+ scala \
+ scalac \
+ scaladoc \
+ scalap
PLIST_SUB+= PORTNAME=${PORTNAME} PORTVERSION=${PORTVERSION}
@@ -33,25 +41,25 @@ pre-patch:
@${ECHO_MSG} "Installation settings:"
@${ECHO_MSG} " SCALA_HOME: ${SCALA_HOME}"
+post-patch:
+.for f in ${SCALA_BINS}
+ @${REINPLACE_CMD} 's|^#!/bin/bash|#!${LOCALBASE}/bin/bash|' \
+ ${WRKSRC}/bin/${f}
+.endfor
+
do-install:
@${ECHO_MSG} ">> Installing Scala files..."
@${INSTALL} -d ${SCALA_HOME}/bin
- @cd ${WRKSRC}/bin \
- && ${FIND} . -perm 755 -type f -exec ${INSTALL_SCRIPT} {} \
- ${SCALA_HOME}/bin/{} \;
-.for target in ${SCALA_SHRDIRS}
- @cd ${WRKSRC}/${target} \
- && ${FIND} . -type d -exec ${INSTALL} -d ${SCALA_HOME}/${target}/{} \; \
- && ${FIND} . -type f -exec ${INSTALL_DATA} {} \
- ${SCALA_HOME}/${target}/{} \;
+.for f in ${SCALA_BINS}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/${f} ${SCALA_HOME}/bin/${f}
+ ${LN} -s ${SCALA_HOME}/${f} ${PREFIX}/bin/${f}
+.endfor
+.for d in ${SCALA_SHRDIRS}
+ @cd ${WRKSRC}/${d} && ${COPYTREE_SHARE} . ${SCALA_HOME}/${d}
+.endfor
+.for m in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/man/man1/${m} ${MANPREFIX}/man/man1/${m}
.endfor
- @cd ${WRKSRC}/man/man1 \
- && ${FIND} . -type f -exec ${INSTALL_MAN} {} \
- ${MANPREFIX}/man/man1/{} \;
- @${ECHO_MSG} ">> Installing symlinks in ${PREFIX}/bin..."
- @cd ${SCALA_HOME}/bin \
- && ${FIND} . -type f -exec ${LN} -s ${SCALA_HOME}/bin/{} \
- ${PREFIX}/bin/{} \;
.if !defined(NOPORTDOCS)
@${ECHO_MSG} ">> Installing documentation files..."