aboutsummaryrefslogtreecommitdiff
path: root/lang/squeak
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-07-30 08:03:08 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-07-30 08:03:08 +0000
commit984457601c094ff805986e1b445d524267304329 (patch)
treed6db16f4a8b587f62bde40d054a9907d554acef3 /lang/squeak
parent2758b97b1539e49f232dca35770aa1844eb96988 (diff)
downloadports-984457601c094ff805986e1b445d524267304329.tar.gz
ports-984457601c094ff805986e1b445d524267304329.zip
- Stagify, sort the knobs, remove excessive whitespace and bogus comments
- Employ USE_GSTREAMER knob instead of depending on libgstreamer.so - Use consistent separators in patch files (this also deuglifies them) PR: 192234
Notes
Notes: svn path=/head/; revision=363453
Diffstat (limited to 'lang/squeak')
-rw-r--r--lang/squeak/Makefile132
-rw-r--r--lang/squeak/files/patch-unix_plugins_CameraPlugin_sqCamera-linux.c (renamed from lang/squeak/files/patch-unix__plugins_CameraPlugin_sqCamera-linux.c)0
-rw-r--r--lang/squeak/files/patch-unix_plugins_ScratchPlugin_unixSeriaPort2Ops.c (renamed from lang/squeak/files/patch-unix__plugins_ScratchPlugin_unixSeriaPort2Ops.c)0
-rw-r--r--lang/squeak/files/patch-unix_plugins_SerialPlugin_sqUnixSerial.c (renamed from lang/squeak/files/patch-unix__plugins_SerialPlugin_sqUnixSerial.c)0
-rw-r--r--lang/squeak/files/patch-unix_plugins_UUIDPlugin_config.cmake (renamed from lang/squeak/files/patch-unix__plugins_UUIDPlugin_config.cmake)0
-rw-r--r--lang/squeak/files/patch-unix_vm_build.cmake (renamed from lang/squeak/files/patch-unix__vm__build.cmake)0
-rw-r--r--lang/squeak/pkg-plist1
7 files changed, 59 insertions, 74 deletions
diff --git a/lang/squeak/Makefile b/lang/squeak/Makefile
index 073967ef830d..6e2fa0a15640 100644
--- a/lang/squeak/Makefile
+++ b/lang/squeak/Makefile
@@ -1,103 +1,87 @@
-# Created by: roland.jesse@gmx.net
+# Created by: Roland Jesse <roland.jesse@gmx.net>
# $FreeBSD$
-PORTNAME= squeak
-PORTVERSION= 4.10.2
-CATEGORIES= lang
-##################################################
-MASTER_SITES= http://www.squeakvm.org/unix/release/:vmsrc \
- http://ftp.squeak.org/${IMAGEVERSION}/:src \
- ftp://squeak.org/4.1/:sqsrc \
- http://squeak.610t.org/patches/:mainsrc
-DISTFILES= Squeak-${VM_VERSION}-src${EXTRACT_SUFX}:vmsrc \
- Squeak${IMAGEVERSION}.zip:src \
- ${SQUEAK_SRC}.gz:sqsrc
-EXTRACT_ONLY= Squeak-${VM_VERSION}-src${EXTRACT_SUFX}
+PORTNAME= squeak
+PORTVERSION= 4.10.2
+CATEGORIES= lang
+MASTER_SITES= http://www.squeakvm.org/unix/release/:vmsrc \
+ http://ftp.squeak.org/${IMAGE_VERSION}/:src \
+ ftp://squeak.org/4.1/:sqsrc \
+ http://squeak.610t.org/patches/:mainsrc
+DISTFILES= Squeak-${VM_VERSION}-src${EXTRACT_SUFX}:vmsrc \
+ Squeak${IMAGE_VERSION}.zip:src \
+ ${SQUEAK_SRC}.gz:sqsrc
+EXTRACT_ONLY= Squeak-${VM_VERSION}-src${EXTRACT_SUFX}
+DIST_SUBDIR= squeak
-##################################################
MAINTAINER= ports@FreeBSD.org
-COMMENT= Full Smalltalk 80 with portability to UNIX, Mac, and Windows
+COMMENT= Full Smalltalk 80 with portability to Unix, Mac, and Windows
-LICENSE= APACHE20 MIT
-LICENSE_COMB= multi
+LICENSE= APACHE20 MIT
+LICENSE_COMB= multi
# Don't set USE_ZIP as this breaks EXTRACT_CMD.
-BUILD_DEPENDS= ${UNZIP_CMD}:${PORTSDIR}/archivers/unzip \
- cmake:${PORTSDIR}/devel/cmake \
- v4l_compat>=1.0.20120501:${PORTSDIR}/multimedia/v4l_compat
-LIB_DEPENDS= libaudio.so:${PORTSDIR}/audio/nas \
- libffi.so:${PORTSDIR}/devel/libffi \
- libasound.so:${PORTSDIR}/audio/alsa-lib \
- libpulse-simple.so:${PORTSDIR}/audio/pulseaudio \
- libgstreamer.so:${PORTSDIR}/multimedia/gstreamer \
- libv4l2.so:${PORTSDIR}/multimedia/libv4l
+BUILD_DEPENDS= ${UNZIP_CMD}:${PORTSDIR}/archivers/unzip \
+ cmake:${PORTSDIR}/devel/cmake \
+ v4l_compat>=1.0.20120501:${PORTSDIR}/multimedia/v4l_compat
+LIB_DEPENDS= libaudio.so:${PORTSDIR}/audio/nas \
+ libffi.so:${PORTSDIR}/devel/libffi \
+ libasound.so:${PORTSDIR}/audio/alsa-lib \
+ libpulse-simple.so:${PORTSDIR}/audio/pulseaudio \
+ libv4l2.so:${PORTSDIR}/multimedia/libv4l
+
+ONLY_FOR_ARCHS= i386 amd64 powerpc
+
+USES= pkgconfig
+USE_GCC= any
+USE_GL= gl
+HAS_CONFIGURE= yes
+USE_GSTREAMER= yes
+VM_VERSION= ${PORTVERSION}.${SVN_VERSION}
+SVN_VERSION= 2614
+IMAGE_VERSION= 4.3
+SQUEAK_SRC= SqueakV41.sources
+SQUEAK_LIB_DIR= ${PORTVERSION}-${SVN_VERSION}
-##################################################
-VM_VERSION= ${PORTVERSION}.${SVNVERSION}
-SVNVERSION= 2614
-IMAGEVERSION= 4.3
-SQUEAK_SRC= SqueakV41.sources
-SQUEAK_LIB_DIR= ${PORTVERSION}-${SVNVERSION}
-USES= pkgconfig
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-##################################################
-DIST_SUBDIR= squeak
-ONLY_FOR_ARCHS= i386 amd64 powerpc
-MAN1= squeak.1
-USE_GCC= any
-USE_GL= gl
-HAS_CONFIGURE= yes
-
-# Plugin image must be writable, because of it copy to user's ~/.npsqueak/ and
-# be updated.
-SHAREMODE= 644
-
-# shared Libaries are to be installed in:
-LDCONFIG_DIRS= ${PREFIX}/lib/squeak/${VM_VERSION}
-
-IMAGES= Squeak${IMAGEVERSION}/Squeak${IMAGEVERSION}.image \
- Squeak${IMAGEVERSION}/Squeak${IMAGEVERSION}.changes
-
-##################################################
-# Configure and Build
WRKSRC= ${WRKDIR}/Squeak-${VM_VERSION}-src
CONFIGURE_WRKSRC= ${WRKSRC}/build
BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
CONFIGURE_SCRIPT= ../unix/cmake/configure
-CONFIGURE_ARGS+= --prefix=${PREFIX}
-
+CONFIGURE_ARGS= --prefix=${PREFIX}
CMAKE_SOURCE_PATH= ../unix
-SUB_FILES= pkg-message
-SUB_LIST= SQUEAK_LIB_DIR=${SQUEAK_LIB_DIR}
+SUB_FILES= pkg-message
+SUB_LIST= SQUEAK_LIB_DIR=${SQUEAK_LIB_DIR}
+PLIST_SUB= SQUEAK_LIB_DIR=${SQUEAK_LIB_DIR}
+
+# Plugin image must be writable, because of it copy to user's ~/.npsqueak/ and
+# be updated.
+SHAREMODE= 644
+
+IMAGES= Squeak${IMAGE_VERSION}/Squeak${IMAGE_VERSION}.image \
+ Squeak${IMAGE_VERSION}/Squeak${IMAGE_VERSION}.changes
-PLIST_SUB= SQUEAK_LIB_DIR=${SQUEAK_LIB_DIR}
+.include <bsd.port.pre.mk>
-##################################################
post-patch:
-
# Fix utmp.h
.if ${OSVERSION} > 900007
- @${REINPLACE_CMD} \
- -e "s,<utmp.h>,<utmpx.h>,g" \
+ @${REINPLACE_CMD} -e 's,<utmp.h>,<utmpx.h>,' \
${WRKSRC}/unix/plugins/PseudoTTYPlugin/openpty.h
.endif
-##################################################
pre-configure:
@${MKDIR} ${CONFIGURE_WRKSRC}
-##################################################
post-install:
- ${GUNZIP_CMD} -c ${DISTDIR}/${DIST_SUBDIR}/${SQUEAK_SRC}.gz > ${WRKDIR}/${SQUEAK_SRC} && ${INSTALL_DATA} ${WRKDIR}/${SQUEAK_SRC} ${PREFIX}/lib/squeak/${SQUEAK_LIB_DIR}/
- (cd ${DISTDIR}/${DIST_SUBDIR} && ${UNZIP_CMD} -u Squeak${IMAGEVERSION}.zip -d ${WRKDIR})
-.for f in ${IMAGES}
- (cd ${WRKDIR} && ${INSTALL_DATA} ${f} ${PREFIX}/lib/squeak/)
-.endfor
- @${CAT} ${PKGMESSAGE}
+ ${GUNZIP_CMD} -c ${DISTDIR}/${DIST_SUBDIR}/${SQUEAK_SRC}.gz > \
+ ${WRKDIR}/${SQUEAK_SRC} && ${INSTALL_DATA} \
+ ${WRKDIR}/${SQUEAK_SRC} \
+ ${STAGEDIR}${PREFIX}/lib/squeak/${SQUEAK_LIB_DIR}
+ (cd ${DISTDIR}/${DIST_SUBDIR} && ${UNZIP_CMD} -u \
+ Squeak${IMAGE_VERSION}.zip -d ${WRKDIR})
+ ${INSTALL_DATA} ${IMAGES:S,^,${WRKDIR}/,} \
+ ${STAGEDIR}${PREFIX}/lib/squeak
.include <bsd.port.post.mk>
diff --git a/lang/squeak/files/patch-unix__plugins_CameraPlugin_sqCamera-linux.c b/lang/squeak/files/patch-unix_plugins_CameraPlugin_sqCamera-linux.c
index 20bd0fc2454e..20bd0fc2454e 100644
--- a/lang/squeak/files/patch-unix__plugins_CameraPlugin_sqCamera-linux.c
+++ b/lang/squeak/files/patch-unix_plugins_CameraPlugin_sqCamera-linux.c
diff --git a/lang/squeak/files/patch-unix__plugins_ScratchPlugin_unixSeriaPort2Ops.c b/lang/squeak/files/patch-unix_plugins_ScratchPlugin_unixSeriaPort2Ops.c
index becdc2f816ef..becdc2f816ef 100644
--- a/lang/squeak/files/patch-unix__plugins_ScratchPlugin_unixSeriaPort2Ops.c
+++ b/lang/squeak/files/patch-unix_plugins_ScratchPlugin_unixSeriaPort2Ops.c
diff --git a/lang/squeak/files/patch-unix__plugins_SerialPlugin_sqUnixSerial.c b/lang/squeak/files/patch-unix_plugins_SerialPlugin_sqUnixSerial.c
index 3d268d5806e7..3d268d5806e7 100644
--- a/lang/squeak/files/patch-unix__plugins_SerialPlugin_sqUnixSerial.c
+++ b/lang/squeak/files/patch-unix_plugins_SerialPlugin_sqUnixSerial.c
diff --git a/lang/squeak/files/patch-unix__plugins_UUIDPlugin_config.cmake b/lang/squeak/files/patch-unix_plugins_UUIDPlugin_config.cmake
index d5dd37d59798..d5dd37d59798 100644
--- a/lang/squeak/files/patch-unix__plugins_UUIDPlugin_config.cmake
+++ b/lang/squeak/files/patch-unix_plugins_UUIDPlugin_config.cmake
diff --git a/lang/squeak/files/patch-unix__vm__build.cmake b/lang/squeak/files/patch-unix_vm_build.cmake
index 5a940fc3c444..5a940fc3c444 100644
--- a/lang/squeak/files/patch-unix__vm__build.cmake
+++ b/lang/squeak/files/patch-unix_vm_build.cmake
diff --git a/lang/squeak/pkg-plist b/lang/squeak/pkg-plist
index fff2f180c304..cd462dd12685 100644
--- a/lang/squeak/pkg-plist
+++ b/lang/squeak/pkg-plist
@@ -31,5 +31,6 @@ lib/squeak/%%SQUEAK_LIB_DIR%%/squeakvm
lib/squeak/%%SQUEAK_LIB_DIR%%/SqueakV41.sources
lib/squeak/Squeak4.3.changes
lib/squeak/Squeak4.3.image
+man/man1/squeak.1.gz
@dirrm lib/squeak/%%SQUEAK_LIB_DIR%%
@dirrm lib/squeak