aboutsummaryrefslogtreecommitdiff
path: root/lang/squeak
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /lang/squeak
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'lang/squeak')
-rw-r--r--lang/squeak/Makefile5
-rw-r--r--lang/squeak/files/patch-platforms::unix::npsqueak::Makefile4
-rw-r--r--lang/squeak/files/patch-platforms::unix::npsqueak::npsqueakregister.in2
3 files changed, 5 insertions, 6 deletions
diff --git a/lang/squeak/Makefile b/lang/squeak/Makefile
index 21693c893085..5aac2af4344c 100644
--- a/lang/squeak/Makefile
+++ b/lang/squeak/Makefile
@@ -85,8 +85,8 @@ INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
CONFIGURE_SCRIPT= ../platforms/unix/config/configure
CONFIGURE_ARGS+= --libdir=${PREFIX}/share \
--without-quartz \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
- CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include"
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include"
# don't pass "-s" to install to avoid trying to strip a shell script
CONFIGURE_ENV=
@@ -163,7 +163,6 @@ PLIST_SUB= IMAGEVERSION=${IMAGEVERSION}\
post-patch:
@${REINPLACE_CMD} \
-e "s,%%LOCALBASE%%,${LOCALBASE},g" \
- -e "s,%%X11BASE%%,${X11BASE},g" \
${WRKSRC}/platforms/unix/npsqueak/npsqueakregister.in \
${WRKSRC}/platforms/unix/npsqueak/npsqueakrun.in \
${WRKSRC}/platforms/unix/npsqueak/Makefile
diff --git a/lang/squeak/files/patch-platforms::unix::npsqueak::Makefile b/lang/squeak/files/patch-platforms::unix::npsqueak::Makefile
index f8692044db87..d5def76a44c7 100644
--- a/lang/squeak/files/patch-platforms::unix::npsqueak::Makefile
+++ b/lang/squeak/files/patch-platforms::unix::npsqueak::Makefile
@@ -5,7 +5,7 @@
############ Customize flags here #######################
-INC = -I./include -I/usr/X11R6/include
-+INC = -I./include -I%%X11BASE%%/include
++INC = -I./include -I%%LOCALBASE%%/include
CC = gcc
CFLAGS = $(INC) -O2 -fPIC -Wall
LD = gcc
@@ -14,7 +14,7 @@
npsqueak.so : npsqueak.o npunix.o
- $(LD) $(LDFLAGS) npsqueak.o npunix.o -o npsqueak.so
-+ $(LD) $(LDFLAGS) npsqueak.o npunix.o -o npsqueak.so -L%%X11BASE%%/lib -lXt -lX11
++ $(LD) $(LDFLAGS) npsqueak.o npunix.o -o npsqueak.so -L%%LOCALBASE%%/lib -lXt -lX11
npsqueak.o: npsqueak.c ../config.h
$(CC) -c $(CFLAGS) -DVM_LIBDIR=\"$(VM_LIBDIR)\" $<
diff --git a/lang/squeak/files/patch-platforms::unix::npsqueak::npsqueakregister.in b/lang/squeak/files/patch-platforms::unix::npsqueak::npsqueakregister.in
index a4ba55ad46d4..a7bd917d2677 100644
--- a/lang/squeak/files/patch-platforms::unix::npsqueak::npsqueakregister.in
+++ b/lang/squeak/files/patch-platforms::unix::npsqueak::npsqueakregister.in
@@ -7,7 +7,7 @@
-BROWSERS="netscape mozilla mozilla-firefox opera MozillaFirefox/lib"
-BROWSER_DIRS="/usr/local/lib /usr/lib /opt"
+BROWSERS="netscape mozilla firefox opera seamonkey"
-+BROWSER_DIRS="%%X11BASE%%/lib %%X11BASE%%/share %%LOCALBASE%%/lib %%LOCALBASE%%/share /usr/lib"
++BROWSER_DIRS="%%LOCALBASE%%/lib %%LOCALBASE%%/share %%LOCALBASE%%/lib %%LOCALBASE%%/share /usr/lib"
SYSTEM_BROWSER_DIR="/usr/lib/browser-plugins"
ACTION=register