aboutsummaryrefslogtreecommitdiff
path: root/lang/stklos
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2005-04-06 19:29:24 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2005-04-06 19:29:24 +0000
commitc4cc2430851cfab4adb0121bc5b41919c73acfe6 (patch)
tree6cbc6149f43bd49bf35d226aa16d0cf88b21a8e2 /lang/stklos
parent63a3d19fecf40d37bf298112c9fee3cddccff45e (diff)
downloadports-c4cc2430851cfab4adb0121bc5b41919c73acfe6.tar.gz
ports-c4cc2430851cfab4adb0121bc5b41919c73acfe6.zip
- update stklos to 0.60
PR: based on 79449 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=132652
Diffstat (limited to 'lang/stklos')
-rw-r--r--lang/stklos/Makefile27
-rw-r--r--lang/stklos/distinfo4
-rw-r--r--lang/stklos/pkg-plist51
3 files changed, 47 insertions, 35 deletions
diff --git a/lang/stklos/Makefile b/lang/stklos/Makefile
index 03d492ddd52a..9909e07bff25 100644
--- a/lang/stklos/Makefile
+++ b/lang/stklos/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= stklos
-PORTVERSION= 0.58
+PORTVERSION= 0.60
CATEGORIES= lang scheme
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,26 +19,23 @@ LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4 \
ONLY_FOR_ARCHS= i386
+USE_GMAKE= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
- LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-gtk --disable-gnome
-PLIST_SUB= VERSION="${PORTVERSION}" \
- INFOSECTION="${INFOSECTION}" \
- INFOENTRY="${INFOENTRY}"
+PLIST_SUB= VERSION="${PORTVERSION}"
MAN1= stklos-compile.1 stklos-config.1 stklos-genlex.1 stklos.1
-INFOSECTION= The Algorithmic Language Scheme
-INFOENTRY= * STklos: (stklos). The successor of the STk Scheme interpreter
-
post-patch:
- ${REINPLACE_CMD} -e 's|share/man|man|' ${WRKSRC}/doc/Makefile.in
- ${REINPLACE_CMD} -e 's|^function ||' ${WRKSRC}/utils/stklos-config.in
-
-post-install:
- install-info --section="${INFOSECTION}" --entry="${INFOENTRY}" \
- ${PREFIX}/info/stklos.info ${PREFIX}/info/dir
+ @${REINPLACE_CMD} -e 's|share/man|man|' ${WRKSRC}/doc/Makefile.in
+ @${REINPLACE_CMD} -e 's|-@VERSION@||' ${WRKSRC}/doc/Makefile.in
+ @${REINPLACE_CMD} -e 's|^function ||' ${WRKSRC}/utils/stklos-config.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -E -e 's/^(install-data-am:).*/\1 install-man install-schemeDATA/' \
+ -e '/install-docpdfDATA install-man install-schemeDATA/d' \
+ ${WRKSRC}/doc/Makefile.in
+.endif
.include <bsd.port.mk>
diff --git a/lang/stklos/distinfo b/lang/stklos/distinfo
index 2f5362e71cbc..1dfaac050897 100644
--- a/lang/stklos/distinfo
+++ b/lang/stklos/distinfo
@@ -1,2 +1,2 @@
-MD5 (stklos-0.58.tar.gz) = 8ab599f6f0c51e9c1b9973b120d90ac2
-SIZE (stklos-0.58.tar.gz) = 2326160
+MD5 (stklos-0.60.tar.gz) = 976d611d5e7e3539c6bf878341869313
+SIZE (stklos-0.60.tar.gz) = 3213763
diff --git a/lang/stklos/pkg-plist b/lang/stklos/pkg-plist
index 0f6657e65642..98280660eb15 100644
--- a/lang/stklos/pkg-plist
+++ b/lang/stklos/pkg-plist
@@ -6,25 +6,8 @@ bin/stklos-script
include/stklos/extraconf.h
include/stklos/stklos.h
include/stklos/stklosconf.h
-@dirrm include/stklos
-@unexec install-info --delete --section="%%INFOSECTION%%" --entry="%%INFOENTRY%%" %D/info/stklos.info %D/info/dir
-info/stklos.info
-@unexec rm -f info/stklos.info-1
-@unexec rm -f info/stklos.info-2
-@unexec rm -f info/stklos.info-3
-@unexec rm -f info/stklos.info-4
-@unexec rm -f info/stklos.info-5
-@unexec rm -f info/stklos.info-6
-@exec install-info --section="%%INFOSECTION%%" --entry="%%INFOENTRY%%" %D/info/stklos.info %D/info/dir
lib/stklos/%%VERSION%%/ldap.so
-@dirrm lib/stklos/%%VERSION%%
-@dirrm lib/stklos
%%DATADIR%%/%%VERSION%%/DOCDB
-%%DATADIR%%/%%VERSION%%/Match/compiler.scm
-%%DATADIR%%/%%VERSION%%/Match/descr.scm
-%%DATADIR%%/%%VERSION%%/Match/mexpand.scm
-%%DATADIR%%/%%VERSION%%/Match/normalize.scm
-%%DATADIR%%/%%VERSION%%/Match/s2cfun.scm
%%DATADIR%%/%%VERSION%%/STklos.init
%%DATADIR%%/%%VERSION%%/assembler.stk
%%DATADIR%%/%%VERSION%%/bb.stk
@@ -48,6 +31,8 @@ lib/stklos/%%VERSION%%/ldap.so
%%DATADIR%%/%%VERSION%%/full-syntax.stk
%%DATADIR%%/%%VERSION%%/getopt.ostk
%%DATADIR%%/%%VERSION%%/getopt.stk
+%%DATADIR%%/%%VERSION%%/lalr.ostk
+%%DATADIR%%/%%VERSION%%/lalr.stk
%%DATADIR%%/%%VERSION%%/ldap.ostk
%%DATADIR%%/%%VERSION%%/ldap.stk
%%DATADIR%%/%%VERSION%%/lex-rt.ostk
@@ -63,6 +48,7 @@ lib/stklos/%%VERSION%%/ldap.so
%%DATADIR%%/%%VERSION%%/peephole.stk
%%DATADIR%%/%%VERSION%%/pp.ostk
%%DATADIR%%/%%VERSION%%/pp.stk
+%%DATADIR%%/%%VERSION%%/pragma.stk
%%DATADIR%%/%%VERSION%%/process.stk
%%DATADIR%%/%%VERSION%%/r5rs.stk
%%DATADIR%%/%%VERSION%%/regexp.stk
@@ -106,6 +92,35 @@ lib/stklos/%%VERSION%%/ldap.so
%%DATADIR%%/%%VERSION%%/struct.stk
%%DATADIR%%/%%VERSION%%/trace.ostk
%%DATADIR%%/%%VERSION%%/trace.stk
-@dirrm %%DATADIR%%/%%VERSION%%/Match
+%%DATADIR%%/%%VERSION%%/Match.d/compiler.scm
+%%DATADIR%%/%%VERSION%%/Match.d/descr.scm
+%%DATADIR%%/%%VERSION%%/Match.d/mexpand.scm
+%%DATADIR%%/%%VERSION%%/Match.d/normalize.scm
+%%DATADIR%%/%%VERSION%%/Match.d/s2cfun.scm
+%%PORTDOCS%%%%DOCSDIR%%/html/stklos-ref-1.html
+%%PORTDOCS%%%%DOCSDIR%%/html/stklos-ref-10.html
+%%PORTDOCS%%%%DOCSDIR%%/html/stklos-ref-11.html
+%%PORTDOCS%%%%DOCSDIR%%/html/stklos-ref-12.html
+%%PORTDOCS%%%%DOCSDIR%%/html/stklos-ref-13.html
+%%PORTDOCS%%%%DOCSDIR%%/html/stklos-ref-2.html
+%%PORTDOCS%%%%DOCSDIR%%/html/stklos-ref-3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/stklos-ref-4.html
+%%PORTDOCS%%%%DOCSDIR%%/html/stklos-ref-5.html
+%%PORTDOCS%%%%DOCSDIR%%/html/stklos-ref-6.html
+%%PORTDOCS%%%%DOCSDIR%%/html/stklos-ref-7.html
+%%PORTDOCS%%%%DOCSDIR%%/html/stklos-ref-8.html
+%%PORTDOCS%%%%DOCSDIR%%/html/stklos-ref-9.html
+%%PORTDOCS%%%%DOCSDIR%%/html/stklos-ref.html
+%%PORTDOCS%%%%DOCSDIR%%/html/doc-style.css
+%%PORTDOCS%%%%DOCSDIR%%/html/images/hierarchy.jpg
+%%PORTDOCS%%%%DOCSDIR%%/pdf/stklos-ref.pdf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/images
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/pdf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/%%VERSION%%/Match.d
@dirrm %%DATADIR%%/%%VERSION%%
@dirrm %%DATADIR%%
+@dirrm include/stklos
+@dirrm lib/stklos/%%VERSION%%
+@dirrm lib/stklos