aboutsummaryrefslogtreecommitdiff
path: root/lang/tclX/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2016-04-19 14:20:01 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2016-04-19 14:20:01 +0000
commit4e23c21fc178f53926a6fdce031c92cf22ece907 (patch)
tree14fe99943d56267ca815906c549d8a671245db05 /lang/tclX/Makefile
parentc1364a4b63589dc9afcb8aed2258c90b1fe957d6 (diff)
downloadports-4e23c21fc178f53926a6fdce031c92cf22ece907.tar.gz
ports-4e23c21fc178f53926a6fdce031c92cf22ece907.zip
Add "tea" argument to USES=tcl to facilitate porting of TEA-based extensions.
Quoting https://tcl.tk/doc/tea: "The Tcl Extension Architecture, or TEA, by John Ousterhout and others, is a set of guidelines and techniques for the distribution, configuration, compilation, and installation of Tcl extensions. TEA also provides a set of utilities that operate accordingly. Many Tcl extensions leverage the TEA utilities, which are designed to be easily customizable." To facilitate the porting of TEA-based extensions, I have added the new "tea" argument to USES=tcl. This argument prepares the autoconf environment by setting GNU_CONFIGURE and sets some commonly used CONFIGURE_ARGS. Also, it tries to figure out the correct extension name, sets TCL_PKG accordingly, and adds it to PLIST_SUB. I have modified a few ports to take advantage of this. More will come.
Notes
Notes: svn path=/head/; revision=413646
Diffstat (limited to 'lang/tclX/Makefile')
-rw-r--r--lang/tclX/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/lang/tclX/Makefile b/lang/tclX/Makefile
index 6570a5ee7f06..518efcc4fd41 100644
--- a/lang/tclX/Makefile
+++ b/lang/tclX/Makefile
@@ -17,13 +17,10 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
WRKSRC= ${WRKDIR}/${PORTNAME:tl}${PORTVERSION:R}
-USES= alias tcl tar:bzip2
+USES= autoreconf alias tcl:tea tar:bzip2
USE_LDCONFIG= ${PREFIX}/lib/tclx${PORTVERSION:R}
-USE_AUTOTOOLS= autoconf
-CONFIGURE_ARGS= --exec-prefix=${PREFIX} \
- --enable-shared \
- --with-help=Help \
- --with-tcl="${TCL_LIBDIR}"
+CONFIGURE_ARGS+=--enable-shared \
+ --with-help=Help
PLIST_SUB= TCLX_VER=${PORTVERSION:R}
ALL_TARGET= binaries libraries
INSTALL_TARGET= install-binaries install-libraries