aboutsummaryrefslogtreecommitdiff
path: root/lang/v8-devel/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-02-21 11:32:02 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-02-21 11:32:02 +0000
commitecbc057a70c9ece3cb0aeec63af131aa94cb256b (patch)
tree750873a7ab0c6d556e237eaedc7aa2c71163c774 /lang/v8-devel/Makefile
parent039218878aaed195d23e6833a23a4dd31bbf9ec4 (diff)
downloadports-ecbc057a70c9ece3cb0aeec63af131aa94cb256b.tar.gz
ports-ecbc057a70c9ece3cb0aeec63af131aa94cb256b.zip
- Use CXXFLAGS instead of CFLAGS
- Simplify CXXFLAGS: all supported Clang are 3.3+
Notes
Notes: svn path=/head/; revision=379502
Diffstat (limited to 'lang/v8-devel/Makefile')
-rw-r--r--lang/v8-devel/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/lang/v8-devel/Makefile b/lang/v8-devel/Makefile
index 4e3d6d3288b8..9590d91df436 100644
--- a/lang/v8-devel/Makefile
+++ b/lang/v8-devel/Makefile
@@ -33,16 +33,13 @@ bash_CMD= ${SH}
.include <bsd.port.pre.mk>
.if ${COMPILER_TYPE} == clang
-CFLAGS+= -Wno-unused-private-field -Wno-unused-variable
+CXXFLAGS+= -Wno-nested-anon-types -Wno-unused-function -Wno-unused-private-field -Wno-unused-variable
MAKE_ARGS+= clang=on
MAKE_ENV+= LINK=clang++ AR=/usr/bin/ar
-.if ${COMPILER_VERSION} >= 33
-CFLAGS+= -Wno-nested-anon-types -Wno-unused-function
.if ${COMPILER_VERSION} >= 34
-CFLAGS+= -Wno-unused-const-variable
+CXXFLAGS+= -Wno-unused-const-variable
.if ${COMPILER_VERSION} >= 35
-CFLAGS+= -Wno-tautological-undefined-compare
-.endif
+CXXFLAGS+= -Wno-tautological-undefined-compare
.endif
.endif
.else