aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2018-10-30 11:03:30 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2018-10-30 11:03:30 +0000
commit54881c2e7e4265fdf66f1ed0eccd66e94b187093 (patch)
tree05c5e3989156dd35fbe4ceb48041982df501cbb7 /lang
parentc5479a946123c1cb94934aac8bebb0c051528ba4 (diff)
downloadports-54881c2e7e4265fdf66f1ed0eccd66e94b187093.tar.gz
ports-54881c2e7e4265fdf66f1ed0eccd66e94b187093.zip
lang/expect: install example scripts and manpages in the proper location
This commit changes the location of the example scripts and manpages. They are now installed in the proper PREFIX/bin and PREFIX/man/man1 - so they are in path and reachable by man(1) - and are renamed with an expect_ prefix to avoid conflicts due to their common names. A pkg-message has been added to notify users of this change. Portrevision has been bumped. PR: 232732 (based on) Submitted by: Walter Schwarzenfeld <w.schwarzenfeld@utanet.at> Reported by: Dennis Clarke <dclarke@blastwave.org>
Notes
Notes: svn path=/head/; revision=483467
Diffstat (limited to 'lang')
-rw-r--r--lang/expect/Makefile8
-rw-r--r--lang/expect/files/patch-Makefile.in14
-rw-r--r--lang/expect/files/patch-tclconfig_tcl.m44
-rw-r--r--lang/expect/files/pkg-message.in3
-rw-r--r--lang/expect/pkg-plist64
5 files changed, 47 insertions, 46 deletions
diff --git a/lang/expect/Makefile b/lang/expect/Makefile
index 281bb30a0de3..28ea8d4dcadb 100644
--- a/lang/expect/Makefile
+++ b/lang/expect/Makefile
@@ -3,6 +3,7 @@
PORTNAME= expect
PORTVERSION= 5.45.4
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= lang tcl tk
MASTER_SITES= SF/expect/Expect/${PORTVERSION}
@@ -14,12 +15,13 @@ COMMENT= Sophisticated scripter based on Tcl/Tk
LICENSE= PD
LICENSE_FILE= ${WRKSRC}/license.terms
-WRKSRC= ${WRKDIR}/${DISTNAME}
-
USES= tcl:tea autoreconf
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --datadir=${DATADIR}
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
PLIST_SUB+= PORTVERSION=${PORTVERSION}
+SUB_FILES+= pkg-message
+SUB_LIST+= MANPREFIX=${MANPREFIX}
TEST_TARGET= test
post-install:
diff --git a/lang/expect/files/patch-Makefile.in b/lang/expect/files/patch-Makefile.in
index 11fd970b6871..fee7a43dda1c 100644
--- a/lang/expect/files/patch-Makefile.in
+++ b/lang/expect/files/patch-Makefile.in
@@ -1,15 +1,11 @@
---- Makefile.in.orig 2010-09-30 17:14:07 UTC
+--- Makefile.in.orig 2018-02-02 19:15:52 UTC
+++ Makefile.in
-@@ -236,10 +236,10 @@ install-libraries: libraries $(SCRIPTS)
- $(INSTALL_DATA) $(srcdir)/$$i $(DESTDIR)$(includedir) ; \
- done;
- # install standalone scripts and their man pages, if requested
-- @mkdir -p $(DESTDIR)$(prefix)/bin
-+ @mkdir -p $(DESTDIR)$(datadir)
+@@ -239,7 +239,7 @@ install-libraries: libraries $(SCRIPTS)
+ @mkdir -p $(DESTDIR)$(prefix)/bin
-for i in $(SCRIPT_LIST) ; do \
if [ -f $$i ] ; then \
- $(INSTALL_PROGRAM) $$i $(DESTDIR)$(prefix)/bin/$$i ; \
-+ $(INSTALL_SCRIPT) $$i $(DESTDIR)$(datadir)/$$i ; \
++ $(INSTALL_SCRIPT) $$i $(DESTDIR)$(prefix)/bin/expect_$$i ; \
rm -f $$i ; \
else true; fi ; \
done
@@ -18,7 +14,7 @@
-for i in $(SCRIPT_MANPAGE_LIST) ; do \
if [ -f $(srcdir)/example/$$i.man ] ; then \
- $(INSTALL_DATA) $(srcdir)/example/$$i.man $(DESTDIR)$(mandir)/man1/$$i.1 ; \
-+ $(INSTALL_DATA) $(srcdir)/example/$$i.man $(DESTDIR)$(datadir)/$$i.1 ; \
++ $(INSTALL_DATA) $(srcdir)/example/$$i.man $(DESTDIR)$(mandir)/man1/expect_$$i.1 ; \
else true; fi ; \
done
diff --git a/lang/expect/files/patch-tclconfig_tcl.m4 b/lang/expect/files/patch-tclconfig_tcl.m4
index 2a001ebbf5a2..cc002b528e75 100644
--- a/lang/expect/files/patch-tclconfig_tcl.m4
+++ b/lang/expect/files/patch-tclconfig_tcl.m4
@@ -902,8 +902,8 @@
+ INSTALL='$(SHELL) $(srcdir)/tclconfig/install-sh -c'
+ INSTALL_DATA_DIR='${INSTALL} -d -m 755'
+ INSTALL_DATA='${INSTALL} -m 644'
-+ INSTALL_PROGRAM='${INSTALL}'
-+ INSTALL_SCRIPT='${INSTALL}'
++ INSTALL_PROGRAM='${INSTALL} -m 755 -s'
++ INSTALL_SCRIPT='${INSTALL} -m 755'
+ INSTALL_LIBRARY='${INSTALL_DATA}'
+
+ AC_SUBST(INSTALL)
diff --git a/lang/expect/files/pkg-message.in b/lang/expect/files/pkg-message.in
new file mode 100644
index 000000000000..2ca45ca7f7d3
--- /dev/null
+++ b/lang/expect/files/pkg-message.in
@@ -0,0 +1,3 @@
+To avoid conflicts, example scripts and man pages have been renamed by
+prefixing them with "expect_".
+They are in %%PREFIX%%/bin and %%MANPREFIX%%/man/man1, respectively.
diff --git a/lang/expect/pkg-plist b/lang/expect/pkg-plist
index 7cfff19f5e88..2da1d396cd18 100644
--- a/lang/expect/pkg-plist
+++ b/lang/expect/pkg-plist
@@ -1,4 +1,25 @@
bin/expect
+bin/expect_autoexpect
+bin/expect_autopasswd
+bin/expect_cryptdir
+bin/expect_decryptdir
+bin/expect_dislocate
+bin/expect_ftp-rfc
+bin/expect_kibitz
+bin/expect_lpunlock
+bin/expect_mkpasswd
+bin/expect_multixterm
+bin/expect_passmass
+bin/expect_rftp
+bin/expect_rlogin-cwd
+bin/expect_timed-read
+bin/expect_timed-run
+bin/expect_tknewsbiff
+bin/expect_tkpasswd
+bin/expect_unbuffer
+bin/expect_weather
+bin/expect_xkibitz
+bin/expect_xpstat
include/expect.h
include/expect_comm.h
include/expect_tcl.h
@@ -8,36 +29,15 @@ lib/expect%%PORTVERSION%%/pkgIndex.tcl
lib/libexpect.so
lib/libexpect.so.1
man/man1/expect.1.gz
+man/man1/expect_autoexpect.1.gz
+man/man1/expect_cryptdir.1.gz
+man/man1/expect_decryptdir.1.gz
+man/man1/expect_dislocate.1.gz
+man/man1/expect_kibitz.1.gz
+man/man1/expect_mkpasswd.1.gz
+man/man1/expect_multixterm.1.gz
+man/man1/expect_passmass.1.gz
+man/man1/expect_tknewsbiff.1.gz
+man/man1/expect_unbuffer.1.gz
+man/man1/expect_xkibitz.1.gz
man/man3/libexpect.3.gz
-%%DATADIR%%/autoexpect
-%%DATADIR%%/autoexpect.1
-%%DATADIR%%/autopasswd
-%%DATADIR%%/cryptdir
-%%DATADIR%%/cryptdir.1
-%%DATADIR%%/decryptdir
-%%DATADIR%%/decryptdir.1
-%%DATADIR%%/dislocate
-%%DATADIR%%/dislocate.1
-%%DATADIR%%/ftp-rfc
-%%DATADIR%%/kibitz
-%%DATADIR%%/kibitz.1
-%%DATADIR%%/lpunlock
-%%DATADIR%%/mkpasswd
-%%DATADIR%%/mkpasswd.1
-%%DATADIR%%/multixterm
-%%DATADIR%%/multixterm.1
-%%DATADIR%%/passmass
-%%DATADIR%%/passmass.1
-%%DATADIR%%/rftp
-%%DATADIR%%/rlogin-cwd
-%%DATADIR%%/timed-read
-%%DATADIR%%/timed-run
-%%DATADIR%%/tknewsbiff
-%%DATADIR%%/tknewsbiff.1
-%%DATADIR%%/tkpasswd
-%%DATADIR%%/unbuffer
-%%DATADIR%%/unbuffer.1
-%%DATADIR%%/weather
-%%DATADIR%%/xkibitz
-%%DATADIR%%/xkibitz.1
-%%DATADIR%%/xpstat