aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-10-20 14:58:37 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-10-20 14:58:37 +0000
commit83e5b9323b0f0281fa8e488f2f24d051ceeb8836 (patch)
tree6edfe3fe5d80ec822070e1ba76ab5a2328385d2c /lang
parentd5173a883f8c36bc1b381fd7ab769a030a85ec8b (diff)
downloadports-83e5b9323b0f0281fa8e488f2f24d051ceeb8836.tar.gz
ports-83e5b9323b0f0281fa8e488f2f24d051ceeb8836.zip
Update to 2.3.8
- Move BROKEN_* upward - Move USES upward - Remove no-op MLINKS and create symlinks for manpages - Sort INSTALLED_SCRIPTS - Regenerate patch files with makepatch: Changes: https://www.ruby-lang.org/en/news/2018/10/17/ruby-2-3-8-released/ PR: 232438 Submitted by: Yasuhiro KIMURA <yasu@utahime.org> Security: afc60484-0652-440e-b01a-5ef814747f06 MFH: 2018Q4
Notes
Notes: svn path=/head/; revision=482556
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby23/Makefile21
-rw-r--r--lang/ruby23/distinfo6
-rw-r--r--lang/ruby23/files/patch-configure.in22
-rw-r--r--lang/ruby23/files/patch-lib_rdoc_generator_json__index.rb (renamed from lang/ruby23/files/patch-lib_rdoc_generator_json_index.rb)8
-rw-r--r--lang/ruby23/files/patch-thread__pthread.c4
-rw-r--r--lang/ruby23/pkg-plist4
6 files changed, 38 insertions, 27 deletions
diff --git a/lang/ruby23/Makefile b/lang/ruby23/Makefile
index 0c8be83118db..6a20f1c39ea5 100644
--- a/lang/ruby23/Makefile
+++ b/lang/ruby23/Makefile
@@ -18,13 +18,16 @@ LICENSE_COMB= dual
LICENSE_FILE_BSD2CLAUSE=${WRKSRC}/BSDL
LICENSE_FILE_RUBY= ${WRKSRC}/COPYING
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel=does not detect and buid the openssl*.rb bits
+
# Using LIB_DEPENDS finds the libffi from gcc which causes problems
BUILD_DEPENDS= libffi>=0:devel/libffi
LIB_DEPENDS= libyaml.so:textproc/libyaml
RUN_DEPENDS= libffi>=0:devel/libffi
-BROKEN_SSL= openssl-devel
-BROKEN_SSL_REASON_openssl-devel=does not detect and buid the openssl*.rb bits
+USES= autoreconf cpe ssl tar:xz
+USE_LDCONFIG= yes
CONFIGURE_ARGS= ${RUBY_CONFIGURE_ARGS} \
--disable-rpath \
@@ -38,8 +41,6 @@ CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
# Keep this, else ruby will fail to load libraries dependent of libpthread.
LIBS+= -lpthread -L${LOCALBASE}/lib
-USE_LDCONFIG= yes
-USES= autoreconf cpe ssl tar:xz
WRKSRC= ${RUBY_WRKSRC}
RUBY_VER= 2.3
@@ -116,14 +117,14 @@ MAKE_JOBS_UNSAFE= yes
.endif
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
-MLINKS= ${RUBY_NAME}.1 ruby.1
PLIST_SUB+= IF_DEFAULT=""
.else
PKGNAMESUFFIX= ${RUBY_VER:C/\.//}
PLIST_SUB+= IF_DEFAULT="@comment "
.endif
-INSTALLED_SCRIPTS= irb erb rdoc ri ruby
+INSTALLED_SCRIPTS= erb irb rdoc ri ruby
+INSTALLED_MANUALS= erb irb ri ruby
EXTSAMPLES= bigdecimal/sample/*.rb
@@ -197,13 +198,19 @@ pre-install-RDOC-on:
${MKDIR} ${STAGEDIR}${RUBY_SITERIDIR}
post-install:
+.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
#
# Link just installed "ruby" to "ruby23", etc.
#
-.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
. for FILE in ${INSTALLED_SCRIPTS}
${LN} -fs ${FILE}${RUBY_SUFFIX} ${STAGEDIR}${PREFIX}/bin/${FILE}
. endfor
+#
+# Link "ruby.1.gz" to "ruby23.1.gz", etc.
+#
+. for FILE in ${INSTALLED_MANUALS}
+ ${LN} -fs ${FILE}${RUBY_SUFFIX}.1.gz ${STAGEDIR}${MANPREFIX}/man/man1/${FILE}.1.gz
+. endfor
.endif
post-install-DEBUG-off:
diff --git a/lang/ruby23/distinfo b/lang/ruby23/distinfo
index dab005f15058..306dbb01402d 100644
--- a/lang/ruby23/distinfo
+++ b/lang/ruby23/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1522331766
-SHA256 (ruby/ruby-2.3.7.tar.xz) = c61f8f2b9d3ffff5567e186421fa191f0d5e7c2b189b426bb84498825d548edb
-SIZE (ruby/ruby-2.3.7.tar.xz) = 11438124
+TIMESTAMP = 1540022780
+SHA256 (ruby/ruby-2.3.8.tar.xz) = 910f635d84fd0d81ac9bdee0731279e6026cb4cd1315bbbb5dfb22e09c5c1dfe
+SIZE (ruby/ruby-2.3.8.tar.xz) = 11465792
diff --git a/lang/ruby23/files/patch-configure.in b/lang/ruby23/files/patch-configure.in
index 687ce6d38649..fdefef0c3c82 100644
--- a/lang/ruby23/files/patch-configure.in
+++ b/lang/ruby23/files/patch-configure.in
@@ -1,6 +1,6 @@
---- configure.in.orig 2017-03-27 17:59:49 UTC
+--- configure.in.orig 2018-03-18 14:15:27 UTC
+++ configure.in
-@@ -633,7 +633,7 @@
+@@ -633,7 +633,7 @@ AC_DEFUN([RUBY_DTRACE_AVAILABLE],
[AC_CACHE_CHECK(whether dtrace USDT is available, rb_cv_dtrace_available,
[
echo "provider conftest{ probe fire(); };" > conftest_provider.d
@@ -9,7 +9,7 @@
AC_TRY_COMPILE([@%:@include "conftest_provider.h"], [CONFTEST_FIRE();], [
# DTrace is available on the system
rb_cv_dtrace_available=yes
-@@ -657,13 +657,13 @@
+@@ -657,13 +657,13 @@ AC_DEFUN([RUBY_DTRACE_POSTPROCESS],
probe fire();
};
_PROBES
@@ -25,7 +25,7 @@
:
}; then
if cmp -s conftest.o conftest.${ac_objext}.save; then
-@@ -1290,10 +1290,10 @@
+@@ -1290,10 +1290,10 @@ main()
],
[ LIBS="-lm $LIBS"])
@@ -40,7 +40,7 @@
dnl Checks for header files.
AC_HEADER_DIRENT
-@@ -2450,7 +2450,7 @@
+@@ -2450,7 +2450,7 @@ if test "$ac_cv_func_qsort_r" != no; the
AC_CACHE_CHECK(whether qsort_r is GNU version, rb_cv_gnu_qsort_r,
[AC_TRY_COMPILE([
@%:@include <stdlib.h>
@@ -49,7 +49,7 @@
int (*compar)(const void *, const void *, void *),
void *arg);
],[ ],
-@@ -2460,7 +2460,7 @@
+@@ -2460,7 +2460,7 @@ void qsort_r(void *base, size_t nmemb, s
AC_CACHE_CHECK(whether qsort_r is BSD version, rb_cv_bsd_qsort_r,
[AC_TRY_COMPILE([
@%:@include <stdlib.h>
@@ -58,7 +58,7 @@
void *arg, int (*compar)(void *, const void *, const void *));
],[ ],
[rb_cv_bsd_qsort_r=yes],
-@@ -2549,7 +2549,7 @@
+@@ -2549,7 +2549,7 @@ main(int argc, char **argv)
if test x"$ac_cv_func_clock_gettime" != xyes; then
# glibc 2.17 moves clock_* functions from librt to the main C library.
# http://sourceware.org/ml/libc-announce/2012/msg00001.html
@@ -67,7 +67,7 @@
if test x"$ac_cv_lib_rt_clock_gettime" = xyes; then
AC_DEFINE(HAVE_CLOCK_GETTIME, 1)
fi
-@@ -2956,7 +2956,7 @@
+@@ -2956,7 +2956,7 @@ else
fi
if test x"$enable_pthread" = xyes; then
@@ -76,7 +76,7 @@
AC_CHECK_LIB($pthread_lib, pthread_kill,
rb_with_pthread=yes, rb_with_pthread=no)
if test "$rb_with_pthread" = "yes"; then break; fi
-@@ -2970,6 +2970,7 @@
+@@ -2970,6 +2970,7 @@ if test x"$enable_pthread" = xyes; then
[c], [],
[root], [],
[c_r], [MAINLIBS="-pthread $MAINLIBS"],
@@ -84,7 +84,7 @@
[AS_CASE(["$target_os"],
[openbsd*|mirbsd*], [LIBS="-pthread $LIBS"],
[LIBS="-l$pthread_lib $LIBS"])])
-@@ -3278,7 +3279,6 @@
+@@ -3278,7 +3279,6 @@ if test "$with_dln_a_out" != yes; then
: ${LDSHARED='$(CC) -shared'}
if test "$rb_cv_binary_elf" = yes; then
LDFLAGS="$LDFLAGS -rdynamic"
@@ -92,7 +92,7 @@
else
test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED='$(LD) -Bshareable'
fi
-@@ -3751,6 +3751,7 @@
+@@ -3751,6 +3751,7 @@ AS_CASE("$enable_shared", [yes], [
[freebsd*|dragonfly*], [
SOLIBS='$(LIBS)'
LIBRUBY_SO='lib$(RUBY_SO_NAME).so.$(MAJOR)$(MINOR)'
diff --git a/lang/ruby23/files/patch-lib_rdoc_generator_json_index.rb b/lang/ruby23/files/patch-lib_rdoc_generator_json__index.rb
index 59eb143bf185..e5e9f6726340 100644
--- a/lang/ruby23/files/patch-lib_rdoc_generator_json_index.rb
+++ b/lang/ruby23/files/patch-lib_rdoc_generator_json__index.rb
@@ -1,6 +1,6 @@
---- ./lib/rdoc/generator/json_index.rb.orig 2017-11-12 19:38:46.598341000 -0500
-+++ ./lib/rdoc/generator/json_index.rb 2017-11-12 19:38:59.759125000 -0500
-@@ -175,7 +175,7 @@
+--- lib/rdoc/generator/json_index.rb.orig 2015-12-22 12:08:13 UTC
++++ lib/rdoc/generator/json_index.rb
+@@ -175,7 +175,7 @@ class RDoc::Generator::JsonIndex
debug_msg "Writing gzipped search index to %s" % outfile
Zlib::GzipWriter.open(outfile) do |gz|
@@ -9,7 +9,7 @@
gz.orig_name = search_index_file.basename.to_s
gz.write search_index
gz.close
-@@ -193,7 +193,7 @@
+@@ -193,7 +193,7 @@ class RDoc::Generator::JsonIndex
debug_msg "Writing gzipped file to %s" % outfile
Zlib::GzipWriter.open(outfile) do |gz|
diff --git a/lang/ruby23/files/patch-thread__pthread.c b/lang/ruby23/files/patch-thread__pthread.c
index 3d4e64ef725b..2bc47d92e376 100644
--- a/lang/ruby23/files/patch-thread__pthread.c
+++ b/lang/ruby23/files/patch-thread__pthread.c
@@ -1,6 +1,6 @@
---- thread_pthread.c.orig 2016-04-15 16:07:07 UTC
+--- thread_pthread.c.orig 2018-03-18 15:27:34 UTC
+++ thread_pthread.c
-@@ -1154,7 +1154,7 @@ native_sleep(rb_thread_t *th, struct tim
+@@ -1155,7 +1155,7 @@ native_sleep(rb_thread_t *th, struct tim
}
#ifdef USE_UBF_LIST
diff --git a/lang/ruby23/pkg-plist b/lang/ruby23/pkg-plist
index 0282cb8e19cc..3e07a98551ed 100644
--- a/lang/ruby23/pkg-plist
+++ b/lang/ruby23/pkg-plist
@@ -877,9 +877,13 @@ lib/lib%%RUBY_NAME%%.so.%%RUBY_SHLIBVER%%
%%RUBY_LIBDIR%%/yaml/dbm.rb
%%RUBY_LIBDIR%%/yaml/store.rb
libdata/pkgconfig/ruby-%%RUBY_VER%%.pc
+%%IF_DEFAULT%%man/man1/erb.1.gz
man/man1/erb%%RUBY_SUFFIX%%.1.gz
+%%IF_DEFAULT%%man/man1/irb.1.gz
man/man1/irb%%RUBY_SUFFIX%%.1.gz
+%%IF_DEFAULT%%man/man1/ri.1.gz
man/man1/ri%%RUBY_SUFFIX%%.1.gz
+%%IF_DEFAULT%%man/man1/ruby.1.gz
man/man1/%%RUBY_NAME%%.1.gz
%%DOCS%%%%RUBY_DOCDIR%%/COPYING
%%DOCS%%%%RUBY_DOCDIR%%/COPYING.ja