aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-07-27 23:15:02 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-07-27 23:15:02 +0000
commit430459f9cf2cc53d9315cee0d21f6929de0f249a (patch)
treebe670854062f8224ffe73403370c762eb4057c54 /lang
parentddd8dd830d4f3a87d52c2ec6ea5f8ca5a7f9af77 (diff)
downloadports-430459f9cf2cc53d9315cee0d21f6929de0f249a.tar.gz
ports-430459f9cf2cc53d9315cee0d21f6929de0f249a.zip
MFphp4: Fix compilation of wddx extension.
Notes
Notes: svn path=/head/; revision=114898
Diffstat (limited to 'lang')
-rw-r--r--lang/php5/Makefile.ext5
-rw-r--r--lang/php53/Makefile.ext5
2 files changed, 8 insertions, 2 deletions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index fe3dde6eb774..5419bf56ef40 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -351,7 +351,10 @@ CONFIGURE_ARGS+=--enable-tokenizer
.endif
.if ${PHP_MODNAME} == "wddx"
-CONFIGURE_ARGS+=--enable-wddx
+CONFIGURE_ARGS+=--enable-wddx \
+ --with-libxml-dir=${LOCALBASE}
+
+USE_GNOME= libxml2
USE_PHP= xml session
USE_PHP_BUILD= yes
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index fe3dde6eb774..5419bf56ef40 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -351,7 +351,10 @@ CONFIGURE_ARGS+=--enable-tokenizer
.endif
.if ${PHP_MODNAME} == "wddx"
-CONFIGURE_ARGS+=--enable-wddx
+CONFIGURE_ARGS+=--enable-wddx \
+ --with-libxml-dir=${LOCALBASE}
+
+USE_GNOME= libxml2
USE_PHP= xml session
USE_PHP_BUILD= yes