aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2005-06-25 23:58:33 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2005-06-25 23:58:33 +0000
commit35e0d4984086199b3de8bad7d6a882fa72436279 (patch)
tree83e9ba6cb87d9df0c5ff4dde8e9b6b303bc6b295 /lang
parent19dc5948a826d5a6a066b8e95f2a334c51e4870e (diff)
downloadports-35e0d4984086199b3de8bad7d6a882fa72436279.tar.gz
ports-35e0d4984086199b3de8bad7d6a882fa72436279.zip
Directly install libraries into a port-specific location instead of
moving them there after the original installation. This is simpler and also avoids the problem where the port would overwrite/remove an existing copy of libiberty.a, which boils down to a true conflict.
Notes
Notes: svn path=/head/; revision=138027
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc40/Makefile11
1 files changed, 2 insertions, 9 deletions
diff --git a/lang/gcc40/Makefile b/lang/gcc40/Makefile
index 43deb6c2d4aa..2051d568d00c 100644
--- a/lang/gcc40/Makefile
+++ b/lang/gcc40/Makefile
@@ -65,6 +65,7 @@ CONFIGURE_ARGS= --disable-nls \
--with-system-zlib \
--with-libiconv-prefix=${LOCALBASE} \
--program-suffix=${SUFFIX} \
+ --libdir=${TARGLIB} \
--with-gxx-include-dir=${TARGLIB}/include/c++/
.if defined(WITH_FORTRAN)
CONFIGURE_ARGS+= --with-gmp=${LOCALBASE}
@@ -74,7 +75,6 @@ MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
CONFIGURE_ARGS+= --enable-shared
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/lib ${TARGLIB}
-EXTRA_LIBS= libgcc_s
.else
CONFIGURE_ARGS+= --disable-shared
.endif
@@ -104,14 +104,12 @@ CONFIGURE_ARGS+= --disable-libgcj
PLIST_SUB+= LIBJAVA="@comment "
.else
PLIST_SUB+= LIBJAVA=""
-EXTRA_LIBS+= libffi libgcj libgij
.endif
.if defined(WITH_FORTRAN)
MAN1+= gfortran${SUFFIX}.1
INFO+= gfortran
PLIST_SUB+= FORTRAN=""
-EXTRA_LIBS+= libgfortran libgfortranbegin
.else
PLIST_SUB+= FORTRAN="@comment "
.endif
@@ -155,12 +153,7 @@ post-install:
${PREFIX}/man/man1/${f}${SUFFIX}.1; \
fi
.endfor
- # These libraries are moved from PREFIX/lib to avoid conflicts with
- # the stock compiler.
-.for f in libstdc++ libsupc++ libobjc libmudflap libmudflapth ${EXTRA_LIBS}
- ${MV} -f ${PREFIX}/lib/${f}.* ${TARGLIB}
-.endfor
- ${RM} -f ${PREFIX}/lib/libiberty.a ${TARGLIB}/*.la
+ ${RM} -f ${TARGLIB}/*.la
${RM} -f ${PREFIX}/man/man7/fsf-funding.7 \
${PREFIX}/man/man7/gfdl.7 ${PREFIX}/man/man7/gpl.7
# Add target libraries and include files to packaging list.