aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2006-12-19 08:50:06 +0000
committerVasil Dimov <vd@FreeBSD.org>2006-12-19 08:50:06 +0000
commit8816de78772207a79433c9099fc4e4e008a0af15 (patch)
tree4b843ca5f18371c382d311871571814a9b1c24f6 /lang
parentd19bf767d4cc2fbcce76390c07f51a4de9ee82f5 (diff)
downloadports-8816de78772207a79433c9099fc4e4e008a0af15.tar.gz
ports-8816de78772207a79433c9099fc4e4e008a0af15.zip
Resurrect lang/clips and update it to 6.24
Notes
Notes: svn path=/head/; revision=180132
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/clips/Makefile37
-rw-r--r--lang/clips/distinfo6
-rw-r--r--lang/clips/pkg-descr9
4 files changed, 53 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index bd4af9a74e23..ff2c4620bb81 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -24,6 +24,7 @@
SUBDIR += chicken
SUBDIR += cim
SUBDIR += cli
+ SUBDIR += clips
SUBDIR += clisp
SUBDIR += cmucl
SUBDIR += cmucl-extra
diff --git a/lang/clips/Makefile b/lang/clips/Makefile
new file mode 100644
index 000000000000..9773fd1c0d62
--- /dev/null
+++ b/lang/clips/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: clips
+# Date created: 8 July 2001
+# Whom: Douglas Anestad <yotta@dougdidit.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= clips
+PORTVERSION= 6.24
+CATEGORIES= lang
+MASTER_SITES= http://www.ghg.net/clips/download/source/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= vd/${PORTNAME}
+DISTFILES= clipssrc.tar.Z ${MAKEFILE}
+DIST_SUBDIR= clips-${PORTVERSION}
+EXTRACT_ONLY= ${DISTFILES:M*.tar.*}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A productive development and delivery expert system tool
+
+WRKSRC= ${WRKDIR}/${PORTNAME}src/${PORTNAME}src
+
+MAKEFILE= makefile.gcc
+ALL_TARGET= clips
+
+PLIST_FILES= bin/clips
+
+post-extract:
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/${MAKEFILE} ${WRKSRC}/
+
+do-patch:
+ ${REINPLACE_CMD} -e 's/gcc /${CC} ${CFLAGS} /g' ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/clips ${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/lang/clips/distinfo b/lang/clips/distinfo
new file mode 100644
index 000000000000..efe2ff61961a
--- /dev/null
+++ b/lang/clips/distinfo
@@ -0,0 +1,6 @@
+MD5 (clips-6.24/clipssrc.tar.Z) = ccba9d912375e57a1b7d9eba12da4198
+SHA256 (clips-6.24/clipssrc.tar.Z) = 80852a0df97597f710e90ca8bf5ecdc250c2034bf9dd3044bbedee111ad2e4ab
+SIZE (clips-6.24/clipssrc.tar.Z) = 1524143
+MD5 (clips-6.24/makefile.gcc) = 3b74fa0bdda8786574b198ae8cf9748a
+SHA256 (clips-6.24/makefile.gcc) = 062990ec16df6c983929711acba0f7ce284c4c8f2b6e527bcfc1794110284e03
+SIZE (clips-6.24/makefile.gcc) = 71566
diff --git a/lang/clips/pkg-descr b/lang/clips/pkg-descr
new file mode 100644
index 000000000000..e766e43cf4ed
--- /dev/null
+++ b/lang/clips/pkg-descr
@@ -0,0 +1,9 @@
+CLIPS is a productive development and delivery expert system tool which
+provides a complete environment for the construction of rule and/or object
+based expert systems.
+
+CLIPS is being used by numerous users throughout the public and private
+community including: all NASA sites and branches of the military, numerous
+federal bureaus, government contractors, universities, and many companies.
+
+WWW: http://www.ghg.net/clips/CLIPS.html