aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2004-06-01 07:46:34 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2004-06-01 07:46:34 +0000
commit18b2e68105d7ee4ad02b5a6a9f82dc9a4440e7ff (patch)
tree2eb77c8a8c607c9148f968c2b52f59fc68e032a9 /lang
parent964bf9bb2285689001d3738d96e4029bf646a070 (diff)
downloadports-18b2e68105d7ee4ad02b5a6a9f82dc9a4440e7ff.tar.gz
ports-18b2e68105d7ee4ad02b5a6a9f82dc9a4440e7ff.zip
Upgrade to 0.8.10, and use cpio(1) instead of tar(1) to install docs.
PR: ports/62013
Notes
Notes: svn path=/head/; revision=110580
Diffstat (limited to 'lang')
-rw-r--r--lang/sbcl/Makefile6
-rw-r--r--lang/sbcl/distinfo8
-rw-r--r--lang/sbcl/pkg-plist139
3 files changed, 118 insertions, 35 deletions
diff --git a/lang/sbcl/Makefile b/lang/sbcl/Makefile
index f65ebe0bfb62..b26dd110c8dd 100644
--- a/lang/sbcl/Makefile
+++ b/lang/sbcl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sbcl
-PORTVERSION= 0.8.9
+PORTVERSION= 0.8.10
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sbcl
@@ -48,7 +48,9 @@ do-install:
${MKDIR} ${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} BUGS COPYING CREDITS ${DOCSDIR})
.if !defined(NOPORTDOCS)
- (cd ${WRKSRC}/doc && ${TAR} cf - html | ${TAR} xf - -C ${DOCSDIR})
+ ${MKDIR} ${DOCSDIR}/manual
+ (cd ${WRKSRC}/doc/manual/sbcl && ${FIND} . -print | \
+ ${CPIO} -pdmu -R${DOCOWN}:${DOCGRP} ${DOCSDIR}/manual)
.endif
.include <bsd.port.mk>
diff --git a/lang/sbcl/distinfo b/lang/sbcl/distinfo
index e92c18ee3b35..cd683d217b24 100644
--- a/lang/sbcl/distinfo
+++ b/lang/sbcl/distinfo
@@ -1,4 +1,4 @@
-MD5 (sbcl-0.8.9-source.tar.bz2) = 97ca1a5dac091f61943325a3d689a8e3
-SIZE (sbcl-0.8.9-source.tar.bz2) = 2069624
-MD5 (sbcl-0.8.9-html.tar.bz2) = 38f9f6de699d4ed9cb7a99abd99da477
-SIZE (sbcl-0.8.9-html.tar.bz2) = 47167
+MD5 (sbcl-0.8.10-source.tar.bz2) = e42f384cbbadcf626342d4048889061b
+SIZE (sbcl-0.8.10-source.tar.bz2) = 2109999
+MD5 (sbcl-0.8.10-html.tar.bz2) = 2648661efbd7d4516e56a53f4e0c3a6d
+SIZE (sbcl-0.8.10-html.tar.bz2) = 63094
diff --git a/lang/sbcl/pkg-plist b/lang/sbcl/pkg-plist
index 5e2ae4e7d254..b7635afebe2f 100644
--- a/lang/sbcl/pkg-plist
+++ b/lang/sbcl/pkg-plist
@@ -1,5 +1,109 @@
+%%DOCSDIR%%/BUGS
+%%DOCSDIR%%/COPYING
+%%DOCSDIR%%/CREDITS
+%%PORTDOCS%%%%DOCSDIR%%/manual/Accessing-Foreign-Values.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Beyond-The-ANSI-Standard.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Calling-Lisp-From-C.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Coercing-Foreign-Values.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Colophon.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Compiler-Policy.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Concept-Index.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Contributed-Modules.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Controlling-Printing-in-the-Debugger.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Customization-Hooks-for-Users.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Debug-Tail-Recursion.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Debugger-Policy-Control.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Defining-Foreign-Types.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Dynamic-extent-allocation.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Efficiency-Hacks.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Efficiency.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Error-Messages.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Error-Severity.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Errors-During-Macroexpansion.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Exiting-Commands.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Extensions.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/External-Foreign-Variables.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Foreign-Data-Structure-Examples.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Foreign-Dynamic-Allocation.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Foreign-Function-Calls.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Foreign-Type-Specifiers.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Foreign-Types-and-Lisp-Types.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Foreign-Types.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Foreign-Variables.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Function-Index.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Function-Names.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Function-Tracing.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Funny-Frames.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Getting-Existing-Programs-to-Run.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Handling-of-Types.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/How-Arguments-are-Printed.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/How-the-Source-is-Found.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Idiosyncrasies.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Implementation-Limitations.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Information-Commands.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Interface-To-Low-Level-SBCL-Implementation.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Introduction-to-the-Foreign-Function-Interface.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Introduction.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Loading-Unix-Object-Files.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Local-Foreign-Variables.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Modular-arithmetic.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/More-Common-Lisp-Information.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/More-SBCL-Information.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Non-Conformance-With-The-ANSI-Standard.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Note-On-Lexical-Variable-Access.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Open-Coding-and-Inline-Expansion.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Operations-On-Foreign-Values.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Overview.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Precise-Type-Checking.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Read-Errors.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Source-Location-Availability.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Source-Location-Printing.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Stack-Frames.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Stack-Motion.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Stale-Extensions.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Starting-the-Debugger.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Step-By-Step-Example-of-the-Foreign-Function-Interface.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Support-For-Unix.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/The-Compiler.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/The-Debugger-Command-Loop.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/The-Debugger.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/The-Foreign-Function-Interface.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/The-Original-and-Actual-Source.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/The-Parts-of-the-Error-Message.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/The-alien-funcall-Primitive.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/The-define-alien-routine-Macro.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Things-Which-Might-Be-In-The-Next-ANSI-Standard.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Threading.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Tools-To-Help-Developers.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Type-Errors-at-Compile-Time.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Unknown-Locations-and-Interrupts.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Variable-Access.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Variable-Index.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Variable-Value-Availability.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/Weakened-Type-Checking.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/define-alien-routine-Example.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/fun-common-lisp-require.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/fun-sb-ext-posix-getenv.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/fun-sb-ext-purify.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/fun-sb-ext-quit.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/fun-sb-ext-save-lisp-and-die.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/fun-sb-md5-md5sum-file.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/fun-sb-md5-md5sum-sequence.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/fun-sb-md5-md5sum-stream.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/fun-sb-rotate-byte-rotate-byte.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/index.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/macro-common-lisp-trace.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/macro-common-lisp-untrace.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/sb-aclrepl.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/sb-md5.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/sb-rotate-byte.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/special-operator-sb-ext-truly-the.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/var-sb-debug-star-max-trace-indentation-star.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/var-sb-debug-star-trace-encapsulate-default-star.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/var-sb-debug-star-trace-indentation-step-star.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/var-sb-debug-star-trace-values-star.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/var-sb-ext-star-module-provider-functions-star.html
bin/sbcl
-bin/sbcl-asdf-install
lib/sbcl/asdf-install/.cvsignore
lib/sbcl/asdf-install/Makefile
lib/sbcl/asdf-install/README
@@ -9,8 +113,6 @@ lib/sbcl/asdf-install/defpackage.fasl
lib/sbcl/asdf-install/defpackage.lisp
lib/sbcl/asdf-install/installer.fasl
lib/sbcl/asdf-install/installer.lisp
-lib/sbcl/asdf-install/loader.fasl
-lib/sbcl/asdf-install/loader.lisp
lib/sbcl/asdf-install/test-passed
lib/sbcl/asdf/asdf.fasl
lib/sbcl/sb-aclrepl/.cvsignore
@@ -24,6 +126,7 @@ lib/sbcl/sb-aclrepl/repl.fasl
lib/sbcl/sb-aclrepl/repl.lisp
lib/sbcl/sb-aclrepl/sb-aclrepl.asd
lib/sbcl/sb-aclrepl/sb-aclrepl.fasl
+lib/sbcl/sb-aclrepl/sb-aclrepl.texinfo
lib/sbcl/sb-aclrepl/test-passed
lib/sbcl/sb-aclrepl/tests.fasl
lib/sbcl/sb-aclrepl/tests.lisp
@@ -112,6 +215,7 @@ lib/sbcl/sb-md5/md5.fasl
lib/sbcl/sb-md5/md5.lisp
lib/sbcl/sb-md5/sb-md5.asd
lib/sbcl/sb-md5/sb-md5.fasl
+lib/sbcl/sb-md5/sb-md5.texinfo
lib/sbcl/sb-md5/test-passed
lib/sbcl/sb-posix/.cvsignore
lib/sbcl/sb-posix/Makefile
@@ -152,6 +256,7 @@ lib/sbcl/sb-rotate-byte/rotate-byte.fasl
lib/sbcl/sb-rotate-byte/rotate-byte.lisp
lib/sbcl/sb-rotate-byte/sb-rotate-byte.asd
lib/sbcl/sb-rotate-byte/sb-rotate-byte.fasl
+lib/sbcl/sb-rotate-byte/sb-rotate-byte.texinfo
lib/sbcl/sb-rotate-byte/test-passed
lib/sbcl/sb-rotate-byte/x86-vm.fasl
lib/sbcl/sb-rotate-byte/x86-vm.lisp
@@ -196,7 +301,7 @@ lib/sbcl/sb-simple-streams/string.fasl
lib/sbcl/sb-simple-streams/string.lisp
lib/sbcl/sb-simple-streams/terminal.fasl
lib/sbcl/sb-simple-streams/terminal.lisp
-lib/sbcl/sb-simple-streams/test-data.txt
+lib/sbcl/sb-simple-streams/test-data.tmp
lib/sbcl/sb-simple-streams/test-passed
lib/sbcl/sbcl.core
lib/sbcl/systems/asdf-install.asd
@@ -209,31 +314,7 @@ lib/sbcl/systems/sb-posix.asd
lib/sbcl/systems/sb-rotate-byte.asd
lib/sbcl/systems/sb-rt.asd
lib/sbcl/systems/sb-simple-streams.asd
-%%DOCSDIR%%/BUGS
-%%DOCSDIR%%/COPYING
-%%DOCSDIR%%/CREDITS
-%%PORTDOCS%%%%DOCSDIR%%/html/beyond-ansi.html
-%%PORTDOCS%%%%DOCSDIR%%/html/colophon.html
-%%PORTDOCS%%%%DOCSDIR%%/html/compiler-policy.html
-%%PORTDOCS%%%%DOCSDIR%%/html/compiler-types.html
-%%PORTDOCS%%%%DOCSDIR%%/html/compiler.html
-%%PORTDOCS%%%%DOCSDIR%%/html/efficiency.html
-%%PORTDOCS%%%%DOCSDIR%%/html/extensions.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ffi-example.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ffi.html
-%%PORTDOCS%%%%DOCSDIR%%/html/foreign-data-structure.html
-%%PORTDOCS%%%%DOCSDIR%%/html/foreign-function-calls.html
-%%PORTDOCS%%%%DOCSDIR%%/html/foreign-types.html
-%%PORTDOCS%%%%DOCSDIR%%/html/foreign-values.html
-%%PORTDOCS%%%%DOCSDIR%%/html/foreign-variables.html
-%%PORTDOCS%%%%DOCSDIR%%/html/idiosyncrasies.html
-%%PORTDOCS%%%%DOCSDIR%%/html/implementation.html
-%%PORTDOCS%%%%DOCSDIR%%/html/index.html
-%%PORTDOCS%%%%DOCSDIR%%/html/intro.html
-%%PORTDOCS%%%%DOCSDIR%%/html/load-object.html
-%%PORTDOCS%%%%DOCSDIR%%/html/open-coding.html
-%%PORTDOCS%%%%DOCSDIR%%/html/where-more.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual
@dirrm %%DOCSDIR%%
@dirrm lib/sbcl/systems
@dirrm lib/sbcl/site-systems