aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2003-08-07 11:30:17 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2003-08-07 11:30:17 +0000
commit0da940ae8ac399be2b692f3b26bef56109a364a1 (patch)
tree6b89462b652ba7ef54e564e1a4ca5c7b9ce85c9f /lang
parent953c94bbc6b718e850dae3077a985952bdc7a198 (diff)
downloadports-0da940ae8ac399be2b692f3b26bef56109a364a1.tar.gz
ports-0da940ae8ac399be2b692f3b26bef56109a364a1.zip
- Remove somewhat buggy libc_r lackness detection. (at least for bento)
- Bump PORTREVISION to enable the thread support in the package building environments.
Notes
Notes: svn path=/head/; revision=86494
Diffstat (limited to 'lang')
-rw-r--r--lang/python15/Makefile7
-rw-r--r--lang/python20/Makefile5
-rw-r--r--lang/python21/Makefile5
3 files changed, 7 insertions, 10 deletions
diff --git a/lang/python15/Makefile b/lang/python15/Makefile
index cc97ed924740..ab065305ecaf 100644
--- a/lang/python15/Makefile
+++ b/lang/python15/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python
PORTVERSION= 1.5.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang python
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/src
@@ -37,10 +37,9 @@ SETUP_FILE= Setup
#
# If you don't want to use Python's thread module, you need to set
-# WITHOUT_THREADS. libc_r should be installed on nowadays' systems.
+# WITHOUT_THREADS.
#
-LIBC_R!= /sbin/ldconfig -r | grep c_r || true
-.if (${LIBC_R} != "") && !defined(WITHOUT_THREADS)
+.if !defined(NOLIBC_R) && !defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --with-thread
CFLAGS+= ${PTHREAD_CFLAGS}
CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
diff --git a/lang/python20/Makefile b/lang/python20/Makefile
index b1a80b319f95..6fe205d041b1 100644
--- a/lang/python20/Makefile
+++ b/lang/python20/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python
PORTVERSION= 2.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang python
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
@@ -39,8 +39,7 @@ SETUP_FILE= Setup
# If you don't want to use Python's thread module, you need to set
# WITHOUT_THREADS.
#
-LIBC_R!= /sbin/ldconfig -r | grep c_r || true
-.if (${LIBC_R} != "") && !defined(WITHOUT_THREADS)
+.if !defined(NOLIBC_R) && !defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
diff --git a/lang/python21/Makefile b/lang/python21/Makefile
index 58278e42f66c..7e76fac90684 100644
--- a/lang/python21/Makefile
+++ b/lang/python21/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python
PORTVERSION= 2.1.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= lang python
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
@@ -33,8 +33,7 @@ LATEST_LINK= ${PYTHON_VERSION:S/.//}
# If you don't want to use Python's thread module, you need to set
# WITHOUT_THREADS.
#
-LIBC_R!= /sbin/ldconfig -r | grep c_r || true
-.if (${LIBC_R} != "") && !defined(WITHOUT_THREADS)
+.if !defined(NOLIBC_R) && !defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"