aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2016-04-07 13:34:26 +0000
committerCy Schubert <cy@FreeBSD.org>2016-04-07 13:34:26 +0000
commit2d6420aa7a2d5a892ebab11c6e546b0c9ff57f2f (patch)
tree216e74f84492a9b53bc448a779c4d9e6c6a03bed /lang
parentb51caf89ca9d44bd20cba49c3a6d368a0bcc657e (diff)
downloadports-2d6420aa7a2d5a892ebab11c6e546b0c9ff57f2f.tar.gz
ports-2d6420aa7a2d5a892ebab11c6e546b0c9ff57f2f.zip
Missed these updates in r410093.
Pointy hat to: myself
Notes
Notes: svn path=/head/; revision=412665
Diffstat (limited to 'lang')
-rw-r--r--lang/dmd2/files/patch-src__dmd__posix.mak58
-rw-r--r--lang/dmd2/pkg-plist6
2 files changed, 8 insertions, 56 deletions
diff --git a/lang/dmd2/files/patch-src__dmd__posix.mak b/lang/dmd2/files/patch-src__dmd__posix.mak
index 10136e214612..0ec355366b83 100644
--- a/lang/dmd2/files/patch-src__dmd__posix.mak
+++ b/lang/dmd2/files/patch-src__dmd__posix.mak
@@ -1,18 +1,6 @@
---- ../../src/dmd/posix.mak.orig 2016-01-27 07:22:54.000000000 -0800
-+++ ../../src/dmd/posix.mak 2016-01-28 12:32:14.044394178 -0800
-@@ -31,9 +31,9 @@
- endif
-
- #ifeq (osx,$(OS))
--# HOST_CC=clang++
-+# HOST_CC=clanc++
- #else
-- HOST_CC=g++
-+ HOST_CC=c++
- #endif
- CC=$(HOST_CC)
- AR=ar
-@@ -56,14 +56,11 @@
+--- ../../src/dmd/posix.mak.orig 2016-04-05 20:46:46.000000000 -0700
++++ ../../src/dmd/posix.mak 2016-04-07 06:19:55.204336000 -0700
+@@ -66,14 +66,11 @@
HOST_DMD_RUN:=$(HOST_DMD)
else
# Auto-bootstrapping, will download dmd automatically
@@ -30,43 +18,7 @@
HOST_DMD_RUN=$(HOST_DMD) -conf=$(dir $(HOST_DMD))dmd.conf
endif
-@@ -92,7 +89,7 @@
- -Wno-unused-value \
- -Wno-unused-variable
- # GCC Specific
--ifeq ($(HOST_CC), g++)
-+ifeq ($(HOST_CC), c++)
- WARNINGS := $(WARNINGS) \
- -Wno-logical-op \
- -Wno-narrowing \
-@@ -100,7 +97,7 @@
- -Wno-uninitialized
- endif
- # Clang Specific
--ifeq ($(HOST_CC), clang++)
-+ifeq ($(HOST_CC), clanc++)
- WARNINGS := $(WARNINGS) \
- -Wno-tautological-constant-out-of-range-compare \
- -Wno-tautological-compare \
-@@ -112,7 +109,7 @@
- # Default Warnings
- WARNINGS := -Wno-deprecated -Wstrict-aliasing
- # Clang Specific
--ifeq ($(HOST_CC), clang++)
-+ifeq ($(HOST_CC), clanc++)
- WARNINGS := $(WARNINGS) \
- -Wno-logical-op-parentheses \
- -Wno-dynamic-class-memaccess \
-@@ -130,7 +127,7 @@
- -D__pascal= -DMARS=1 -DTARGET_$(OS_UPCASE)=1 -DDM_TARGET_CPU_$(TARGET_CPU)=1 \
- $(MODEL_FLAG)
- # GCC Specific
--ifeq ($(HOST_CC), g++)
-+ifeq ($(HOST_CC), c++)
- CFLAGS := $(CFLAGS) \
- -std=gnu++98
- endif
-@@ -321,19 +318,6 @@
+@@ -333,19 +330,6 @@
verstr.h SYSCONFDIR.imp core *.cov *.deps *.gcda *.gcno *.a *.lst
@[ ! -d ${PGO_DIR} ] || echo You should issue manually: rm -rf ${PGO_DIR}
@@ -86,7 +38,7 @@
######## generate a default dmd.conf
define DEFAULT_DMD_CONF
-@@ -440,7 +424,7 @@
+@@ -452,7 +436,7 @@
$(eval bin_dir=$(if $(filter $(OS),osx), bin, bin$(MODEL)))
mkdir -p $(INSTALL_DIR)/$(OS)/$(bin_dir)
cp dmd $(INSTALL_DIR)/$(OS)/$(bin_dir)/dmd
diff --git a/lang/dmd2/pkg-plist b/lang/dmd2/pkg-plist
index fae67d622df0..c6c8efc66222 100644
--- a/lang/dmd2/pkg-plist
+++ b/lang/dmd2/pkg-plist
@@ -39,6 +39,7 @@ include/d/druntime/import/core/exception.d
include/d/druntime/import/core/internal/abort.d
include/d/druntime/import/core/internal/convert.d
include/d/druntime/import/core/internal/hash.d
+include/d/druntime/import/core/internal/spinlock.d
include/d/druntime/import/core/internal/string.d
include/d/druntime/import/core/internal/traits.d
include/d/druntime/import/core/math.d
@@ -65,6 +66,8 @@ include/d/druntime/import/core/stdc/string.d
include/d/druntime/import/core/stdc/tgmath.d
include/d/druntime/import/core/stdc/time.d
include/d/druntime/import/core/stdc/wchar_.d
+include/d/druntime/import/core/stdcpp/exception.d
+include/d/druntime/import/core/stdcpp/typeinfo.d
include/d/druntime/import/core/stdc/wctype.d
include/d/druntime/import/core/sync/barrier.di
include/d/druntime/import/core/sync/condition.di
@@ -463,7 +466,6 @@ include/d/phobos2/std/json.d
include/d/phobos2/std/math.d
include/d/phobos2/std/mathspecial.d
include/d/phobos2/std/meta.d
-include/d/phobos2/std/metastrings.d
include/d/phobos2/std/mmfile.d
include/d/phobos2/std/net/curl.d
include/d/phobos2/std/net/isemail.d
@@ -492,11 +494,9 @@ include/d/phobos2/std/stdio.d
include/d/phobos2/std/stdiobase.d
include/d/phobos2/std/stream.d
include/d/phobos2/std/string.d
-include/d/phobos2/std/syserror.d
include/d/phobos2/std/system.d
include/d/phobos2/std/traits.d
include/d/phobos2/std/typecons.d
-include/d/phobos2/std/typelist.d
include/d/phobos2/std/typetuple.d
include/d/phobos2/std/uni.d
include/d/phobos2/std/uri.d