aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-25 16:17:19 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-25 16:17:19 +0000
commit4d32bbcef6444fe1625b9b0a62da9c7aceadd457 (patch)
tree6b3679b99a4f945bc127fb23b5a99279be3b083d /lang
parent414b46fbfaae08a771f7e9f52f788799be25a7c9 (diff)
downloadports-4d32bbcef6444fe1625b9b0a62da9c7aceadd457.tar.gz
ports-4d32bbcef6444fe1625b9b0a62da9c7aceadd457.zip
Move USE_BDB support from bsd.databases.mk to its own file.
Also: - Deorbit WANT_BDB_VER, one can use USES=bdb:<ver> instead. - USE_BDB can't happen after bsd.port.pre.mk because it is a USES. PR: 208971 Submitted by: mat Exp-run by: antoine With hat: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D5951
Notes
Notes: svn path=/head/; revision=414018
Diffstat (limited to 'lang')
-rw-r--r--lang/php55/Makefile.ext4
-rw-r--r--lang/php56/Makefile.ext4
-rw-r--r--lang/php70/Makefile.ext4
3 files changed, 9 insertions, 3 deletions
diff --git a/lang/php55/Makefile.ext b/lang/php55/Makefile.ext
index c5f4435a7a6f..69a16f499b15 100644
--- a/lang/php55/Makefile.ext
+++ b/lang/php55/Makefile.ext
@@ -464,7 +464,7 @@ CONFIGURE_ARGS+=--enable-zip \
CONFIGURE_ARGS+=--with-zlib=/usr
.endif
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PHP_MODNAME} == "dba"
. if empty(PORT_OPTIONS:MCDB)
@@ -499,6 +499,8 @@ CONFIGURE_ARGS+=--disable-flatfile
. endif
.endif
+.include <bsd.port.pre.mk>
+
.if ${PHP_MODNAME} == "gd"
. if ${PORT_OPTIONS:MT1LIB}
LIB_DEPENDS+= libt1.so:devel/t1lib
diff --git a/lang/php56/Makefile.ext b/lang/php56/Makefile.ext
index e74eccc1e304..8ed5295444be 100644
--- a/lang/php56/Makefile.ext
+++ b/lang/php56/Makefile.ext
@@ -467,7 +467,7 @@ CONFIGURE_ARGS+=--enable-zip \
CONFIGURE_ARGS+=--with-zlib=/usr
.endif
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PHP_MODNAME} == "dba"
. if empty(PORT_OPTIONS:MCDB)
@@ -502,6 +502,8 @@ CONFIGURE_ARGS+=--disable-flatfile
. endif
.endif
+.include <bsd.port.pre.mk>
+
.if ${PHP_MODNAME} == "gd"
. if ${PORT_OPTIONS:MT1LIB}
LIB_DEPENDS+= libt1.so:devel/t1lib
diff --git a/lang/php70/Makefile.ext b/lang/php70/Makefile.ext
index 871e1ed1091b..88c8d16e5b7e 100644
--- a/lang/php70/Makefile.ext
+++ b/lang/php70/Makefile.ext
@@ -459,7 +459,7 @@ CONFIGURE_ARGS+=--enable-zip \
CONFIGURE_ARGS+=--with-zlib=/usr
.endif
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PHP_MODNAME} == "dba"
. if empty(PORT_OPTIONS:MCDB)
@@ -494,6 +494,8 @@ CONFIGURE_ARGS+=--disable-flatfile
. endif
.endif
+.include <bsd.port.pre.mk>
+
.if ${PHP_MODNAME} == "gd"
. if ${PORT_OPTIONS:MT1LIB}
LIB_DEPENDS+= libt1.so:devel/t1lib