aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-11 08:56:53 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-11 08:56:53 +0000
commit72185e5fb2229800490e58850811d57db1039664 (patch)
tree9c01d1faf4fbbd4d19b88647d3113491e00711c3 /lang
parente91a050e2e1205f1fd54ffc8c66aa2680ffb6a63 (diff)
downloadports-72185e5fb2229800490e58850811d57db1039664.tar.gz
ports-72185e5fb2229800490e58850811d57db1039664.zip
- convert to the new perl5 framework
- trim Makefile header Approved by: portmgr (bapt@, blanket)
Notes
Notes: svn path=/head/; revision=326955
Diffstat (limited to 'lang')
-rw-r--r--lang/p5-JavaScript-Value-Escape/Makefile8
-rw-r--r--lang/p5-Modern-Perl/Makefile9
-rw-r--r--lang/pecl-perl/Makefile8
3 files changed, 7 insertions, 18 deletions
diff --git a/lang/p5-JavaScript-Value-Escape/Makefile b/lang/p5-JavaScript-Value-Escape/Makefile
index b1f9815f7fd2..1e63853b1c43 100644
--- a/lang/p5-JavaScript-Value-Escape/Makefile
+++ b/lang/p5-JavaScript-Value-Escape/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: JavaScript::Value::Escape
-# Date created: 19 May 2011
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= JavaScript-Value-Escape
PORTVERSION= 0.06
@@ -14,7 +9,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension to avoid XSS with JavaScript value interpolation
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= JavaScript::Value::Escape.3
diff --git a/lang/p5-Modern-Perl/Makefile b/lang/p5-Modern-Perl/Makefile
index 79a264660ab8..34e74b2beacc 100644
--- a/lang/p5-Modern-Perl/Makefile
+++ b/lang/p5-Modern-Perl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Modern-Perl
-# Date created: 2010-04-03
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Modern-Perl
PORTVERSION= 1.03
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= Enable all of the features of Modern Perl with one command
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Modern::Perl.3
diff --git a/lang/pecl-perl/Makefile b/lang/pecl-perl/Makefile
index 900c7b36843a..c4ceb1ca4798 100644
--- a/lang/pecl-perl/Makefile
+++ b/lang/pecl-perl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pecl-perl
-# Date created: 2007-3-3
-# Whom: Luke Jee
-#
+# Created by: Luke Jee
# $FreeBSD$
-#
PORTNAME= perl
DISTVERSION= 1.0.0
@@ -22,6 +18,6 @@ USE_PHPEXT= yes
USE_PHP_BUILD= yes
DEFAULT_PHP_VER=53
-USE_PERL5= yes
+USES= perl5
.include <bsd.port.mk>