aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorBartek Rutkowski <robak@FreeBSD.org>2015-04-03 20:32:14 +0000
committerBartek Rutkowski <robak@FreeBSD.org>2015-04-03 20:32:14 +0000
commitdd5e0f907f0e5d0bc118bccffd5ae911374488b0 (patch)
tree5f8f30c9be2016db9bb793fb6b39fcfd0a562fe0 /lang
parentf0e3f4a2366e4c05440097b8c47f320a449d3663 (diff)
downloadports-dd5e0f907f0e5d0bc118bccffd5ae911374488b0.tar.gz
ports-dd5e0f907f0e5d0bc118bccffd5ae911374488b0.zip
lang/nimrod: MOVED to lang/nim and update 0.9.2 -> 0.10.2
- Upstream has renamed the project from 'nimrod' to 'nim' PR: 199118 Submitted by: Neal Nelson <ports@nicandneal.net>
Notes
Notes: svn path=/head/; revision=383175
Diffstat (limited to 'lang')
-rw-r--r--lang/nim/Makefile (renamed from lang/nimrod/Makefile)16
-rw-r--r--lang/nim/distinfo2
-rw-r--r--lang/nim/files/patch-build.sh (renamed from lang/nimrod/files/patch-build.sh)0
-rw-r--r--lang/nim/files/patch-compiler-nimconf.nim27
-rw-r--r--lang/nim/files/patch-config-nim.cfg (renamed from lang/nimrod/files/patch-config-nimrod.cfg)13
-rw-r--r--lang/nim/files/patch-install.sh (renamed from lang/nimrod/files/patch-install.sh)36
-rw-r--r--lang/nim/files/patch-lib-posix-posix.nim11
-rw-r--r--lang/nim/files/patch-lib-pure-os.nim12
-rw-r--r--lang/nim/pkg-descr13
-rw-r--r--lang/nim/pkg-plist206
-rw-r--r--lang/nimrod/distinfo2
-rw-r--r--lang/nimrod/files/patch-compiler-nimconf.nim25
-rw-r--r--lang/nimrod/files/patch-lib-pure-os.nim36
-rw-r--r--lang/nimrod/pkg-descr13
-rw-r--r--lang/nimrod/pkg-plist372
15 files changed, 303 insertions, 481 deletions
diff --git a/lang/nimrod/Makefile b/lang/nim/Makefile
index ec04f8f98f77..151b36f59299 100644
--- a/lang/nimrod/Makefile
+++ b/lang/nim/Makefile
@@ -1,15 +1,14 @@
# Created by: Neal Nelson <ports@nicandneal.net>
# $FreeBSD$
-PORTNAME= nimrod
-PORTVERSION= 0.9.2
-PORTREVISION= 1
+PORTNAME= nim
+PORTVERSION= 0.10.2
+PORTREVISION= 0
CATEGORIES= lang
-MASTER_SITES= http://nimrod-code.org/download/
-DISTNAME= ${PORTNAME}_${PORTVERSION}
+MASTER_SITES= http://nim-lang.org/download/
MAINTAINER= ports@nicandneal.net
-COMMENT= The Nimrod programming language
+COMMENT= The Nim programming language
LICENSE= MIT
@@ -17,20 +16,19 @@ OPTIONS_DEFINE= DOCS
MAKE_JOBS_UNSAFE= yes
USES= compiler zip
-WRKSRC= ${WRKDIR}/${PORTNAME}
.include <bsd.port.pre.mk>
post-patch:
.if ${COMPILER_TYPE} == clang
- @${REINPLACE_CMD} -e '/cc =/s/gcc/clang/' ${WRKSRC}/config/nimrod.cfg
+ @${REINPLACE_CMD} -e '/cc =/s/gcc/clang/' ${WRKSRC}/config/nim.cfg
.endif
do-build:
cd ${WRKSRC} && ${SETENV} CC="${CC}" LINKER="${CC}" \
COMP_FLAGS="${CPPFLAGS} ${CFLAGS}" LINK_FLAGS="${LDFLAGS}" \
${SH} build.sh
- cd ${WRKSRC} && bin/nimrod c --parallelBuild=${MAKE_JOBS_NUMBER} koch
+ cd ${WRKSRC} && bin/nim c --parallelBuild=${MAKE_JOBS_NUMBER} koch
cd ${WRKSRC} && ./koch boot --parallelBuild=${MAKE_JOBS_NUMBER} \
-d:release
diff --git a/lang/nim/distinfo b/lang/nim/distinfo
new file mode 100644
index 000000000000..4e2d95fc71ce
--- /dev/null
+++ b/lang/nim/distinfo
@@ -0,0 +1,2 @@
+SHA256 (nim-0.10.2.zip) = 2fb7986cbceda10992fbe2cf657241cac416991e2e68bc0175f3a8fd387279ca
+SIZE (nim-0.10.2.zip) = 27753779
diff --git a/lang/nimrod/files/patch-build.sh b/lang/nim/files/patch-build.sh
index d48a98e93784..d48a98e93784 100644
--- a/lang/nimrod/files/patch-build.sh
+++ b/lang/nim/files/patch-build.sh
diff --git a/lang/nim/files/patch-compiler-nimconf.nim b/lang/nim/files/patch-compiler-nimconf.nim
new file mode 100644
index 000000000000..ca534bc348b2
--- /dev/null
+++ b/lang/nim/files/patch-compiler-nimconf.nim
@@ -0,0 +1,27 @@
+--- compiler/nimconf.nim.orig 2015-04-02 16:30:19.768619132 +0200
++++ compiler/nimconf.nim 2015-04-02 16:44:18.476742363 +0200
+@@ -215,20 +215,16 @@
+ # the UNIX way)
+ let p = getPrefixDir()
+ result = joinPath([p, "config", filename])
+- when defined(unix):
+- if not existsFile(result): result = joinPath([p, "etc", filename])
+- if not existsFile(result): result = "/etc/" & filename
++ if not existsFile(result): result = joinPath([p, "etc", filename])
++ if not existsFile(result): result = "/etc/" & filename
+
+ proc loadConfigs*(cfg: string) =
+ # set default value (can be overwritten):
+ if libpath == "":
+ # choose default libpath:
+ var prefix = getPrefixDir()
+- when defined(posix):
+- if prefix == "/usr": libpath = "/usr/lib/nim"
+- elif prefix == "/usr/local": libpath = "/usr/local/lib/nim"
+- else: libpath = joinPath(prefix, "lib")
+- else: libpath = joinPath(prefix, "lib")
++ libpath = joinPath(prefix, "lib/nim")
++ if not existsDir(libpath): libpath = joinPath(prefix, "lib")
+
+ if optSkipConfigFile notin gGlobalOptions:
+ readConfigFile(getSystemConfigPath(cfg))
diff --git a/lang/nimrod/files/patch-config-nimrod.cfg b/lang/nim/files/patch-config-nim.cfg
index 6f15a2f955c4..ac454a2ae4e1 100644
--- a/lang/nimrod/files/patch-config-nimrod.cfg
+++ b/lang/nim/files/patch-config-nim.cfg
@@ -1,14 +1,15 @@
---- config/nimrod.cfg.orig
-+++ config/nimrod.cfg
-@@ -67,11 +67,6 @@
- gpp.options.linker = "-ldl"
+--- config/nim.cfg.orig
++++ config/nim.cfg
+@@ -78,12 +78,6 @@
clang.options.linker = "-ldl"
tcc.options.linker = "-ldl"
-- @else:
+ @end
+- @if bsd or haiku:
- # BSD got posix_spawn only recently, so we deactivate it for osproc:
- define:useFork
- # at least NetBSD has problems with thread local storage:
- tlsEmulation:on
- @end
+- @end
@end
+ # Configuration for the Intel C/C++ compiler:
diff --git a/lang/nimrod/files/patch-install.sh b/lang/nim/files/patch-install.sh
index 158f18adfe06..b91735d1e083 100644
--- a/lang/nimrod/files/patch-install.sh
+++ b/lang/nim/files/patch-install.sh
@@ -2,7 +2,7 @@
+++ install.sh
@@ -15,39 +15,14 @@
"--help"|"-h"|"help"|"h")
- echo "Nimrod installation script"
+ echo "Nim installation script"
echo "Usage: [sudo] sh install.sh DIR"
- echo "Where DIR may be:"
- echo " /usr/bin"
@@ -16,32 +16,32 @@
- "/usr/bin")
- bindir=/usr/bin
- configdir=/etc
-- libdir=/usr/lib/nimrod
-- docdir=/usr/share/nimrod/doc
-- datadir=/usr/share/nimrod/data
+- libdir=/usr/lib/nim
+- docdir=/usr/share/nim/doc
+- datadir=/usr/share/nim/data
- ;;
- "/usr/local/bin")
- bindir=/usr/local/bin
- configdir=/etc
-- libdir=/usr/local/lib/nimrod
-- docdir=/usr/local/share/nimrod/doc
-- datadir=/usr/local/share/nimrod/data
+- libdir=/usr/local/lib/nim
+- docdir=/usr/local/share/nim/doc
+- datadir=/usr/local/share/nim/data
- ;;
*)
-- bindir="$1/nimrod/bin"
-- configdir="$1/nimrod/config"
-- libdir="$1/nimrod/lib"
-- docdir="$1/nimrod/doc"
-- datadir="$1/nimrod/data"
+- bindir="$1/nim/bin"
+- configdir="$1/nim/config"
+- libdir="$1/nim/lib"
+- docdir="$1/nim/doc"
+- datadir="$1/nim/data"
-
-- mkdir -p $1/nimrod
+- mkdir -p $1/nim
- mkdir -p $bindir
- mkdir -p $configdir
-+ bindir=$1/bin
-+ configdir=$1/etc
-+ libdir=$1/lib/nimrod
-+ docdir=$1/share/doc/nimrod
-+ datadir=$1/share/nimrod
++ bindir="$1/bin"
++ configdir="$1/etc"
++ libdir="$1/lib/nim"
++ docdir="$1/share/doc/nim"
++ datadir="$1/share/nim"
;;
esac
mkdir -p $libdir
diff --git a/lang/nim/files/patch-lib-posix-posix.nim b/lang/nim/files/patch-lib-posix-posix.nim
new file mode 100644
index 000000000000..516f94637607
--- /dev/null
+++ b/lang/nim/files/patch-lib-posix-posix.nim
@@ -0,0 +1,11 @@
+--- lib/posix/posix.nim.orig
++++ lib/posix/posix.nim
+@@ -453,7 +453,7 @@
+ l_linger*: cint ## Linger time, in seconds.
+
+ TInPort* = int16 ## unsigned!
+- TInAddrScalar* = int32 ## unsigned!
++ TInAddrScalar* {.importc: "u_int32_t", header: "<sys/types.h>", final, pure.} = int32 ## unsigned!
+
+ TInAddrT* {.importc: "in_addr_t", pure, final,
+ header: "<netinet/in.h>".} = int32 ## unsigned!
diff --git a/lang/nim/files/patch-lib-pure-os.nim b/lang/nim/files/patch-lib-pure-os.nim
new file mode 100644
index 000000000000..c72f506e4a0e
--- /dev/null
+++ b/lang/nim/files/patch-lib-pure-os.nim
@@ -0,0 +1,12 @@
+--- lib/pure/os.nim.orig
++++ lib/pure/os.nim
+@@ -1785,8 +1785,7 @@
+ result = getApplAux("/proc/" & $getpid() & "/path/a.out")
+ if result.len == 0: result = getApplHeuristic()
+ elif defined(freebsd):
+- result = getApplAux("/proc/" & $getpid() & "/file")
+- if result.len == 0: result = getApplHeuristic()
++ result = getApplHeuristic()
+ elif defined(macosx):
+ var size: cuint32
+ getExecPath1(nil, size)
diff --git a/lang/nim/pkg-descr b/lang/nim/pkg-descr
new file mode 100644
index 000000000000..79fdfe16c074
--- /dev/null
+++ b/lang/nim/pkg-descr
@@ -0,0 +1,13 @@
+Nim (formerly known as "Nimrod") is a statically typed, imperative
+programming language that tries to give the programmer ultimate power
+without compromises on runtime efficiency. This means it focuses on
+compile-time mechanisms in all their various forms.
+
+Beneath a nice infix/indentation based syntax with a powerful (AST
+based, hygienic) macro system lies a semantic model that supports a soft
+realtime GC on thread local heaps. Asynchronous message passing is used
+between threads, so no "stop the world" mechanism is necessary. An unsafe
+shared memory heap is also provided for the increased efficiency that
+results from that model.
+
+WWW: http://nim-lang.org/
diff --git a/lang/nim/pkg-plist b/lang/nim/pkg-plist
new file mode 100644
index 000000000000..965c775f5aec
--- /dev/null
+++ b/lang/nim/pkg-plist
@@ -0,0 +1,206 @@
+bin/nim
+etc/nim.cfg
+etc/nimdoc.cfg
+etc/nimdoc.tex.cfg
+lib/nim/core/locks.nim
+lib/nim/core/macros.nim
+lib/nim/core/typeinfo.nim
+lib/nim/core/unsigned.nim
+lib/nim/impure/db_mysql.nim
+lib/nim/impure/db_postgres.nim
+lib/nim/impure/db_sqlite.nim
+lib/nim/impure/dialogs.nim
+lib/nim/impure/graphics.nim
+lib/nim/impure/osinfo_posix.nim
+lib/nim/impure/osinfo_win.nim
+lib/nim/impure/rdstdin.nim
+lib/nim/impure/re.nim
+lib/nim/impure/ssl.nim
+lib/nim/impure/zipfiles.nim
+lib/nim/js/dom.nim
+lib/nim/nimbase.h
+lib/nim/nimrtl.nim
+lib/nim/nimrtl.nimrod.cfg
+lib/nim/packages/docutils/highlite.nim
+lib/nim/packages/docutils/rst.nim
+lib/nim/packages/docutils/rstast.nim
+lib/nim/packages/docutils/rstgen.nim
+lib/nim/posix/epoll.nim
+lib/nim/posix/inotify.nim
+lib/nim/posix/linux.nim
+lib/nim/posix/posix.nim
+lib/nim/prelude.nim
+lib/nim/pure/actors.nim
+lib/nim/pure/actors.nim.cfg
+lib/nim/pure/algorithm.nim
+lib/nim/pure/asyncdispatch.nim
+lib/nim/pure/asyncdispatch.nimrod.cfg
+lib/nim/pure/asyncfile.nim
+lib/nim/pure/asyncftpclient.nim
+lib/nim/pure/asynchttpserver.nim
+lib/nim/pure/asyncio.nim
+lib/nim/pure/asyncnet.nim
+lib/nim/pure/base64.nim
+lib/nim/pure/basic2d.nim
+lib/nim/pure/basic3d.nim
+lib/nim/pure/browsers.nim
+lib/nim/pure/cgi.nim
+lib/nim/pure/collections/LockFreeHash.nim
+lib/nim/pure/collections/critbits.nim
+lib/nim/pure/collections/intsets.nim
+lib/nim/pure/collections/lists.nim
+lib/nim/pure/collections/queues.nim
+lib/nim/pure/collections/rtarrays.nim
+lib/nim/pure/collections/sequtils.nim
+lib/nim/pure/collections/sets.nim
+lib/nim/pure/collections/tables.nim
+lib/nim/pure/colors.nim
+lib/nim/pure/complex.nim
+lib/nim/pure/concurrency/cpuinfo.nim
+lib/nim/pure/concurrency/cpuload.nim
+lib/nim/pure/concurrency/threadpool.nim
+lib/nim/pure/concurrency/threadpool.nim.cfg
+lib/nim/pure/cookies.nim
+lib/nim/pure/dynlib.nim
+lib/nim/pure/encodings.nim
+lib/nim/pure/endians.nim
+lib/nim/pure/events.nim
+lib/nim/pure/fenv.nim
+lib/nim/pure/fsmonitor.nim
+lib/nim/pure/ftpclient.nim
+lib/nim/pure/future.nim
+lib/nim/pure/gentabs.nim
+lib/nim/pure/hashes.nim
+lib/nim/pure/htmlgen.nim
+lib/nim/pure/htmlparser.nim
+lib/nim/pure/httpclient.nim
+lib/nim/pure/httpserver.nim
+lib/nim/pure/json.nim
+lib/nim/pure/lexbase.nim
+lib/nim/pure/logging.nim
+lib/nim/pure/marshal.nim
+lib/nim/pure/matchers.nim
+lib/nim/pure/math.nim
+lib/nim/pure/md5.nim
+lib/nim/pure/memfiles.nim
+lib/nim/pure/mersenne.nim
+lib/nim/pure/mimetypes.nim
+lib/nim/pure/net.nim
+lib/nim/pure/nimprof.nim
+lib/nim/pure/nimprof.nimrod.cfg
+lib/nim/pure/numeric.nim
+lib/nim/pure/oids.nim
+lib/nim/pure/os.nim
+lib/nim/pure/osproc.nim
+lib/nim/pure/parsecfg.nim
+lib/nim/pure/parsecsv.nim
+lib/nim/pure/parseopt.nim
+lib/nim/pure/parseopt2.nim
+lib/nim/pure/parsesql.nim
+lib/nim/pure/parseurl.nim
+lib/nim/pure/parseutils.nim
+lib/nim/pure/parsexml.nim
+lib/nim/pure/pegs.nim
+lib/nim/pure/poly.nim
+lib/nim/pure/rawsockets.nim
+lib/nim/pure/rawsockets.pretty.nim
+lib/nim/pure/redis.nim
+lib/nim/pure/romans.nim
+lib/nim/pure/ropes.nim
+lib/nim/pure/scgi.nim
+lib/nim/pure/selectors.nim
+lib/nim/pure/smtp.nim
+lib/nim/pure/smtp.nimrod.cfg
+lib/nim/pure/sockets.nim
+lib/nim/pure/streams.nim
+lib/nim/pure/strtabs.nim
+lib/nim/pure/strutils.nim
+lib/nim/pure/subexes.nim
+lib/nim/pure/terminal.nim
+lib/nim/pure/times.nim
+lib/nim/pure/typetraits.nim
+lib/nim/pure/unicode.nim
+lib/nim/pure/unidecode/unidecode.nim
+lib/nim/pure/unittest.nim
+lib/nim/pure/uri.nim
+lib/nim/pure/xmldom.nim
+lib/nim/pure/xmldomparser.nim
+lib/nim/pure/xmlparser.nim
+lib/nim/pure/xmltree.nim
+lib/nim/system.nim
+lib/nim/system/alloc.nim
+lib/nim/system/ansi_c.nim
+lib/nim/system/arithm.nim
+lib/nim/system/assign.nim
+lib/nim/system/atomics.nim
+lib/nim/system/avltree.nim
+lib/nim/system/cellsets.nim
+lib/nim/system/cgprocs.nim
+lib/nim/system/channels.nim
+lib/nim/system/chcks.nim
+lib/nim/system/debugger.nim
+lib/nim/system/deepcopy.nim
+lib/nim/system/dyncalls.nim
+lib/nim/system/embedded.nim
+lib/nim/system/endb.nim
+lib/nim/system/excpt.nim
+lib/nim/system/gc.nim
+lib/nim/system/gc2.nim
+lib/nim/system/gc_ms.nim
+lib/nim/system/hti.nim
+lib/nim/system/inclrtl.nim
+lib/nim/system/jssys.nim
+lib/nim/system/mmdisp.nim
+lib/nim/system/platforms.nim
+lib/nim/system/profiler.nim
+lib/nim/system/repr.nim
+lib/nim/system/reprjs.nim
+lib/nim/system/sets.nim
+lib/nim/system/sysio.nim
+lib/nim/system/syslocks.nim
+lib/nim/system/sysspawn.nim
+lib/nim/system/sysstr.nim
+lib/nim/system/threads.nim
+lib/nim/system/timers.nim
+lib/nim/system/widestrs.nim
+lib/nim/windows/mmsystem.nim
+lib/nim/windows/nb30.nim
+lib/nim/windows/psapi.nim
+lib/nim/windows/shellapi.nim
+lib/nim/windows/shfolder.nim
+lib/nim/windows/windows.nim
+lib/nim/windows/winlean.nim
+lib/nim/wrappers/claro.nim
+lib/nim/wrappers/expat.nim
+lib/nim/wrappers/iup.nim
+lib/nim/wrappers/joyent_http_parser.nim
+lib/nim/wrappers/libcurl.nim
+lib/nim/wrappers/libsvm.nim
+lib/nim/wrappers/libuv.nim
+lib/nim/wrappers/mysql.nim
+lib/nim/wrappers/odbcsql.nim
+lib/nim/wrappers/openssl.nim
+lib/nim/wrappers/pcre.nim
+lib/nim/wrappers/pdcurses.nim
+lib/nim/wrappers/postgres.nim
+lib/nim/wrappers/readline/history.nim
+lib/nim/wrappers/readline/readline.nim
+lib/nim/wrappers/readline/rltypedefs.nim
+lib/nim/wrappers/sdl/sdl.nim
+lib/nim/wrappers/sdl/sdl_gfx.nim
+lib/nim/wrappers/sdl/sdl_image.nim
+lib/nim/wrappers/sdl/sdl_mixer.nim
+lib/nim/wrappers/sdl/sdl_mixer_nosmpeg.nim
+lib/nim/wrappers/sdl/sdl_net.nim
+lib/nim/wrappers/sdl/sdl_ttf.nim
+lib/nim/wrappers/sdl/smpeg.nim
+lib/nim/wrappers/sphinx.nim
+lib/nim/wrappers/sqlite3.nim
+lib/nim/wrappers/tinyc.nim
+lib/nim/wrappers/tre.nim
+lib/nim/wrappers/zip/libzip.nim
+lib/nim/wrappers/zip/libzip_all.c
+lib/nim/wrappers/zip/zlib.nim
+lib/nim/wrappers/zip/zzip.nim
+%%PORTDOCS%%%%DOCSDIR%%/overview.html
+
diff --git a/lang/nimrod/distinfo b/lang/nimrod/distinfo
deleted file mode 100644
index 83d2a010576b..000000000000
--- a/lang/nimrod/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (nimrod_0.9.2.zip) = 4903ff46b90caa61194551f66fdff291b1ecba8bb4eec1611373cd34ecaf7090
-SIZE (nimrod_0.9.2.zip) = 19002240
diff --git a/lang/nimrod/files/patch-compiler-nimconf.nim b/lang/nimrod/files/patch-compiler-nimconf.nim
deleted file mode 100644
index 92761fff2e3f..000000000000
--- a/lang/nimrod/files/patch-compiler-nimconf.nim
+++ /dev/null
@@ -1,25 +0,0 @@
---- compiler/nimconf.nim.orig
-+++ compiler/nimconf.nim
-@@ -213,7 +213,9 @@
- proc getSystemConfigPath(filename: string): string =
- # try standard configuration file (installation did not distribute files
- # the UNIX way)
-- result = joinPath([getPrefixDir(), "config", filename])
-+ var prefix = getPrefixDir()
-+ result = joinPath([prefix, "etc", filename])
-+ if not ExistsFile(result): result = joinPath([prefix, "config", filename])
- if not ExistsFile(result): result = "/etc/" & filename
-
- proc LoadConfigs*(cfg: string) =
-@@ -221,9 +223,8 @@
- if libpath == "":
- # choose default libpath:
- var prefix = getPrefixDir()
-- if prefix == "/usr": libpath = "/usr/lib/nimrod"
-- elif prefix == "/usr/local": libpath = "/usr/local/lib/nimrod"
-- else: libpath = joinPath(prefix, "lib")
-+ libpath = joinPath(prefix, "lib/nimrod")
-+ if not ExistsDir(libpath): libpath = joinPath(prefix, "lib")
-
- if optSkipConfigFile notin gGlobalOptions:
- readConfigFile(getSystemConfigPath(cfg))
diff --git a/lang/nimrod/files/patch-lib-pure-os.nim b/lang/nimrod/files/patch-lib-pure-os.nim
deleted file mode 100644
index e4b094fd507e..000000000000
--- a/lang/nimrod/files/patch-lib-pure-os.nim
+++ /dev/null
@@ -1,36 +0,0 @@
---- lib/pure/os.nim.orig
-+++ lib/pure/os.nim
-@@ -1389,8 +1389,6 @@
- result = getApplAux("/proc/self/exe")
- elif defined(solaris):
- result = getApplAux("/proc/" & $getpid() & "/path/a.out")
-- elif defined(freebsd):
-- result = getApplAux("/proc/" & $getpid() & "/file")
- elif defined(macosx):
- var size: cuint32
- getExecPath1(nil, size)
-@@ -1399,16 +1397,14 @@
- result = "" # error!
- else:
- # little heuristic that may work on other POSIX-like systems:
-- result = string(getEnv("_"))
-- if len(result) == 0:
-- result = string(ParamStr(0))
-- # POSIX guaranties that this contains the executable
-- # as it has been executed by the calling process
-- if len(result) > 0 and result[0] != DirSep: # not an absolute path?
-- # iterate over any path in the $PATH environment variable
-- for p in split(string(getEnv("PATH")), {PathSep}):
-- var x = joinPath(p, result)
-- if ExistsFile(x): return x
-+ result = string(ParamStr(0))
-+ # POSIX guaranties that this contains the executable
-+ # as it has been executed by the calling process
-+ if len(result) > 0 and result[0] != DirSep: # not an absolute path?
-+ # iterate over any path in the $PATH environment variable
-+ for p in split(string(getEnv("PATH")), {PathSep}):
-+ var x = joinPath(p, result)
-+ if ExistsFile(x): return x
-
- proc getApplicationFilename*(): string {.rtl, extern: "nos$1", deprecated.} =
- ## Returns the filename of the application's executable.
diff --git a/lang/nimrod/pkg-descr b/lang/nimrod/pkg-descr
deleted file mode 100644
index 01ec2b57c405..000000000000
--- a/lang/nimrod/pkg-descr
+++ /dev/null
@@ -1,13 +0,0 @@
-Nimrod is a statically typed, imperative programming language that tries
-to give the programmer ultimate power without compromises on runtime
-efficiency. This means it focuses on compile-time mechanisms in all
-their various forms.
-
-Beneath a nice infix/indentation based syntax with a powerful (AST
-based, hygienic) macro system lies a semantic model that supports a soft
-realtime GC on thread local heaps. Asynchronous message passing is used
-between threads, so no "stop the world" mechanism is necessary. An
-unsafe shared memory heap is also provided for the increased efficiency
-that results from that model.
-
-WWW: http://nimrod-code.org/
diff --git a/lang/nimrod/pkg-plist b/lang/nimrod/pkg-plist
deleted file mode 100644
index 98fb171c6384..000000000000
--- a/lang/nimrod/pkg-plist
+++ /dev/null
@@ -1,372 +0,0 @@
-bin/nimrod
-etc/nimdoc.cfg
-etc/nimdoc.tex.cfg
-etc/nimrod.cfg
-lib/nimrod/core/locks.nim
-lib/nimrod/core/macros.nim
-lib/nimrod/core/typeinfo.nim
-lib/nimrod/core/unsigned.nim
-lib/nimrod/impure/db_mongo.nim
-lib/nimrod/impure/db_mysql.nim
-lib/nimrod/impure/db_postgres.nim
-lib/nimrod/impure/db_sqlite.nim
-lib/nimrod/impure/dialogs.nim
-lib/nimrod/impure/graphics.nim
-lib/nimrod/impure/osinfo_posix.nim
-lib/nimrod/impure/osinfo_win.nim
-lib/nimrod/impure/rdstdin.nim
-lib/nimrod/impure/re.nim
-lib/nimrod/impure/ssl.nim
-lib/nimrod/impure/web.nim
-lib/nimrod/impure/zipfiles.nim
-lib/nimrod/js/dom.nim
-lib/nimrod/nimbase.h
-lib/nimrod/nimrtl.nim
-lib/nimrod/nimrtl.nimrod.cfg
-lib/nimrod/packages/docutils/highlite.nim
-lib/nimrod/packages/docutils/rst.nim
-lib/nimrod/packages/docutils/rstast.nim
-lib/nimrod/packages/docutils/rstgen.nim
-lib/nimrod/posix/inotify.nim
-lib/nimrod/posix/posix.nim
-lib/nimrod/prelude.nim
-lib/nimrod/pure/actors.nim
-lib/nimrod/pure/algorithm.nim
-lib/nimrod/pure/asyncio.nim
-lib/nimrod/pure/base64.nim
-lib/nimrod/pure/browsers.nim
-lib/nimrod/pure/cgi.nim
-lib/nimrod/pure/collections/critbits.nim
-lib/nimrod/pure/collections/intsets.nim
-lib/nimrod/pure/collections/lists.nim
-lib/nimrod/pure/collections/queues.nim
-lib/nimrod/pure/collections/sequtils.nim
-lib/nimrod/pure/collections/sets.nim
-lib/nimrod/pure/collections/tables.nim
-lib/nimrod/pure/colors.nim
-lib/nimrod/pure/complex.nim
-lib/nimrod/pure/cookies.nim
-lib/nimrod/pure/dynlib.nim
-lib/nimrod/pure/encodings.nim
-lib/nimrod/pure/endians.nim
-lib/nimrod/pure/events.nim
-lib/nimrod/pure/fsmonitor.nim
-lib/nimrod/pure/ftpclient.nim
-lib/nimrod/pure/gentabs.nim
-lib/nimrod/pure/hashes.nim
-lib/nimrod/pure/htmlgen.nim
-lib/nimrod/pure/htmlparser.nim
-lib/nimrod/pure/httpclient.nim
-lib/nimrod/pure/httpserver.nim
-lib/nimrod/pure/irc.nim
-lib/nimrod/pure/json.nim
-lib/nimrod/pure/lexbase.nim
-lib/nimrod/pure/marshal.nim
-lib/nimrod/pure/matchers.nim
-lib/nimrod/pure/math.nim
-lib/nimrod/pure/md5.nim
-lib/nimrod/pure/memfiles.nim
-lib/nimrod/pure/mimetypes.nim
-lib/nimrod/pure/nimprof.nim
-lib/nimrod/pure/oids.nim
-lib/nimrod/pure/os.nim
-lib/nimrod/pure/osproc.nim
-lib/nimrod/pure/parsecfg.nim
-lib/nimrod/pure/parsecsv.nim
-lib/nimrod/pure/parseopt.nim
-lib/nimrod/pure/parsesql.nim
-lib/nimrod/pure/parseurl.nim
-lib/nimrod/pure/parseutils.nim
-lib/nimrod/pure/parsexml.nim
-lib/nimrod/pure/pegs.nim
-lib/nimrod/pure/redis.nim
-lib/nimrod/pure/romans.nim
-lib/nimrod/pure/ropes.nim
-lib/nimrod/pure/scgi.nim
-lib/nimrod/pure/smtp.nim
-lib/nimrod/pure/sockets.nim
-lib/nimrod/pure/streams.nim
-lib/nimrod/pure/strtabs.nim
-lib/nimrod/pure/strutils.nim
-lib/nimrod/pure/subexes.nim
-lib/nimrod/pure/terminal.nim
-lib/nimrod/pure/times.nim
-lib/nimrod/pure/typetraits.nim
-lib/nimrod/pure/unicode.nim
-lib/nimrod/pure/unittest.nim
-lib/nimrod/pure/uri.nim
-lib/nimrod/pure/xmldom.nim
-lib/nimrod/pure/xmldomparser.nim
-lib/nimrod/pure/xmlparser.nim
-lib/nimrod/pure/xmltree.nim
-lib/nimrod/system.nim
-lib/nimrod/system/alloc.nim
-lib/nimrod/system/ansi_c.nim
-lib/nimrod/system/arithm.nim
-lib/nimrod/system/assign.nim
-lib/nimrod/system/atomics.nim
-lib/nimrod/system/avltree.nim
-lib/nimrod/system/cellsets.nim
-lib/nimrod/system/cgprocs.nim
-lib/nimrod/system/channels.nim
-lib/nimrod/system/debugger.nim
-lib/nimrod/system/dyncalls.nim
-lib/nimrod/system/embedded.nim
-lib/nimrod/system/endb.nim
-lib/nimrod/system/excpt.nim
-lib/nimrod/system/gc.nim
-lib/nimrod/system/gc2.nim
-lib/nimrod/system/gc_ms.nim
-lib/nimrod/system/hti.nim
-lib/nimrod/system/inclrtl.nim
-lib/nimrod/system/jssys.nim
-lib/nimrod/system/mmdisp.nim
-lib/nimrod/system/profiler.nim
-lib/nimrod/system/repr.nim
-lib/nimrod/system/reprjs.nim
-lib/nimrod/system/sets.nim
-lib/nimrod/system/sysio.nim
-lib/nimrod/system/syslocks.nim
-lib/nimrod/system/sysstr.nim
-lib/nimrod/system/threads.nim
-lib/nimrod/system/timers.nim
-lib/nimrod/system/widestrs.nim
-lib/nimrod/windows/mmsystem.nim
-lib/nimrod/windows/nb30.nim
-lib/nimrod/windows/ole2.nim
-lib/nimrod/windows/psapi.nim
-lib/nimrod/windows/shellapi.nim
-lib/nimrod/windows/shfolder.nim
-lib/nimrod/windows/windows.nim
-lib/nimrod/windows/winlean.nim
-lib/nimrod/wrappers/cairo/cairo.nim
-lib/nimrod/wrappers/cairo/cairoft.nim
-lib/nimrod/wrappers/cairo/cairowin32.nim
-lib/nimrod/wrappers/cairo/cairoxlib.nim
-lib/nimrod/wrappers/claro.nim
-lib/nimrod/wrappers/expat.nim
-lib/nimrod/wrappers/gtk/atk.nim
-lib/nimrod/wrappers/gtk/gdk2.nim
-lib/nimrod/wrappers/gtk/gdk2pixbuf.nim
-lib/nimrod/wrappers/gtk/gdkglext.nim
-lib/nimrod/wrappers/gtk/glib2.nim
-lib/nimrod/wrappers/gtk/gtk2.nim
-lib/nimrod/wrappers/gtk/gtkglext.nim
-lib/nimrod/wrappers/gtk/gtkhtml.nim
-lib/nimrod/wrappers/gtk/libglade2.nim
-lib/nimrod/wrappers/gtk/pango.nim
-lib/nimrod/wrappers/gtk/pangoutils.nim
-lib/nimrod/wrappers/iup.nim
-lib/nimrod/wrappers/joyent_http_parser.nim
-lib/nimrod/wrappers/libcurl.nim
-lib/nimrod/wrappers/libffi.nim
-lib/nimrod/wrappers/libsvm.nim
-lib/nimrod/wrappers/libuv.nim
-lib/nimrod/wrappers/lua/lauxlib.nim
-lib/nimrod/wrappers/lua/lua.nim
-lib/nimrod/wrappers/lua/lualib.nim
-lib/nimrod/wrappers/mongo.nim
-lib/nimrod/wrappers/mysql.nim
-lib/nimrod/wrappers/odbcsql.nim
-lib/nimrod/wrappers/opengl/gl.nim
-lib/nimrod/wrappers/opengl/glext.nim
-lib/nimrod/wrappers/opengl/glu.nim
-lib/nimrod/wrappers/opengl/glut.nim
-lib/nimrod/wrappers/opengl/glx.nim
-lib/nimrod/wrappers/opengl/opengl.nim
-lib/nimrod/wrappers/opengl/wingl.nim
-lib/nimrod/wrappers/openssl.nim
-lib/nimrod/wrappers/pcre.nim
-lib/nimrod/wrappers/pdcurses.nim
-lib/nimrod/wrappers/postgres.nim
-lib/nimrod/wrappers/python.nim
-lib/nimrod/wrappers/readline/history.nim
-lib/nimrod/wrappers/readline/readline.nim
-lib/nimrod/wrappers/readline/rltypedefs.nim
-lib/nimrod/wrappers/sdl/sdl.nim
-lib/nimrod/wrappers/sdl/sdl_gfx.nim
-lib/nimrod/wrappers/sdl/sdl_image.nim
-lib/nimrod/wrappers/sdl/sdl_mixer.nim
-lib/nimrod/wrappers/sdl/sdl_mixer_nosmpeg.nim
-lib/nimrod/wrappers/sdl/sdl_net.nim
-lib/nimrod/wrappers/sdl/sdl_ttf.nim
-lib/nimrod/wrappers/sdl/smpeg.nim
-lib/nimrod/wrappers/sphinx.nim
-lib/nimrod/wrappers/sqlite3.nim
-lib/nimrod/wrappers/tcl.nim
-lib/nimrod/wrappers/tinyc.nim
-lib/nimrod/wrappers/tre.nim
-lib/nimrod/wrappers/x11/cursorfont.nim
-lib/nimrod/wrappers/x11/keysym.nim
-lib/nimrod/wrappers/x11/x.nim
-lib/nimrod/wrappers/x11/xatom.nim
-lib/nimrod/wrappers/x11/xcms.nim
-lib/nimrod/wrappers/x11/xf86dga.nim
-lib/nimrod/wrappers/x11/xf86vmode.nim
-lib/nimrod/wrappers/x11/xi.nim
-lib/nimrod/wrappers/x11/xinerama.nim
-lib/nimrod/wrappers/x11/xkb.nim
-lib/nimrod/wrappers/x11/xkblib.nim
-lib/nimrod/wrappers/x11/xlib.nim
-lib/nimrod/wrappers/x11/xrandr.nim
-lib/nimrod/wrappers/x11/xrender.nim
-lib/nimrod/wrappers/x11/xresource.nim
-lib/nimrod/wrappers/x11/xshm.nim
-lib/nimrod/wrappers/x11/xutil.nim
-lib/nimrod/wrappers/x11/xv.nim
-lib/nimrod/wrappers/x11/xvlib.nim
-lib/nimrod/wrappers/zip/libzip.nim
-lib/nimrod/wrappers/zip/libzip_all.c
-lib/nimrod/wrappers/zip/zlib.nim
-lib/nimrod/wrappers/zip/zzip.nim
-lib/nimrod/wrappers/zmq.nim
-%%PORTDOCS%%%%DOCSDIR%%/abstypes.txt
-%%PORTDOCS%%%%DOCSDIR%%/actors.html
-%%PORTDOCS%%%%DOCSDIR%%/advopt.txt
-%%PORTDOCS%%%%DOCSDIR%%/algorithm.html
-%%PORTDOCS%%%%DOCSDIR%%/apis.html
-%%PORTDOCS%%%%DOCSDIR%%/apis.txt
-%%PORTDOCS%%%%DOCSDIR%%/astspec.txt
-%%PORTDOCS%%%%DOCSDIR%%/asyncio.html
-%%PORTDOCS%%%%DOCSDIR%%/base64.html
-%%PORTDOCS%%%%DOCSDIR%%/basicopt.txt
-%%PORTDOCS%%%%DOCSDIR%%/browsers.html
-%%PORTDOCS%%%%DOCSDIR%%/c2nim.html
-%%PORTDOCS%%%%DOCSDIR%%/c2nim.pdf
-%%PORTDOCS%%%%DOCSDIR%%/c2nim.txt
-%%PORTDOCS%%%%DOCSDIR%%/cgi.html
-%%PORTDOCS%%%%DOCSDIR%%/channels.html
-%%PORTDOCS%%%%DOCSDIR%%/colors.html
-%%PORTDOCS%%%%DOCSDIR%%/complex.html
-%%PORTDOCS%%%%DOCSDIR%%/cookies.html
-%%PORTDOCS%%%%DOCSDIR%%/critbits.html
-%%PORTDOCS%%%%DOCSDIR%%/db_mongo.html
-%%PORTDOCS%%%%DOCSDIR%%/db_mysql.html
-%%PORTDOCS%%%%DOCSDIR%%/db_postgres.html
-%%PORTDOCS%%%%DOCSDIR%%/db_sqlite.html
-%%PORTDOCS%%%%DOCSDIR%%/docs.txt
-%%PORTDOCS%%%%DOCSDIR%%/dom.html
-%%PORTDOCS%%%%DOCSDIR%%/dynlib.html
-%%PORTDOCS%%%%DOCSDIR%%/effects.txt
-%%PORTDOCS%%%%DOCSDIR%%/encodings.html
-%%PORTDOCS%%%%DOCSDIR%%/endb.html
-%%PORTDOCS%%%%DOCSDIR%%/endb.txt
-%%PORTDOCS%%%%DOCSDIR%%/endians.html
-%%PORTDOCS%%%%DOCSDIR%%/estp.html
-%%PORTDOCS%%%%DOCSDIR%%/estp.txt
-%%PORTDOCS%%%%DOCSDIR%%/events.html
-%%PORTDOCS%%%%DOCSDIR%%/filelist.txt
-%%PORTDOCS%%%%DOCSDIR%%/filters.html
-%%PORTDOCS%%%%DOCSDIR%%/filters.txt
-%%PORTDOCS%%%%DOCSDIR%%/fsmonitor.html
-%%PORTDOCS%%%%DOCSDIR%%/ftpclient.html
-%%PORTDOCS%%%%DOCSDIR%%/gc.html
-%%PORTDOCS%%%%DOCSDIR%%/gc.pdf
-%%PORTDOCS%%%%DOCSDIR%%/gc.txt
-%%PORTDOCS%%%%DOCSDIR%%/grammar.txt
-%%PORTDOCS%%%%DOCSDIR%%/graphics.html
-%%PORTDOCS%%%%DOCSDIR%%/hashes.html
-%%PORTDOCS%%%%DOCSDIR%%/htmlgen.html
-%%PORTDOCS%%%%DOCSDIR%%/htmlparser.html
-%%PORTDOCS%%%%DOCSDIR%%/httpclient.html
-%%PORTDOCS%%%%DOCSDIR%%/httpserver.html
-%%PORTDOCS%%%%DOCSDIR%%/intern.html
-%%PORTDOCS%%%%DOCSDIR%%/intern.txt
-%%PORTDOCS%%%%DOCSDIR%%/intsets.html
-%%PORTDOCS%%%%DOCSDIR%%/irc.html
-%%PORTDOCS%%%%DOCSDIR%%/json.html
-%%PORTDOCS%%%%DOCSDIR%%/keywords.txt
-%%PORTDOCS%%%%DOCSDIR%%/lexbase.html
-%%PORTDOCS%%%%DOCSDIR%%/lib.html
-%%PORTDOCS%%%%DOCSDIR%%/lib.pdf
-%%PORTDOCS%%%%DOCSDIR%%/lib.txt
-%%PORTDOCS%%%%DOCSDIR%%/lists.html
-%%PORTDOCS%%%%DOCSDIR%%/locks.html
-%%PORTDOCS%%%%DOCSDIR%%/macros.html
-%%PORTDOCS%%%%DOCSDIR%%/manual.html
-%%PORTDOCS%%%%DOCSDIR%%/manual.pdf
-%%PORTDOCS%%%%DOCSDIR%%/manual.txt
-%%PORTDOCS%%%%DOCSDIR%%/marshal.html
-%%PORTDOCS%%%%DOCSDIR%%/matchers.html
-%%PORTDOCS%%%%DOCSDIR%%/math.html
-%%PORTDOCS%%%%DOCSDIR%%/memfiles.html
-%%PORTDOCS%%%%DOCSDIR%%/mimetypes.html
-%%PORTDOCS%%%%DOCSDIR%%/mytest.cfg
-%%PORTDOCS%%%%DOCSDIR%%/nimgrep.html
-%%PORTDOCS%%%%DOCSDIR%%/nimgrep.txt
-%%PORTDOCS%%%%DOCSDIR%%/niminst.html
-%%PORTDOCS%%%%DOCSDIR%%/niminst.pdf
-%%PORTDOCS%%%%DOCSDIR%%/niminst.txt
-%%PORTDOCS%%%%DOCSDIR%%/nimprof.html
-%%PORTDOCS%%%%DOCSDIR%%/nimrodc.html
-%%PORTDOCS%%%%DOCSDIR%%/nimrodc.pdf
-%%PORTDOCS%%%%DOCSDIR%%/nimrodc.txt
-%%PORTDOCS%%%%DOCSDIR%%/oids.html
-%%PORTDOCS%%%%DOCSDIR%%/os.html
-%%PORTDOCS%%%%DOCSDIR%%/osproc.html
-%%PORTDOCS%%%%DOCSDIR%%/overview.html
-%%PORTDOCS%%%%DOCSDIR%%/overview.txt
-%%PORTDOCS%%%%DOCSDIR%%/parsecfg.html
-%%PORTDOCS%%%%DOCSDIR%%/parsecsv.html
-%%PORTDOCS%%%%DOCSDIR%%/parseopt.html
-%%PORTDOCS%%%%DOCSDIR%%/parsesql.html
-%%PORTDOCS%%%%DOCSDIR%%/parseutils.html
-%%PORTDOCS%%%%DOCSDIR%%/parsexml.html
-%%PORTDOCS%%%%DOCSDIR%%/pegdocs.txt
-%%PORTDOCS%%%%DOCSDIR%%/pegs.html
-%%PORTDOCS%%%%DOCSDIR%%/queues.html
-%%PORTDOCS%%%%DOCSDIR%%/rdstdin.html
-%%PORTDOCS%%%%DOCSDIR%%/re.html
-%%PORTDOCS%%%%DOCSDIR%%/readme.txt
-%%PORTDOCS%%%%DOCSDIR%%/redis.html
-%%PORTDOCS%%%%DOCSDIR%%/regexprs.txt
-%%PORTDOCS%%%%DOCSDIR%%/ropes.html
-%%PORTDOCS%%%%DOCSDIR%%/rst.txt
-%%PORTDOCS%%%%DOCSDIR%%/scgi.html
-%%PORTDOCS%%%%DOCSDIR%%/sdl.html
-%%PORTDOCS%%%%DOCSDIR%%/sdl_gfx.html
-%%PORTDOCS%%%%DOCSDIR%%/sdl_image.html
-%%PORTDOCS%%%%DOCSDIR%%/sdl_mixer.html
-%%PORTDOCS%%%%DOCSDIR%%/sdl_mixer_nosmpeg.html
-%%PORTDOCS%%%%DOCSDIR%%/sdl_net.html
-%%PORTDOCS%%%%DOCSDIR%%/sdl_ttf.html
-%%PORTDOCS%%%%DOCSDIR%%/sequtils.html
-%%PORTDOCS%%%%DOCSDIR%%/sets.html
-%%PORTDOCS%%%%DOCSDIR%%/smpeg.html
-%%PORTDOCS%%%%DOCSDIR%%/smtp.html
-%%PORTDOCS%%%%DOCSDIR%%/sockets.html
-%%PORTDOCS%%%%DOCSDIR%%/sphinx.html
-%%PORTDOCS%%%%DOCSDIR%%/ssl.html
-%%PORTDOCS%%%%DOCSDIR%%/streams.html
-%%PORTDOCS%%%%DOCSDIR%%/strtabs.html
-%%PORTDOCS%%%%DOCSDIR%%/strutils.html
-%%PORTDOCS%%%%DOCSDIR%%/subexes.html
-%%PORTDOCS%%%%DOCSDIR%%/subexes.txt
-%%PORTDOCS%%%%DOCSDIR%%/system.html
-%%PORTDOCS%%%%DOCSDIR%%/tables.html
-%%PORTDOCS%%%%DOCSDIR%%/terminal.html
-%%PORTDOCS%%%%DOCSDIR%%/theindex.html
-%%PORTDOCS%%%%DOCSDIR%%/threads.html
-%%PORTDOCS%%%%DOCSDIR%%/times.html
-%%PORTDOCS%%%%DOCSDIR%%/tools.html
-%%PORTDOCS%%%%DOCSDIR%%/tools.txt
-%%PORTDOCS%%%%DOCSDIR%%/trmacros.html
-%%PORTDOCS%%%%DOCSDIR%%/trmacros.txt
-%%PORTDOCS%%%%DOCSDIR%%/tut1.html
-%%PORTDOCS%%%%DOCSDIR%%/tut1.pdf
-%%PORTDOCS%%%%DOCSDIR%%/tut1.txt
-%%PORTDOCS%%%%DOCSDIR%%/tut2.html
-%%PORTDOCS%%%%DOCSDIR%%/tut2.pdf
-%%PORTDOCS%%%%DOCSDIR%%/tut2.txt
-%%PORTDOCS%%%%DOCSDIR%%/typeinfo.html
-%%PORTDOCS%%%%DOCSDIR%%/unicode.html
-%%PORTDOCS%%%%DOCSDIR%%/unidecode.html
-%%PORTDOCS%%%%DOCSDIR%%/unsigned.html
-%%PORTDOCS%%%%DOCSDIR%%/uri.html
-%%PORTDOCS%%%%DOCSDIR%%/web.html
-%%PORTDOCS%%%%DOCSDIR%%/xmldom.html
-%%PORTDOCS%%%%DOCSDIR%%/xmldomparser.html
-%%PORTDOCS%%%%DOCSDIR%%/xmlparser.html
-%%PORTDOCS%%%%DOCSDIR%%/xmltree.html
-%%PORTDOCS%%%%DOCSDIR%%/zipfiles.html
-%%PORTDOCS%%%%DOCSDIR%%/zmq.html