aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>1999-07-06 01:28:28 +0000
committerChris Piazza <cpiazza@FreeBSD.org>1999-07-06 01:28:28 +0000
commit59dc9e23d04539a365808dea840c9755fa87dc30 (patch)
treec30fcce38931e4862623d82b764e7ecb6a25bab4 /lang
parent1e2b05a04245a530d236ce4bb4ea85d71da021ba (diff)
downloadports-59dc9e23d04539a365808dea840c9755fa87dc30.tar.gz
ports-59dc9e23d04539a365808dea840c9755fa87dc30.zip
Lua:
A programming language originally designed for extending applications, but also frequently used as a general-purpose, stand-alone language. Lua combines simple procedural syntax (similar to Pascal) with powerful data description constructs based on associative arrays and extensible semantics. PR: 12459 Submitted by: Richard Kiss <richard@homemail.com>
Notes
Notes: svn path=/head/; revision=20090
Diffstat (limited to 'lang')
-rw-r--r--lang/lua/Makefile33
-rw-r--r--lang/lua/distinfo1
-rw-r--r--lang/lua/files/patch-aa17
-rw-r--r--lang/lua/pkg-comment1
-rw-r--r--lang/lua/pkg-descr21
-rw-r--r--lang/lua/pkg-plist7
-rw-r--r--lang/lua4/Makefile33
-rw-r--r--lang/lua4/distinfo1
-rw-r--r--lang/lua4/files/patch-aa17
-rw-r--r--lang/lua4/pkg-comment1
-rw-r--r--lang/lua4/pkg-descr21
-rw-r--r--lang/lua4/pkg-plist7
-rw-r--r--lang/lua50/Makefile33
-rw-r--r--lang/lua50/distinfo1
-rw-r--r--lang/lua50/files/patch-aa17
-rw-r--r--lang/lua50/pkg-comment1
-rw-r--r--lang/lua50/pkg-descr21
-rw-r--r--lang/lua50/pkg-plist7
18 files changed, 240 insertions, 0 deletions
diff --git a/lang/lua/Makefile b/lang/lua/Makefile
new file mode 100644
index 000000000000..eb07cbe012a2
--- /dev/null
+++ b/lang/lua/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: lua
+# Version required: 3.1
+# Date created: 27 June 1999
+# Whom: Richard Kiss <richard@homemail.com>
+#
+# $Id$
+#
+
+DISTNAME= lua-3.1
+CATEGORIES= lang
+MASTER_SITES= ftp://ftp.tecgraf.puc-rio.br/pub/lua/ \
+ ftp://csg.uwaterloo.ca/pub/lhf/lua/ \
+ ftp://ftp.cdrom.com/pub/languages/lua/ \
+ ftp://ftp.ntua.gr/pub/lang/lua/ \
+ ftp://ftp.uni-trier.de/pub/languages/lua/ \
+ ftp://ftp.gwdg.de/pub/languages/lua/
+
+MAINTAINER= richard@homemail.com
+
+MAN1= luac.1
+WRKSRC= ${WRKDIR}/lua
+
+do-install:
+ @ ${MKDIR} ${PREFIX}/share/doc/lua
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/bin/lua ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/bin/luac ${PREFIX}/bin
+ @ ${INSTALL_MAN} ${WRKSRC}/doc/luac.man ${PREFIX}/man/man1/luac.1
+ @ ${INSTALL_DATA} ${WRKSRC}/doc/idx.html ${PREFIX}/share/doc/lua
+ @ ${INSTALL_DATA} ${WRKSRC}/doc/index.html ${PREFIX}/share/doc/lua
+ @ ${INSTALL_DATA} ${WRKSRC}/doc/luac.html ${PREFIX}/share/doc/lua
+ @ ${INSTALL_DATA} ${WRKSRC}/doc/manual.html ${PREFIX}/share/doc/lua
+
+.include <bsd.port.mk>
diff --git a/lang/lua/distinfo b/lang/lua/distinfo
new file mode 100644
index 000000000000..f55e08bb1cca
--- /dev/null
+++ b/lang/lua/distinfo
@@ -0,0 +1 @@
+MD5 (lua-3.1.tar.gz) = d677f3827167eefdefc7b211397cfdfb
diff --git a/lang/lua/files/patch-aa b/lang/lua/files/patch-aa
new file mode 100644
index 000000000000..101f1a83e236
--- /dev/null
+++ b/lang/lua/files/patch-aa
@@ -0,0 +1,17 @@
+--- config.orig Tue Jul 6 18:17:42 1999
++++ config Tue Jul 6 18:18:03 1999
+@@ -3,7 +3,7 @@
+ # == CHANGE THE SETTINGS BELOW TO SUIT YOUR ENVIRONMENT ======================
+
+ # you need an ANSI C compiler. gcc is a popular one.
+-CC= gcc
++CC?= gcc
+ WARN= -ansi -Wall
+
+ # on SGI's, cc is ANSI.
+@@ -51,4 +51,4 @@
+ INCS= -I$(INC) $(EXTRA_INCS)
+ DEFS= $(COMPAT) $(NUMBER) $(OLD_ANSI) $(EXTRA_DEFS)
+
+-CFLAGS= -O2 $(WARN) $(INCS) $(DEFS)
++CFLAGS+= $(WARN) $(INCS) $(DEFS)
diff --git a/lang/lua/pkg-comment b/lang/lua/pkg-comment
new file mode 100644
index 000000000000..2ba3321e13d8
--- /dev/null
+++ b/lang/lua/pkg-comment
@@ -0,0 +1 @@
+Small, compilable scripting language providing easy access to C code
diff --git a/lang/lua/pkg-descr b/lang/lua/pkg-descr
new file mode 100644
index 000000000000..a232582174e2
--- /dev/null
+++ b/lang/lua/pkg-descr
@@ -0,0 +1,21 @@
+Lua is a programming language originally designed for extending applications,
+but also frequently used as a general-purpose, stand-alone language. Lua
+combines simple procedural syntax (similar to Pascal) with powerful data
+description constructs based on associative arrays and extensible semantics.
+Lua is dynamically typed, interpreted from bytecodes, and has automatic memory
+management with garbage collection, making it ideal for configuration,
+scripting, and rapid prototyping.
+
+A fundamental concept in the design of Lua is to provide meta-mechanisms for
+implementing features, instead of providing a host of features directly in
+the language. For example, although Lua is not a pure object-oriented
+language, it does provide meta-mechanisms for implementing classes and
+inheritance. Lua's meta-mechanisms bring an economy of concepts and keep the
+language small, while allowing the semantics to be extended in unconventional
+ways. Extensible semantics is a distinguishing feature of Lua.
+
+Lua is implemented as a small library of C functions, written in ANSI C, and
+compiles unmodified in all known platforms. The implementation goals are
+simplicity, efficiency, portability, and low embedding cost.
+
+WWW: http://www.tecgraf.puc-rio.br/lua/
diff --git a/lang/lua/pkg-plist b/lang/lua/pkg-plist
new file mode 100644
index 000000000000..e9e4b9b78eec
--- /dev/null
+++ b/lang/lua/pkg-plist
@@ -0,0 +1,7 @@
+bin/lua
+bin/luac
+share/doc/lua/idx.html
+share/doc/lua/index.html
+share/doc/lua/luac.html
+share/doc/lua/manual.html
+@dirrm share/doc/lua
diff --git a/lang/lua4/Makefile b/lang/lua4/Makefile
new file mode 100644
index 000000000000..eb07cbe012a2
--- /dev/null
+++ b/lang/lua4/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: lua
+# Version required: 3.1
+# Date created: 27 June 1999
+# Whom: Richard Kiss <richard@homemail.com>
+#
+# $Id$
+#
+
+DISTNAME= lua-3.1
+CATEGORIES= lang
+MASTER_SITES= ftp://ftp.tecgraf.puc-rio.br/pub/lua/ \
+ ftp://csg.uwaterloo.ca/pub/lhf/lua/ \
+ ftp://ftp.cdrom.com/pub/languages/lua/ \
+ ftp://ftp.ntua.gr/pub/lang/lua/ \
+ ftp://ftp.uni-trier.de/pub/languages/lua/ \
+ ftp://ftp.gwdg.de/pub/languages/lua/
+
+MAINTAINER= richard@homemail.com
+
+MAN1= luac.1
+WRKSRC= ${WRKDIR}/lua
+
+do-install:
+ @ ${MKDIR} ${PREFIX}/share/doc/lua
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/bin/lua ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/bin/luac ${PREFIX}/bin
+ @ ${INSTALL_MAN} ${WRKSRC}/doc/luac.man ${PREFIX}/man/man1/luac.1
+ @ ${INSTALL_DATA} ${WRKSRC}/doc/idx.html ${PREFIX}/share/doc/lua
+ @ ${INSTALL_DATA} ${WRKSRC}/doc/index.html ${PREFIX}/share/doc/lua
+ @ ${INSTALL_DATA} ${WRKSRC}/doc/luac.html ${PREFIX}/share/doc/lua
+ @ ${INSTALL_DATA} ${WRKSRC}/doc/manual.html ${PREFIX}/share/doc/lua
+
+.include <bsd.port.mk>
diff --git a/lang/lua4/distinfo b/lang/lua4/distinfo
new file mode 100644
index 000000000000..f55e08bb1cca
--- /dev/null
+++ b/lang/lua4/distinfo
@@ -0,0 +1 @@
+MD5 (lua-3.1.tar.gz) = d677f3827167eefdefc7b211397cfdfb
diff --git a/lang/lua4/files/patch-aa b/lang/lua4/files/patch-aa
new file mode 100644
index 000000000000..101f1a83e236
--- /dev/null
+++ b/lang/lua4/files/patch-aa
@@ -0,0 +1,17 @@
+--- config.orig Tue Jul 6 18:17:42 1999
++++ config Tue Jul 6 18:18:03 1999
+@@ -3,7 +3,7 @@
+ # == CHANGE THE SETTINGS BELOW TO SUIT YOUR ENVIRONMENT ======================
+
+ # you need an ANSI C compiler. gcc is a popular one.
+-CC= gcc
++CC?= gcc
+ WARN= -ansi -Wall
+
+ # on SGI's, cc is ANSI.
+@@ -51,4 +51,4 @@
+ INCS= -I$(INC) $(EXTRA_INCS)
+ DEFS= $(COMPAT) $(NUMBER) $(OLD_ANSI) $(EXTRA_DEFS)
+
+-CFLAGS= -O2 $(WARN) $(INCS) $(DEFS)
++CFLAGS+= $(WARN) $(INCS) $(DEFS)
diff --git a/lang/lua4/pkg-comment b/lang/lua4/pkg-comment
new file mode 100644
index 000000000000..2ba3321e13d8
--- /dev/null
+++ b/lang/lua4/pkg-comment
@@ -0,0 +1 @@
+Small, compilable scripting language providing easy access to C code
diff --git a/lang/lua4/pkg-descr b/lang/lua4/pkg-descr
new file mode 100644
index 000000000000..a232582174e2
--- /dev/null
+++ b/lang/lua4/pkg-descr
@@ -0,0 +1,21 @@
+Lua is a programming language originally designed for extending applications,
+but also frequently used as a general-purpose, stand-alone language. Lua
+combines simple procedural syntax (similar to Pascal) with powerful data
+description constructs based on associative arrays and extensible semantics.
+Lua is dynamically typed, interpreted from bytecodes, and has automatic memory
+management with garbage collection, making it ideal for configuration,
+scripting, and rapid prototyping.
+
+A fundamental concept in the design of Lua is to provide meta-mechanisms for
+implementing features, instead of providing a host of features directly in
+the language. For example, although Lua is not a pure object-oriented
+language, it does provide meta-mechanisms for implementing classes and
+inheritance. Lua's meta-mechanisms bring an economy of concepts and keep the
+language small, while allowing the semantics to be extended in unconventional
+ways. Extensible semantics is a distinguishing feature of Lua.
+
+Lua is implemented as a small library of C functions, written in ANSI C, and
+compiles unmodified in all known platforms. The implementation goals are
+simplicity, efficiency, portability, and low embedding cost.
+
+WWW: http://www.tecgraf.puc-rio.br/lua/
diff --git a/lang/lua4/pkg-plist b/lang/lua4/pkg-plist
new file mode 100644
index 000000000000..e9e4b9b78eec
--- /dev/null
+++ b/lang/lua4/pkg-plist
@@ -0,0 +1,7 @@
+bin/lua
+bin/luac
+share/doc/lua/idx.html
+share/doc/lua/index.html
+share/doc/lua/luac.html
+share/doc/lua/manual.html
+@dirrm share/doc/lua
diff --git a/lang/lua50/Makefile b/lang/lua50/Makefile
new file mode 100644
index 000000000000..eb07cbe012a2
--- /dev/null
+++ b/lang/lua50/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: lua
+# Version required: 3.1
+# Date created: 27 June 1999
+# Whom: Richard Kiss <richard@homemail.com>
+#
+# $Id$
+#
+
+DISTNAME= lua-3.1
+CATEGORIES= lang
+MASTER_SITES= ftp://ftp.tecgraf.puc-rio.br/pub/lua/ \
+ ftp://csg.uwaterloo.ca/pub/lhf/lua/ \
+ ftp://ftp.cdrom.com/pub/languages/lua/ \
+ ftp://ftp.ntua.gr/pub/lang/lua/ \
+ ftp://ftp.uni-trier.de/pub/languages/lua/ \
+ ftp://ftp.gwdg.de/pub/languages/lua/
+
+MAINTAINER= richard@homemail.com
+
+MAN1= luac.1
+WRKSRC= ${WRKDIR}/lua
+
+do-install:
+ @ ${MKDIR} ${PREFIX}/share/doc/lua
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/bin/lua ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/bin/luac ${PREFIX}/bin
+ @ ${INSTALL_MAN} ${WRKSRC}/doc/luac.man ${PREFIX}/man/man1/luac.1
+ @ ${INSTALL_DATA} ${WRKSRC}/doc/idx.html ${PREFIX}/share/doc/lua
+ @ ${INSTALL_DATA} ${WRKSRC}/doc/index.html ${PREFIX}/share/doc/lua
+ @ ${INSTALL_DATA} ${WRKSRC}/doc/luac.html ${PREFIX}/share/doc/lua
+ @ ${INSTALL_DATA} ${WRKSRC}/doc/manual.html ${PREFIX}/share/doc/lua
+
+.include <bsd.port.mk>
diff --git a/lang/lua50/distinfo b/lang/lua50/distinfo
new file mode 100644
index 000000000000..f55e08bb1cca
--- /dev/null
+++ b/lang/lua50/distinfo
@@ -0,0 +1 @@
+MD5 (lua-3.1.tar.gz) = d677f3827167eefdefc7b211397cfdfb
diff --git a/lang/lua50/files/patch-aa b/lang/lua50/files/patch-aa
new file mode 100644
index 000000000000..101f1a83e236
--- /dev/null
+++ b/lang/lua50/files/patch-aa
@@ -0,0 +1,17 @@
+--- config.orig Tue Jul 6 18:17:42 1999
++++ config Tue Jul 6 18:18:03 1999
+@@ -3,7 +3,7 @@
+ # == CHANGE THE SETTINGS BELOW TO SUIT YOUR ENVIRONMENT ======================
+
+ # you need an ANSI C compiler. gcc is a popular one.
+-CC= gcc
++CC?= gcc
+ WARN= -ansi -Wall
+
+ # on SGI's, cc is ANSI.
+@@ -51,4 +51,4 @@
+ INCS= -I$(INC) $(EXTRA_INCS)
+ DEFS= $(COMPAT) $(NUMBER) $(OLD_ANSI) $(EXTRA_DEFS)
+
+-CFLAGS= -O2 $(WARN) $(INCS) $(DEFS)
++CFLAGS+= $(WARN) $(INCS) $(DEFS)
diff --git a/lang/lua50/pkg-comment b/lang/lua50/pkg-comment
new file mode 100644
index 000000000000..2ba3321e13d8
--- /dev/null
+++ b/lang/lua50/pkg-comment
@@ -0,0 +1 @@
+Small, compilable scripting language providing easy access to C code
diff --git a/lang/lua50/pkg-descr b/lang/lua50/pkg-descr
new file mode 100644
index 000000000000..a232582174e2
--- /dev/null
+++ b/lang/lua50/pkg-descr
@@ -0,0 +1,21 @@
+Lua is a programming language originally designed for extending applications,
+but also frequently used as a general-purpose, stand-alone language. Lua
+combines simple procedural syntax (similar to Pascal) with powerful data
+description constructs based on associative arrays and extensible semantics.
+Lua is dynamically typed, interpreted from bytecodes, and has automatic memory
+management with garbage collection, making it ideal for configuration,
+scripting, and rapid prototyping.
+
+A fundamental concept in the design of Lua is to provide meta-mechanisms for
+implementing features, instead of providing a host of features directly in
+the language. For example, although Lua is not a pure object-oriented
+language, it does provide meta-mechanisms for implementing classes and
+inheritance. Lua's meta-mechanisms bring an economy of concepts and keep the
+language small, while allowing the semantics to be extended in unconventional
+ways. Extensible semantics is a distinguishing feature of Lua.
+
+Lua is implemented as a small library of C functions, written in ANSI C, and
+compiles unmodified in all known platforms. The implementation goals are
+simplicity, efficiency, portability, and low embedding cost.
+
+WWW: http://www.tecgraf.puc-rio.br/lua/
diff --git a/lang/lua50/pkg-plist b/lang/lua50/pkg-plist
new file mode 100644
index 000000000000..e9e4b9b78eec
--- /dev/null
+++ b/lang/lua50/pkg-plist
@@ -0,0 +1,7 @@
+bin/lua
+bin/luac
+share/doc/lua/idx.html
+share/doc/lua/index.html
+share/doc/lua/luac.html
+share/doc/lua/manual.html
+@dirrm share/doc/lua