aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>1999-07-18 06:27:18 +0000
committerChris Piazza <cpiazza@FreeBSD.org>1999-07-18 06:27:18 +0000
commita7b26a212e9b748c28d6b1535aa433aa5663797f (patch)
tree12a6c118a8e49b2fab2de9215441582a29110b6d /lang
parentf291dba51e7b3bad5c700547e46ca97ed54c198f (diff)
downloadports-a7b26a212e9b748c28d6b1535aa433aa5663797f.tar.gz
ports-a7b26a212e9b748c28d6b1535aa433aa5663797f.zip
Give this port a USE_XLIB so it'll link. Also move the CC=egcc
into the ${OSVERSION} check so it'll actually compile on -current with egcs.
Notes
Notes: svn path=/head/; revision=20259
Diffstat (limited to 'lang')
-rw-r--r--lang/gnustep-base/Makefile6
-rw-r--r--lang/gnustep-guile/Makefile6
-rw-r--r--lang/gnustep-objc/Makefile6
3 files changed, 12 insertions, 6 deletions
diff --git a/lang/gnustep-base/Makefile b/lang/gnustep-base/Makefile
index cd04a664fc82..009f7a228e1c 100644
--- a/lang/gnustep-base/Makefile
+++ b/lang/gnustep-base/Makefile
@@ -3,7 +3,7 @@
# Date created: 03 October 1998
# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1999/05/10 11:31:58 tg Exp $
#
DISTNAME= gstep-core-0.5.5
@@ -24,18 +24,20 @@ BROKEN= "Sorry, this port does not work on FreeBSD-2.2.x"
.elif ${OSVERSION} < 400000
BUILD_DEPENDS= egcc:${PORTSDIR}/lang/egcs
RUN_DEPENDS= egcc:${PORTSDIR}/lang/egcs
+CC= egcc
.endif
WRKSRC= ${WRKDIR}/gstep-0.5.5
PREFIX= ${LOCALBASE}/GNUstep
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CC=egcc INSTALL_PROGRAM="install -c" INSTALL_DATA="install -c"
+CONFIGURE_ENV= INSTALL_PROGRAM="${INSTALL} -c" INSTALL_DATA="${INSTALL} -c"
CONFIGURE_ARGS= --with-library-combo=gnu-gnu-gnu-xraw \
--with-jpeg-library=${LOCALBASE}/lib \
--with-jpeg-include=${LOCALBASE}/include \
--with-tiff-library=${LOCALBASE}/lib \
--with-tiff-include=${LOCALBASE}/include
USE_GMAKE= yes
+USE_XLIB= yes
MAKEFILE=
MAKE_FLAGS= OPTFLAG="${CFLAGS}"
NO_MTREE= yes
diff --git a/lang/gnustep-guile/Makefile b/lang/gnustep-guile/Makefile
index cd04a664fc82..009f7a228e1c 100644
--- a/lang/gnustep-guile/Makefile
+++ b/lang/gnustep-guile/Makefile
@@ -3,7 +3,7 @@
# Date created: 03 October 1998
# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1999/05/10 11:31:58 tg Exp $
#
DISTNAME= gstep-core-0.5.5
@@ -24,18 +24,20 @@ BROKEN= "Sorry, this port does not work on FreeBSD-2.2.x"
.elif ${OSVERSION} < 400000
BUILD_DEPENDS= egcc:${PORTSDIR}/lang/egcs
RUN_DEPENDS= egcc:${PORTSDIR}/lang/egcs
+CC= egcc
.endif
WRKSRC= ${WRKDIR}/gstep-0.5.5
PREFIX= ${LOCALBASE}/GNUstep
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CC=egcc INSTALL_PROGRAM="install -c" INSTALL_DATA="install -c"
+CONFIGURE_ENV= INSTALL_PROGRAM="${INSTALL} -c" INSTALL_DATA="${INSTALL} -c"
CONFIGURE_ARGS= --with-library-combo=gnu-gnu-gnu-xraw \
--with-jpeg-library=${LOCALBASE}/lib \
--with-jpeg-include=${LOCALBASE}/include \
--with-tiff-library=${LOCALBASE}/lib \
--with-tiff-include=${LOCALBASE}/include
USE_GMAKE= yes
+USE_XLIB= yes
MAKEFILE=
MAKE_FLAGS= OPTFLAG="${CFLAGS}"
NO_MTREE= yes
diff --git a/lang/gnustep-objc/Makefile b/lang/gnustep-objc/Makefile
index cd04a664fc82..009f7a228e1c 100644
--- a/lang/gnustep-objc/Makefile
+++ b/lang/gnustep-objc/Makefile
@@ -3,7 +3,7 @@
# Date created: 03 October 1998
# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1999/05/10 11:31:58 tg Exp $
#
DISTNAME= gstep-core-0.5.5
@@ -24,18 +24,20 @@ BROKEN= "Sorry, this port does not work on FreeBSD-2.2.x"
.elif ${OSVERSION} < 400000
BUILD_DEPENDS= egcc:${PORTSDIR}/lang/egcs
RUN_DEPENDS= egcc:${PORTSDIR}/lang/egcs
+CC= egcc
.endif
WRKSRC= ${WRKDIR}/gstep-0.5.5
PREFIX= ${LOCALBASE}/GNUstep
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CC=egcc INSTALL_PROGRAM="install -c" INSTALL_DATA="install -c"
+CONFIGURE_ENV= INSTALL_PROGRAM="${INSTALL} -c" INSTALL_DATA="${INSTALL} -c"
CONFIGURE_ARGS= --with-library-combo=gnu-gnu-gnu-xraw \
--with-jpeg-library=${LOCALBASE}/lib \
--with-jpeg-include=${LOCALBASE}/include \
--with-tiff-library=${LOCALBASE}/lib \
--with-tiff-include=${LOCALBASE}/include
USE_GMAKE= yes
+USE_XLIB= yes
MAKEFILE=
MAKE_FLAGS= OPTFLAG="${CFLAGS}"
NO_MTREE= yes