aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-02-19 15:51:37 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-02-19 15:51:37 +0000
commitf8df0902f63712535c923f91aa23e5fb6aaaef8f (patch)
treecdc3b0e253c06e23a4f07d046f5d5bdd990382c5 /lang
parent3788793f58e0f6383db1269d3f181014509ac611 (diff)
downloadports-f8df0902f63712535c923f91aa23e5fb6aaaef8f.tar.gz
ports-f8df0902f63712535c923f91aa23e5fb6aaaef8f.zip
Kill unwanted extension directories rather than "hiding" them.
Notes
Notes: svn path=/head/; revision=38485
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby/Makefile6
-rw-r--r--lang/ruby16/Makefile6
2 files changed, 6 insertions, 6 deletions
diff --git a/lang/ruby/Makefile b/lang/ruby/Makefile
index be0c63a92423..179680a4a980 100644
--- a/lang/ruby/Makefile
+++ b/lang/ruby/Makefile
@@ -47,9 +47,9 @@ CONFIGURE_ARGS+= --enable-ipv6
post-patch:
find ${WRKSRC} -name '*.orig' -delete
- ${RM} -f ${WRKSRC}/ext/gdbm/MANIFEST
- ${RM} -f ${WRKSRC}/ext/tcltklib/MANIFEST
- ${RM} -f ${WRKSRC}/ext/tk/MANIFEST
+.for d in Win32API gdbm tcltklib tk
+ ${RM} -rf ${WRKSRC}/ext/${d}
+.endfor
post-install:
strip ${RUBY}
diff --git a/lang/ruby16/Makefile b/lang/ruby16/Makefile
index be0c63a92423..179680a4a980 100644
--- a/lang/ruby16/Makefile
+++ b/lang/ruby16/Makefile
@@ -47,9 +47,9 @@ CONFIGURE_ARGS+= --enable-ipv6
post-patch:
find ${WRKSRC} -name '*.orig' -delete
- ${RM} -f ${WRKSRC}/ext/gdbm/MANIFEST
- ${RM} -f ${WRKSRC}/ext/tcltklib/MANIFEST
- ${RM} -f ${WRKSRC}/ext/tk/MANIFEST
+.for d in Win32API gdbm tcltklib tk
+ ${RM} -rf ${WRKSRC}/ext/${d}
+.endfor
post-install:
strip ${RUBY}