aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-14 14:05:32 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-14 14:05:32 +0000
commitbbcd9f3fd273ca151ebef513e2b1b6fad063da63 (patch)
treed9d0a0a8b3834b076383be46452f0b431199a721 /lang
parent18bf135afb26519cc755ea430305b4ad4b11fc4e (diff)
downloadports-bbcd9f3fd273ca151ebef513e2b1b6fad063da63.tar.gz
ports-bbcd9f3fd273ca151ebef513e2b1b6fad063da63.zip
- Make OpenSSL handling more obvious
Notes
Notes: svn path=/head/; revision=153461
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby18/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index 9d896530429f..b9a30687b27a 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -38,8 +38,7 @@ USE_REINPLACE= yes
GNU_CONFIGURE= yes
WRKSRC= ${RUBY_WRKSRC}
CONFIGURE_ARGS= ${RUBY_CONFIGURE_ARGS} \
- --enable-shared \
- --with-openssl-include=${PREFIX}/include
+ --enable-shared
CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
LIBS="${PTHREAD_LIBS}"
@@ -52,6 +51,11 @@ INSTALLS_SHLIB= yes
MAN1= ${RUBY_NAME}.1
.include <bsd.port.pre.mk>
+
+.if defined(WITH_OPENSSL_PORT)
+CONFIGURE_ARGS+=--with-openssl-include=${LOCALBASE}/include
+.endif
+
.if ${OSVERSION} < 502102
EXTRA_PATCHES= ${PATCHDIR}/extrapatch-eval.c
.endif