aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2012-08-17 13:16:43 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2012-08-17 13:16:43 +0000
commitb7e92b9c87bb4474ebdafe72c7b93447dd6d1379 (patch)
treeabbb6fd6495a28f8c846ff7612267254b9c0a4b7 /lang
parent3a2038b339d07d7cbc3c3fa37bf57d91ff70f7be (diff)
downloadports-b7e92b9c87bb4474ebdafe72c7b93447dd6d1379.tar.gz
ports-b7e92b9c87bb4474ebdafe72c7b93447dd6d1379.zip
Add experimental DTrace support.
Obtained from: Kenji Rikitake's Erlang port on github https://github.com/jj1bdx/erlang-freebsd-port
Notes
Notes: svn path=/head/; revision=302681
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang/Makefile17
1 files changed, 16 insertions, 1 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index aede724adb7f..ccee9b07be97 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -44,7 +44,7 @@ SUB_LIST= TOOLS_VSN=${TOOLS_VSN}
MAKE_JOBS_UNSAFE=yes
-OPTIONS_DEFINE= DOCS GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREADS WX
+OPTIONS_DEFINE= DOCS GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREADS WX DTRACE
OPTIONS_SINGLE= ODBC
OPTIONS_SINGLE_ODBC= IODBC UNIXODBC
@@ -54,11 +54,26 @@ SCTP_DESC= Enable SCTP support
SMP_DESC= Enable SMP support
WX_DESC= Enable WX application
GS_DESC= Enable GS application (deprecated)
+DTRACE_DESC= Enable DTrace support (experimental)
OPTIONS_DEFAULT=SMP OPENSSL THREADS SCTP KQUEUE
.include <bsd.port.options.mk>
+# See http://wiki.freebsd.org/DTrace to learn how to enable DTrace
+# on your system. You will need to configure STRIP, WITH_CTF and
+# CFLAGS in your make.conf before building.
+
+# If you run Erlang and get a message resembling "WARNING: number of
+# probes fixed does not match the number of defined probes (54 != 132,
+# respectively)" you probably misconfigured DTrace in some way.
+
+.if ${PORT_OPTIONS:MDTRACE}
+CONFIGURE_ARGS+=--with-dynamic-trace=dtrace
+.else
+CONFIGURE_ARGS+=--without-dynamic-trace
+.endif
+
.if ${PORT_OPTIONS:MOPENSSL}
USE_OPENSSL= yes
CONFIGURE_ARGS+=--with-ssl=${OPENSSLBASE}