aboutsummaryrefslogtreecommitdiff
path: root/mail/assp
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-12-01 08:10:20 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-12-01 08:10:20 +0000
commit4ce7ccd8a46ea4843e372bf9327c89655e1e8dca (patch)
treeadc1c359d7067f55c2a9f2425c04db120dbb0f54 /mail/assp
parent66e47a582239d9ba90fd4cf35fdf621dde28012b (diff)
downloadports-4ce7ccd8a46ea4843e372bf9327c89655e1e8dca.tar.gz
ports-4ce7ccd8a46ea4843e372bf9327c89655e1e8dca.zip
- Update to 1.2.5.2
PR: ports/106092 Submitted by: "J.R. Oldroyd" <fbsd@opal.com> (maintainer)
Notes
Notes: svn path=/head/; revision=178438
Diffstat (limited to 'mail/assp')
-rw-r--r--mail/assp/Makefile21
-rw-r--r--mail/assp/distinfo9
-rw-r--r--mail/assp/files/patch-assp.pl31
-rw-r--r--mail/assp/files/pkg-install.in2
-rw-r--r--mail/assp/pkg-plist23
5 files changed, 49 insertions, 37 deletions
diff --git a/mail/assp/Makefile b/mail/assp/Makefile
index a5a771af3053..aac95056245f 100644
--- a/mail/assp/Makefile
+++ b/mail/assp/Makefile
@@ -6,11 +6,12 @@
#
PORTNAME= assp
-PORTVERSION= 1.2.3
+PORTVERSION= 1.2.5.2
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME:U}_${PORTVERSION}-Install
+DISTFILES= ${PORTNAME:U}_1.2.5-Install${EXTRACT_SUFX} \
+ ${PORTNAME:U}_1.2.5_Rev.2-Update${EXTRACT_SUFX}
MAINTAINER= fbsd@opal.com
COMMENT= Anti-Spam SMTP Proxy
@@ -22,7 +23,7 @@ USE_PERL5_RUN= yes
USE_DOS2UNIX= addservice.pl \
assp.pl \
changelog.txt \
- freshclam.sh \
+ helpreport.txt \
move2num.pl \
nodelay.txt \
notspamreport.txt \
@@ -97,7 +98,7 @@ RUN_DEPENDS+= ${SITE_PERL}/mach/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compre
.endif
.if !defined(WITHOUT_CLAMAV)
-RUN_DEPENDS+= wget:${PORTSDIR}/ftp/wget
+RUN_DEPENDS+= ${SITE_PERL}/File/Scan/ClamAV.pm:${PORTSDIR}/security/p5-File-Scan-ClamAV
PLIST_SUB+= ASSP_CLAMAV=""
.else
PLIST_SUB+= ASSP_CLAMAV="@comment "
@@ -109,6 +110,11 @@ RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS
EXTRACT_AFTER_ARGS= -d ${PORTNAME}-${PORTVERSION}
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ cd ${WRKDIR}/${PORTNAME}-${PORTVERSION}; ${UNZIP_CMD} -q ${DISTDIR}/${PORTNAME:U}_1.2.5-Install${EXTRACT_SUFX}
+ cd ${WRKDIR}/${PORTNAME}-${PORTVERSION}/${PORTNAME:U}; ${UNZIP_CMD} -oq ${DISTDIR}/${PORTNAME:U}_1.2.5_Rev.2-Update${EXTRACT_SUFX}
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' ${WRKSRC}/*.pl
@@ -116,13 +122,10 @@ do-install:
${MKDIR} ${PREFIX}/lib/assp
${INSTALL_SCRIPT} ${WRKSRC}/*.pl ${PREFIX}/lib/assp
${INSTALL_SCRIPT} ${WRKSRC}/stats.sh ${PREFIX}/lib/assp
-.if defined(WITH_CLAMAV)
- ${INSTALL_SCRIPT} ${WRKSRC}/freshclam.sh ${PREFIX}/lib/assp
-.endif
- ${INSTALL_DATA} ${WRKSRC}/*report.txt ${PREFIX}/lib/assp
${INSTALL_DATA} ${WRKSRC}/nodelay.txt ${PREFIX}/lib/assp
${INSTALL_DATA} ${WRKSRC}/redre.txt ${PREFIX}/lib/assp
-
+ ${MKDIR} ${PREFIX}/lib/assp/reports
+ ${INSTALL_DATA} ${WRKSRC}/*report.txt ${PREFIX}/lib/assp/reports
${MKDIR} ${PREFIX}/lib/assp/images
${INSTALL_DATA} ${WRKSRC}/images/* ${PREFIX}/lib/assp/images
diff --git a/mail/assp/distinfo b/mail/assp/distinfo
index 3f3fe89c4c90..02a9a81ed298 100644
--- a/mail/assp/distinfo
+++ b/mail/assp/distinfo
@@ -1,3 +1,6 @@
-MD5 (ASSP_1.2.3-Install.zip) = 456208cfdd184fdbdc10224f6afed6c7
-SHA256 (ASSP_1.2.3-Install.zip) = 746205e2511b52b9859e34634155c12e4e0a34a444036486bf37f3c63ec9dec6
-SIZE (ASSP_1.2.3-Install.zip) = 235717
+MD5 (ASSP_1.2.5-Install.zip) = ffbb815b24ea5073000dd50143edc311
+SHA256 (ASSP_1.2.5-Install.zip) = 282325e0434ef8554fe281a2b25267fde99254ea83bc7073c2acfbc47c2d31af
+SIZE (ASSP_1.2.5-Install.zip) = 244225
+MD5 (ASSP_1.2.5_Rev.2-Update.zip) = 6ad6641b88fe4e261432ee47da432540
+SHA256 (ASSP_1.2.5_Rev.2-Update.zip) = 86e837609712e1c033a59e112eb3f22bff2e3617c1f7f87f88a7da9438d3bbf8
+SIZE (ASSP_1.2.5_Rev.2-Update.zip) = 96722
diff --git a/mail/assp/files/patch-assp.pl b/mail/assp/files/patch-assp.pl
index d9685c23a202..3a39412c811a 100644
--- a/mail/assp/files/patch-assp.pl
+++ b/mail/assp/files/patch-assp.pl
@@ -1,24 +1,33 @@
---- assp.pl.orig Sun Jun 25 15:35:15 2006
-+++ assp.pl Sun Jun 25 15:43:20 2006
-@@ -67,7 +67,7 @@
+--- assp.pl.orig Thu Nov 30 16:33:20 2006
++++ assp.pl Thu Nov 30 16:34:18 2006
+@@ -69,7 +69,7 @@
loadConfig();
sub loadConfig {
- print "loading config -- base='$base'\n";
+ # print "loading config -- base='$base'\n";
@Config=(
- [0,0,0,'heading','Network Setup'],
- # except for the heading lines, all config lines have the following:
-@@ -86,7 +86,7 @@
- 'The address:port of your message handling system\'s smtp server. For example: 127.0.0.1:125'],
- [AsAService,'As a Service',0,checkbox,0,'(.*)',undef,
+
+
+@@ -91,7 +91,7 @@
+ 'The address:port of your message handling system\'s smtp server(s). Secondary servers possible, will try the next if the first doesn\'t respond.<br />If only the port is entered, or the keyword <b>__INBOUND__</b>:<i>port</i> is used, then the connection will be established to the same IP where the connection was received. This is usefull when you have several IPs with different domains/profiles in your MTA.<br /> Examples: "127.0.0.1:125","127.0.0.1:125|127.0.0.5:125", "10.0.1.3", "10.0.1.3:1025", "__INBOUND__:125", "125", etc.'],
+ [AsAService,'As a Service',0,checkbox,0,'(.*)',undef,
'In Windows 2000 / NT you can run it as a service; requires <a href="http://www.roth.net/perl/Daemon/" rel="external">win32::daemon</a>. Requires start from the service control panel.'],
- [AsADaemon,'As a Daemon',0,checkbox,0,'(.*)',undef,
+ [AsADaemon,'As a Daemon',0,checkbox,1,'(.*)',undef,
'In Linux/BSD/Unix/OSX fork and close file handles, kinda like "perl assp.pl &amp;" but better. Requires restart.'],
[myName,'My Name',40,textinput,'ASSP.nospam','(\S+)',undef,
'What the program calls itself in the email "received by" header. Usually ASSP.nospam.'],
-@@ -811,7 +811,7 @@
+@@ -666,7 +666,7 @@
+ 'SMTP error message to reject attachments.'],
+ [UseAvClamd,'Use Av Clamd',0,checkbox,1,'(.*)',undef,
+ 'If activated, the message is checked by Av Clamd, this requires an installed <a href="http://search.cpan.org/~cfaber/File-Scan-ClamAV-1.06/lib/File/Scan/ClamAV.pm" rel="external">File::Scan::ClamAV</a> Perl module. '],
+-[AvClamdPort,'Port or file socket for local Av Clamd',20,textinput,'3310','(\S+)',undef,
++[AvClamdPort,'Port or file socket for local Av Clamd',20,textinput,'/var/run/clamav/clamd','(\S+)',undef,
+ 'A port or socket to connect to. If the socket has been setup as a TCP/IP socket (see the TCPSocket option in the clamav.conf file), then specifying in a number will cause File::Scan::ClamAV to use a TCP socket. For example 3310 or /tmp/clamd '],
+ [AvClamdBufSize,'Size of buffer for Av Clamd',7,textinput,'512','(\d+)',undef,
+ 'Buffer size for stream check, must be more than max length of virus signature'],
+@@ -839,7 +839,7 @@
'<span class="negative"> 0 = no report, 1 = to user, 2 = to TO address, 3 = both</span>'],
[EmailRedlistTo,'To Address for Redlist-Reports',40,textinput,'','(.+)',undef,
'Email sent from ASSP acknowledging your submissions will be sent to this address. For example: admin@domain.com'],
@@ -27,7 +36,7 @@
'Email sent from ASSP acknowledging your submissions will be sent from this address.<br />
Some mailers don\'t like the default setting. For example: ASSP &lt;&gt; or Mail Administrator
&lt;mailadmin@mydomain.com&gt;
-@@ -913,9 +913,9 @@
+@@ -943,9 +943,9 @@
'],
[0,0,0,'heading','Security'],
@@ -39,7 +48,7 @@
'The *nix group to assume after startup: assp or nogroup -- requires ASSP restart.'],
[ChangeRoot,'Change Root',40,textinput,'','(.*)',undef,
'Non-blank means to run in chroot jail in *nix. You need an etc/protocols file to make this work<br />
-@@ -7865,6 +7865,7 @@
+@@ -8328,6 +8328,7 @@
@PossibleOptionFiles2=();
foreach (@Config) {
if($_->[6] eq 'ConfigMakeRe') {
diff --git a/mail/assp/files/pkg-install.in b/mail/assp/files/pkg-install.in
index 82c5f2a988b6..517e5f2c2dd9 100644
--- a/mail/assp/files/pkg-install.in
+++ b/mail/assp/files/pkg-install.in
@@ -2,8 +2,8 @@
if [ "$2" = "POST-INSTALL" ]; then
install -d -m 0700 -o %%ASSP_USER%% -g %%ASSP_GROUP%% %%ASSP_HOME%%
- ln -s $PKG_PREFIX/lib/assp/*report.txt %%ASSP_HOME%%
ln -s $PKG_PREFIX/lib/assp/nodelay.txt %%ASSP_HOME%%
ln -s $PKG_PREFIX/lib/assp/redre.txt %%ASSP_HOME%%
ln -s $PKG_PREFIX/lib/assp/images %%ASSP_HOME%%
+ ln -s $PKG_PREFIX/lib/assp/reports %%ASSP_HOME%%
fi
diff --git a/mail/assp/pkg-plist b/mail/assp/pkg-plist
index b8a1d58bfeb2..1c9591ed4503 100644
--- a/mail/assp/pkg-plist
+++ b/mail/assp/pkg-plist
@@ -10,6 +10,7 @@ lib/assp/images/favicon.ico
lib/assp/images/logo.jpg
lib/assp/images/minusIcon.png
lib/assp/images/noIcon.png
+lib/assp/images/opensource-logo.gif
lib/assp/images/plusIcon.png
lib/assp/images/shutdown.css
lib/assp/images/sourceforge-logo.gif
@@ -18,18 +19,19 @@ lib/assp/images/village.gif
lib/assp/images/xml-pill.gif
lib/assp/move2num.pl
lib/assp/nodelay.txt
-lib/assp/notspamreport.txt
lib/assp/rebuildspamdb.pl
-lib/assp/redremovereport.txt
lib/assp/redre.txt
-lib/assp/redreport.txt
lib/assp/repair.pl
-lib/assp/spamreport.txt
+lib/assp/reports/helpreport.txt
+lib/assp/reports/notspamreport.txt
+lib/assp/reports/redremovereport.txt
+lib/assp/reports/redreport.txt
+lib/assp/reports/spamreport.txt
+lib/assp/reports/whiteremovereport.txt
+lib/assp/reports/whitereport.txt
lib/assp/stat.pl
lib/assp/stats.sh
-lib/assp/whiteremovereport.txt
-lib/assp/whitereport.txt
-%%ASSP_CLAMAV%%lib/assp/freshclam.sh
+@dirrm lib/assp/reports
@dirrm lib/assp/images
@dirrm lib/assp
sbin/assp
@@ -37,14 +39,9 @@ sbin/assplog
%%PORTDOCS%%%%DOCSDIR%%/ASSP Documentation.htm
%%PORTDOCS%%%%DOCSDIR%%/Regular Expression Tutorial.htm
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@unexec rm -f %%ASSP_HOME%%/reports 2>/dev/null || true
@unexec rm -f %%ASSP_HOME%%/images 2>/dev/null || true
@unexec rm -f %%ASSP_HOME%%/nodelay.txt 2>/dev/null || true
-@unexec rm -f %%ASSP_HOME%%/notspamreport.txt 2>/dev/null || true
-@unexec rm -f %%ASSP_HOME%%/redremovereport.txt 2>/dev/null || true
@unexec rm -f %%ASSP_HOME%%/redre.txt 2>/dev/null || true
-@unexec rm -f %%ASSP_HOME%%/redreport.txt 2>/dev/null || true
-@unexec rm -f %%ASSP_HOME%%/spamreport.txt 2>/dev/null || true
-@unexec rm -f %%ASSP_HOME%%/whiteremovereport.txt 2>/dev/null || true
-@unexec rm -f %%ASSP_HOME%%/whitereport.txt 2>/dev/null || true
@unexec rmdir %%ASSP_HOME%% 2>/dev/null || true
@unexec if [ -d %%ASSP_HOME%% ]; then echo "If you are deinstalling ASSP completely, remove the %%ASSP_HOME%% directory."; fi