aboutsummaryrefslogtreecommitdiff
path: root/mail/autosig
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-05-20 03:26:24 +0000
committerWill Andrews <will@FreeBSD.org>2001-05-20 03:26:24 +0000
commitfd48dcd8c3d1a5537504c52f4b8c2e3371dc1a6a (patch)
tree61ddf018c6b73886f63c8c0189f6547707c52924 /mail/autosig
parentdf905663603c9cc63b2ecc0b95a600e0ba3ac4c7 (diff)
downloadports-fd48dcd8c3d1a5537504c52f4b8c2e3371dc1a6a.tar.gz
ports-fd48dcd8c3d1a5537504c52f4b8c2e3371dc1a6a.zip
Add autosig 2.3, a random .signature generator with header file
included. PR: 27458 Submitted by: Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
Notes
Notes: svn path=/head/; revision=42784
Diffstat (limited to 'mail/autosig')
-rw-r--r--mail/autosig/Makefile24
-rw-r--r--mail/autosig/distinfo1
-rw-r--r--mail/autosig/pkg-comment1
-rw-r--r--mail/autosig/pkg-descr10
-rw-r--r--mail/autosig/pkg-plist1
5 files changed, 37 insertions, 0 deletions
diff --git a/mail/autosig/Makefile b/mail/autosig/Makefile
new file mode 100644
index 000000000000..c1e34015f3fe
--- /dev/null
+++ b/mail/autosig/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: autosig
+# Date created: 23 April 2001
+# Whom: Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= autosig
+PORTVERSION= 2.3
+CATEGORIES= mail
+MASTER_SITES= http://www.irendi.com/
+
+MAINTAINER= leeym@cae.ce.ntu.edu.tw
+
+MAKEFILE= makefile
+ALL_TARGET= ${PORTNAME}
+
+pre-build:
+ ${PERL} -pi -e 's,gcc,${CC} ${CFLAGS},g' ${WRKSRC}/makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/mail/autosig/distinfo b/mail/autosig/distinfo
new file mode 100644
index 000000000000..4a5dfd170caf
--- /dev/null
+++ b/mail/autosig/distinfo
@@ -0,0 +1 @@
+MD5 (autosig-2.3.tar.gz) = b13ddbef5051b2b2249d5faef61374be
diff --git a/mail/autosig/pkg-comment b/mail/autosig/pkg-comment
new file mode 100644
index 000000000000..532a12a41288
--- /dev/null
+++ b/mail/autosig/pkg-comment
@@ -0,0 +1 @@
+A random .signature generator with header file included
diff --git a/mail/autosig/pkg-descr b/mail/autosig/pkg-descr
new file mode 100644
index 000000000000..c93c22764c72
--- /dev/null
+++ b/mail/autosig/pkg-descr
@@ -0,0 +1,10 @@
+ Auto-Sig v2.3
+ -------------
+
+This application is used to generate .signature and .plan files from a list of
+quotes. The files are generated by combining a constant header file with one
+quote which is randomly selected from the quote file. This package includes the
+source which can be used to build the autosig application and a number of
+sample shell script which demonstrate how everything works.
+
+WWW: http://www.irendi.com/
diff --git a/mail/autosig/pkg-plist b/mail/autosig/pkg-plist
new file mode 100644
index 000000000000..480d8ccd5911
--- /dev/null
+++ b/mail/autosig/pkg-plist
@@ -0,0 +1 @@
+bin/autosig