aboutsummaryrefslogtreecommitdiff
path: root/mail/balsa2/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-05-30 03:38:11 +0000
committerSteve Price <steve@FreeBSD.org>1999-05-30 03:38:11 +0000
commit5f48cbd6fd882f9162263da791fcea772eac5ecc (patch)
tree364e325edf42a1e04f833c88278270a319d9a19b /mail/balsa2/Makefile
parentdd51d51a595bd4c333d93f53e545993aba4f2129 (diff)
downloadports-5f48cbd6fd882f9162263da791fcea772eac5ecc.tar.gz
ports-5f48cbd6fd882f9162263da791fcea772eac5ecc.zip
Use new gnomelibs port and set USE_LIBTOOL=yes
PR: 11844 Submitted by: Jeremy Lea <reg@shale.csir.co.za>
Notes
Notes: svn path=/head/; revision=19101
Diffstat (limited to 'mail/balsa2/Makefile')
-rw-r--r--mail/balsa2/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/mail/balsa2/Makefile b/mail/balsa2/Makefile
index 039a55d0dcb4..4589a291bfd5 100644
--- a/mail/balsa2/Makefile
+++ b/mail/balsa2/Makefile
@@ -3,7 +3,7 @@
# Date created: 02 December 1998
# Whom: Glenn Johnson <gljohns@bellsouth.net>
#
-# $Id: Makefile,v 1.4 1999/02/03 20:50:03 vanilla Exp $
+# $Id: Makefile,v 1.5 1999/03/24 16:38:27 nectar Exp $
#
DISTNAME= balsa-0.4.9
@@ -14,24 +14,23 @@ MASTER_SITE_SUBDIR= sources/balsa
MAINTAINER= ports@FreeBSD.ORG
RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore
-LIB_DEPENDS= gnome.1:${PORTSDIR}/x11/gnomelibs \
+LIB_DEPENDS= gnome.2:${PORTSDIR}/x11/gnomelibs \
PropList.1:${PORTSDIR}/devel/libPropList
-BUILD_DEPENDS= orbit-idl:${PORTSDIR}/devel/ORBit
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+LIBTOOLFILES= configure libmutt/configure
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
--datadir=${PREFIX}/share/gnome \
- --with-gnome=${X11BASE}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- GTK_CONFIG="${X11BASE}/bin/gtk12-config" \
- LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lxpg4"
+ --with-gnome=${PREFIX}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
MAN1= balsa.1
-pre-build:
- cd ${WRKSRC}/idl && orbit-idl balsa.idl
-
post-install:
${INSTALL_MAN} ${WRKSRC}/balsa.1 ${PREFIX}/man/man1