aboutsummaryrefslogtreecommitdiff
path: root/mail/balsa
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-07-20 12:09:05 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-07-20 12:09:05 +0000
commitd9f2c0c23d2de474f27b114baafbcf418dbf05e2 (patch)
treeef7dab2765400d6c5e79bdc210472686992a93d5 /mail/balsa
parent1611217d1f14868e23a8d51175d8ebec574ea32e (diff)
downloadports-d9f2c0c23d2de474f27b114baafbcf418dbf05e2.tar.gz
ports-d9f2c0c23d2de474f27b114baafbcf418dbf05e2.zip
Update to 1.1.7.
PR: 28963 Submitted by: John Merryweather Cooper <jmcoopr@webmail.bmi.net>
Notes
Notes: svn path=/head/; revision=45281
Diffstat (limited to 'mail/balsa')
-rw-r--r--mail/balsa/Makefile7
-rw-r--r--mail/balsa/distinfo2
-rw-r--r--mail/balsa/files/patch-aq12
-rw-r--r--mail/balsa/files/patch-ltmain.sh18
4 files changed, 22 insertions, 17 deletions
diff --git a/mail/balsa/Makefile b/mail/balsa/Makefile
index f322d0ff2655..10599f0a74e6 100644
--- a/mail/balsa/Makefile
+++ b/mail/balsa/Makefile
@@ -6,20 +6,19 @@
#
PORTNAME= balsa
-PORTVERSION= 1.1.4
-PORTREVISION= 2
+PORTVERSION= 1.1.7
CATEGORIES= mail gnome
MASTER_SITES= http://www.theochem.kth.se/~pawsa/balsa/ \
ftp://ftp.newton.cx/pub/balsa/
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= PropList.2:${PORTSDIR}/devel/libPropList
+LIB_DEPENDS= esmtp.5:${PORTSDIR}/mail/libesmtp
USE_X_PREFIX= yes
USE_GNOME= yes
USE_LIBTOOL= yes
-LIBTOOLFILES= configure libmutt/configure
+LIBTOOLFILES= libmutt/configure
CONFIGURE_ARGS= --enable-threads \
--enable-gtkhtml \
--disable-more-warnings
diff --git a/mail/balsa/distinfo b/mail/balsa/distinfo
index 5eaf907d5104..c417223aab5e 100644
--- a/mail/balsa/distinfo
+++ b/mail/balsa/distinfo
@@ -1 +1 @@
-MD5 (balsa-1.1.4.tar.gz) = 1ba025cefaae403cb099e61ac2acf356
+MD5 (balsa-1.1.7.tar.gz) = 9a6cda3e70a8877308a4ff55da8dcec9
diff --git a/mail/balsa/files/patch-aq b/mail/balsa/files/patch-aq
deleted file mode 100644
index 08c8d4f7cd21..000000000000
--- a/mail/balsa/files/patch-aq
+++ /dev/null
@@ -1,12 +0,0 @@
---- libbalsa/send.c.orig Fri Sep 29 14:00:46 2000
-+++ libbalsa/send.c Mon Oct 2 13:23:37 2000
-@@ -24,6 +24,9 @@
-
- /* #include <radlib.h> */
- /* FreeBSD 4.1-STABLE FreeBSD 4.1-STABLE */
-+#include <sys/types.h>
-+#include <sys/socket.h>
-+#include <netinet/in.h>
- #include <arpa/inet.h>
- #include <netdb.h>
-
diff --git a/mail/balsa/files/patch-ltmain.sh b/mail/balsa/files/patch-ltmain.sh
new file mode 100644
index 000000000000..78f2d1ed3198
--- /dev/null
+++ b/mail/balsa/files/patch-ltmain.sh
@@ -0,0 +1,18 @@
+
+$FreeBSD$
+
+--- ltmain.sh 2001/07/20 11:55:49 1.1
++++ ltmain.sh 2001/07/20 11:56:15
+@@ -4175,10 +4175,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"