aboutsummaryrefslogtreecommitdiff
path: root/mail/biffer
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-10-28 07:00:21 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-10-28 07:00:21 +0000
commit00676749e80d0ea2b41632408c85d89941f84c89 (patch)
tree4e5ac58ab9aff69f1c658e71fda2e9019f040d4a /mail/biffer
parent635bb209f8ab355dd57ec02796f0f0356ddf49ff (diff)
downloadports-00676749e80d0ea2b41632408c85d89941f84c89.tar.gz
ports-00676749e80d0ea2b41632408c85d89941f84c89.zip
- Respect ${PREFIX} [1]
- Cleanup: s,${WRKDIR}/${DISTNAME},${WRKSRC}, [1]: PR: ports/88114 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=146544
Diffstat (limited to 'mail/biffer')
-rw-r--r--mail/biffer/Makefile14
-rw-r--r--mail/biffer/files/patch-biffer_comsat::Makefile16
2 files changed, 16 insertions, 14 deletions
diff --git a/mail/biffer/Makefile b/mail/biffer/Makefile
index aede498dd64b..6ca0cc1fea1f 100644
--- a/mail/biffer/Makefile
+++ b/mail/biffer/Makefile
@@ -19,15 +19,11 @@ MAN1= biffopt.1
MAN8= biffer.8 biffer_comsat.8
do-install:
- ${INSTALL_PROGRAM} \
- ${WRKDIR}/${DISTNAME}/biffer/biffer ${PREFIX}/libexec
- ${INSTALL_PROGRAM} \
- ${WRKDIR}/${DISTNAME}/biffopt/biffopt ${PREFIX}/bin
- ${INSTALL_MAN} \
- ${WRKDIR}/${DISTNAME}/biffopt/biffopt.1 ${MAN1PREFIX}/man/man1
- ${INSTALL_MAN} \
- ${WRKDIR}/${DISTNAME}/biffer/biffer.8 ${MAN8PREFIX}/man/man8
- cd ${WRKDIR}/${DISTNAME}/biffer_comsat && ${MAKE} ${MFLAGS} install
+ ${INSTALL_PROGRAM} ${WRKSRC}/biffer/biffer ${PREFIX}/libexec
+ ${INSTALL_PROGRAM} ${WRKSRC}/biffopt/biffopt ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/biffopt/biffopt.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/biffer/biffer.8 ${MAN8PREFIX}/man/man8
+ cd ${WRKSRC}/biffer_comsat && ${MAKE} ${MFLAGS} install
post-install:
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} \
diff --git a/mail/biffer/files/patch-biffer_comsat::Makefile b/mail/biffer/files/patch-biffer_comsat::Makefile
index 742090a6deeb..4a720e6cb97d 100644
--- a/mail/biffer/files/patch-biffer_comsat::Makefile
+++ b/mail/biffer/files/patch-biffer_comsat::Makefile
@@ -1,8 +1,14 @@
---- biffer_comsat/Makefile.orig Wed Oct 22 17:11:51 2003
-+++ biffer_comsat/Makefile Wed Oct 22 17:12:01 2003
-@@ -11,6 +11,8 @@
- BINDIR= /usr/local/libexec
- MANDIR= /usr/local/man/man
+--- biffer_comsat/Makefile.orig Thu Oct 27 23:23:21 2005
++++ biffer_comsat/Makefile Thu Oct 27 23:25:14 2005
+@@ -8,9 +8,12 @@
+
+ SRCS= comsat.c usebiffer.c
+
+-BINDIR= /usr/local/libexec
+-MANDIR= /usr/local/man/man
++PREFIX= /usr/local
++BINDIR= ${PREFIX}/libexec
++MANDIR= ${PREFIX}/man/man
+CC?= cc
+CFLAGS?= -O -pipe