aboutsummaryrefslogtreecommitdiff
path: root/mail/bogofilter/Makefile
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2005-07-25 15:15:06 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2005-07-25 15:15:06 +0000
commit7d5406184086773dc424e0c29dc601aa69348c59 (patch)
treedb0125997005990b97c7d2959004d2dccf8d72be /mail/bogofilter/Makefile
parentc5150c9b5a843b39f0c1d0752cce18993d4495b1 (diff)
downloadports-7d5406184086773dc424e0c29dc601aa69348c59.tar.gz
ports-7d5406184086773dc424e0c29dc601aa69348c59.zip
Update to 0.95.2
PR: ports/83906 Submitted by: Matthias Andree <matthias.andree@gmx.de> (maintainer) Approved by: perky (mentor)
Notes
Notes: svn path=/head/; revision=140091
Diffstat (limited to 'mail/bogofilter/Makefile')
-rw-r--r--mail/bogofilter/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/mail/bogofilter/Makefile b/mail/bogofilter/Makefile
index 45df0ee68385..34d4a3ef0f69 100644
--- a/mail/bogofilter/Makefile
+++ b/mail/bogofilter/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= bogofilter
-PORTVERSION= 0.94.14
-PORTREVISION?= 1
+PORTVERSION= 0.95.2
+PORTREVISION?= 0
CATEGORIES?= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,9 +15,9 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER?= matthias.andree@gmx.de
COMMENT= Fast, teachable, learning spam detector
-OPTIONS= BASH "Install scripts that depend on the bash(1) shell" on
-OPTIONS+= GSL "Link with system-wide GSL dynamically (recommended)" on
-OPTIONS+= ICONV "Normalize tokens to Unicode (EXPERIMENTAL)" off
+OPTIONS= BASH "Install scripts that depend on the bash(1) shell" on
+OPTIONS+= GSL "Link with system-wide GSL dynamically (recommended)" on
+OPTIONS+= UNICODE "Normalize tokens to Unicode (UTF-8)" on
LIB_DEPENDS?= db-4.3:${PORTSDIR}/databases/db43
@@ -38,8 +38,8 @@ RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
BF_LIBS?= -ldb-4.3
BF_CPPFLAGS?= -I${LOCALBASE}/include/db43 -I${LOCALBASE}/include
CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc
-.if defined(WITH_ICONV)
-CONFIGURE_ARGS+= --enable-iconv
+.if !defined(WITHOUT_UNICODE)
+CONFIGURE_ARGS+= --enable-unicode
USE_ICONV= yes
BF_LIBS+= -liconv
.endif
@@ -54,7 +54,7 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALL_TARGET= install-strip prefix=${PREFIX}
MAN1= bogofilter.1 bogoutil.1 bogoupgrade.1 bogolexer.1 bogotune.1 \
- bf_copy.1 bf_compact.1 bf_resize.1 bf_tar.1
+ bf_copy.1 bf_compact.1 bf_tar.1
post-patch:
${REINPLACE_CMD} -e "s|/bin/bash|${LOCALBASE}/bin/bash|" \
@@ -67,6 +67,8 @@ post-patch:
${WRKSRC}/contrib/bogominitrain.pl \
${WRKSRC}/contrib/mime.get.rfc822 \
${WRKSRC}/contrib/printmaildir.pl
+ ${REINPLACE_CMD} -e 's/INTEGRITY_TESTS = t.lock1 t.lock3 t.valgrind/INTEGRITY_TESTS = t.lock1 t.lock3/' \
+ ${WRKSRC}/src/tests/Makefile.in
.if !defined(NOPORTDOCS)
PORTDOCS= *