aboutsummaryrefslogtreecommitdiff
path: root/mail/bogofilter
diff options
context:
space:
mode:
authorYaroslav Tykhiy <ytykhiy@gmail.com>2005-05-30 10:48:24 +0000
committerYaroslav Tykhiy <ytykhiy@gmail.com>2005-05-30 10:48:24 +0000
commit1e6b35a3eb38011b5f540e56ea5d7d4b61770664 (patch)
tree60f5634e3b6117b34ed5c245ff23f049ce7c6ac2 /mail/bogofilter
parentebb62390c8216a70220c3a97d09b52b44f37565b (diff)
downloadports-1e6b35a3eb38011b5f540e56ea5d7d4b61770664.tar.gz
ports-1e6b35a3eb38011b5f540e56ea5d7d4b61770664.zip
- Update to 0.94.13
* iconv/unicode bugfixes * sqlite3 interface much more CPU efficient and faster now * bogofilter -q option to suppress printing of statistics (see share/doc/bogofilter/NEWS for details) - convert WITHOUT_*/pre-everything messaging stuff (GSL, BASH) to OPTIONS - add an OPTIONS switch for ICONV (experimental, default off), suggested by Yar Tikhiy. - revise pkg-install message - use a more suitable LIBS/CPPFLAGS passing for sibling ports or when GSL=off ICONV=on is used. - change wording of GSL OPTION. - reset -qdbm PORTREVISION - remove obsoleted bogofilter-qdbm/files/* patches - deprecate bogofilter-tdb effective 2005-11-30 Removed files: - bogofilter-qdbm/files/patch-pathcycle PR: ports/81642 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=136418
Diffstat (limited to 'mail/bogofilter')
-rw-r--r--mail/bogofilter/Makefile56
-rw-r--r--mail/bogofilter/distinfo4
-rw-r--r--mail/bogofilter/pkg-install5
3 files changed, 32 insertions, 33 deletions
diff --git a/mail/bogofilter/Makefile b/mail/bogofilter/Makefile
index 3b479002fdb6..76859a1a92ed 100644
--- a/mail/bogofilter/Makefile
+++ b/mail/bogofilter/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bogofilter
-PORTVERSION= 0.94.12
+PORTVERSION= 0.94.13
PORTREVISION?= 0
CATEGORIES?= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -15,13 +15,11 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER?= matthias.andree@gmx.de
COMMENT= Fast, teachable, learning spam detector
+OPTIONS= BASH "Install scripts that depend on the bash(1) shell" on
+OPTIONS+= GSL "Link with system-wide GSL dynamically (recommended)" on
+OPTIONS+= ICONV "Normalize tokens to Unicode (EXPERIMENTAL)" off
+
LIB_DEPENDS?= db-4.3:${PORTSDIR}/databases/db43
-.if !defined(WITHOUT_GSL)
-LIB_DEPENDS+= gsl:${PORTSDIR}/math/gsl
-.endif
-.if !defined(WITHOUT_BASH)
-RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
-.endif
CONFLICTS?= bogofilter-sqlite-[0-9]* bogofilter-tdb-[0-9]* bogofilter-qdbm-[0-9]* [a-z][a-z]-bogofilter-[0-9]* bogofilter-sqlite-[0-9]*
@@ -30,13 +28,28 @@ USE_REINPLACE= yes
USE_PERL5_RUN= yes
GNU_CONFIGURE= yes
PATCH_STRIP= -p1
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_BASH)
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+.endif
+
+BF_LIBS?= -ldb-4.3
+BF_CPPFLAGS?= -I${LOCALBASE}/include/db43 -I${LOCALBASE}/include
CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc
-.if defined(WITHOUT_GSL)
+.if defined(WITH_ICONV)
+CONFIGURE_ARGS+= --enable-iconv
+USE_ICONV= yes
+BF_LIBS+= -liconv
+.endif
+.if defined(WITH_GSL)
+LIB_DEPENDS+= gsl:${PORTSDIR}/math/gsl
+.else
CONFIGURE_ARGS+= --with-included-gsl
.endif
-CONFIGURE_ENV?= CPPFLAGS="-I${LOCALBASE}/include/db43" \
- LDFLAGS="-L${LOCALBASE}/lib" LIBS="-ldb-4.3"
-CONFIGURE_ENV+= PERL="${PERL}"
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" LIBS="${BF_LIBS}" \
+ PERL="${PERL}" CPPFLAGS="${BF_CPPFLAGS}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALL_TARGET= install-strip prefix=${PREFIX}
@@ -59,23 +72,6 @@ post-patch:
PORTDOCS= *
.endif
-pre-everything::
- @${ECHO_CMD} ""
-.if !defined(WITHOUT_BASH)
- @${ECHO_CMD} "To install without bash dependency, you can use: make -DWITHOUT_BASH install"
- @${ECHO_CMD} "Note that installing without bash dependency will mean that some of the"
- @${ECHO_CMD} "${DOCSDIR}/contrib scripts will not be installed."
- @${ECHO_CMD} ""
-.endif
-.if !defined(WITHOUT_GSL)
- @${ECHO_CMD} "To have bogofilter link against its shipped GSL 1.4 statically,"
- @${ECHO_CMD} "you can use: make -DWITHOUT_GSL && make -DWITHOUT_GSL install"
-.if !defined(WITHOUT_BASH)
- @${ECHO_CMD} "or: make -DWITHOUT_GSL && make -DWITHOUT_GSL -DWITHOUT_BASH install"
-.endif
- @${ECHO_CMD} ""
-.endif
-
post-build::
cd ${WRKSRC} && make check SHELL=${SH}
@@ -109,7 +105,7 @@ post-install::
${INSTALL_DATA} ${WRKSRC}/doc/programmer/README.freebsd ${DOCSDIR}/programmer
${INSTALL_DATA} ${FILESDIR}/ChangeLog.port ${DOCSDIR}
.endif
-.if !defined(WITHOUT_BASH)
+.if defined(WITH_BASH)
.for i in randomtrain scramble trainbogo.sh
${INSTALL_SCRIPT} ${WRKSRC}/contrib/${i} ${DOCSDIR}/contrib/
.endfor
@@ -117,4 +113,4 @@ post-install::
.endif
${SETENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/bogofilter/distinfo b/mail/bogofilter/distinfo
index 0604b07f8577..4b1e7cd83464 100644
--- a/mail/bogofilter/distinfo
+++ b/mail/bogofilter/distinfo
@@ -1,2 +1,2 @@
-MD5 (bogofilter-0.94.12.tar.bz2) = 489337defebff75d8e2b46350e946752
-SIZE (bogofilter-0.94.12.tar.bz2) = 723385
+MD5 (bogofilter-0.94.13.tar.bz2) = 1b3c6f192a361f0825a3decaa7f65e6b
+SIZE (bogofilter-0.94.13.tar.bz2) = 724255
diff --git a/mail/bogofilter/pkg-install b/mail/bogofilter/pkg-install
index c1fe0fc37f03..8da3d8915d7e 100644
--- a/mail/bogofilter/pkg-install
+++ b/mail/bogofilter/pkg-install
@@ -5,7 +5,10 @@ cat - <<_EOF
The recent bogofilter versions have undergone substantial changes that can
affect compatibility and may require that you change your configuration.
-See the RELEASE.NOTES-* files that shipped with bogofilter for details.
+See the RELEASE.NOTES file that shipped with bogofilter for details,
+particularly the sections with headings [Incompat ...] and [Major ...]!
+
+It is also advisable to check the README.* file for your database driver.
--------------------------------------------------------------------------
_EOF