aboutsummaryrefslogtreecommitdiff
path: root/mail/bulk_mailer
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-06-08 10:00:45 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-06-08 10:00:45 +0000
commit5029de3d095bc973fe87193dbafe6f0aaa86bc3d (patch)
tree9e413e8e6b088f9c9a5c4143e77fb9820b92fa14 /mail/bulk_mailer
parent89a8ae829b8a4c4063debd617a472d36571db496 (diff)
downloadports-5029de3d095bc973fe87193dbafe6f0aaa86bc3d.tar.gz
ports-5029de3d095bc973fe87193dbafe6f0aaa86bc3d.zip
Update bulk_mailer from 1.12 to 1.13.
Several my own fixes/cleanups: - make it use mkstemp() instead of less secupe mktemp(); - HAS_CONFIGURE --> GNU_CONFIGURE; - install README into separate bulk_mailer directory under ${PREFIX}/share/doc, not just ${PREFIX}/share/doc/bulk_mailer.README. PR: 19100 Submitted by: Ying-Chieh Liao <ijliao@Terry.Dorm8.NCTU.edu.tw>
Notes
Notes: svn path=/head/; revision=29382
Diffstat (limited to 'mail/bulk_mailer')
-rw-r--r--mail/bulk_mailer/Makefile14
-rw-r--r--mail/bulk_mailer/distinfo2
-rw-r--r--mail/bulk_mailer/files/patch-ab39
-rw-r--r--mail/bulk_mailer/pkg-plist3
4 files changed, 35 insertions, 23 deletions
diff --git a/mail/bulk_mailer/Makefile b/mail/bulk_mailer/Makefile
index d95eb5fbaab1..5da3fbe6880b 100644
--- a/mail/bulk_mailer/Makefile
+++ b/mail/bulk_mailer/Makefile
@@ -6,26 +6,24 @@
#
PORTNAME= bulk_mailer
-PORTVERSION= 1.12
+PORTVERSION= 1.13
CATEGORIES= mail
MASTER_SITES= ftp://cs.utk.edu/pub/moore/bulk_mailer/
MAINTAINER= dlowe@saturn5.com
-MAN1= bulk_mailer.1
-
-HAS_CONFIGURE= YES
+GNU_CONFIGURE= YES
CONFIGURE_ARGS=--cache-file=/dev/null
ALL_TARGET= bulk_mailer
-pre-configure:
- cd ${WRKSRC} ; make distclean
+MAN1= bulk_mailer.1
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/bulk_mailer ${PREFIX}/bin/bulk_mailer
- @ ${INSTALL_DATA} ${WRKSRC}/bulk_mailer.README \
- ${PREFIX}/share/doc/bulk_mailer.README
+ @ ${MKDIR} ${PREFIX}/share/doc/bulk_mailer
+ @ ${INSTALL_MAN} ${WRKSRC}/bulk_mailer.README \
+ ${PREFIX}/share/doc/bulk_mailer/README
@ ${INSTALL_MAN} ${WRKSRC}/bulk_mailer.1 ${PREFIX}/man/man1/bulk_mailer.1
.include <bsd.port.mk>
diff --git a/mail/bulk_mailer/distinfo b/mail/bulk_mailer/distinfo
index c271dc20b588..f5e3e84488d9 100644
--- a/mail/bulk_mailer/distinfo
+++ b/mail/bulk_mailer/distinfo
@@ -1 +1 @@
-MD5 (bulk_mailer-1.12.tar.gz) = 6a5ea15eedfcc1c316e9690092670366
+MD5 (bulk_mailer-1.13.tar.gz) = 795a953ae89c01c4b2192bf965377feb
diff --git a/mail/bulk_mailer/files/patch-ab b/mail/bulk_mailer/files/patch-ab
index 441ff66bf011..7328316db53a 100644
--- a/mail/bulk_mailer/files/patch-ab
+++ b/mail/bulk_mailer/files/patch-ab
@@ -1,6 +1,6 @@
---- bulk_mailer.c.ORIG Tue Apr 14 19:38:46 1998
-+++ bulk_mailer.c Fri Aug 14 22:02:19 1998
-@@ -91,11 +91,16 @@
+--- bulk_mailer.c.orig Wed May 24 22:34:33 2000
++++ bulk_mailer.c Thu Jun 8 12:35:46 2000
+@@ -95,11 +95,16 @@
#include <sysexits.h>
#include <errno.h>
#include <time.h>
@@ -17,7 +17,7 @@
#ifndef PIPECOMMAND
#define PIPECOMMAND "/usr/lib/sendmail -bs %s"
#endif
-@@ -271,6 +276,7 @@
+@@ -296,6 +301,7 @@
* memory, appending a NUL to the copy.
*/
@@ -25,7 +25,7 @@
static char *
strndup (str, len)
char *str;
-@@ -282,6 +288,7 @@
+@@ -307,6 +313,7 @@
result[len] = '\0';
return result;
}
@@ -33,7 +33,7 @@
/*
* sort by case-folded reversed domain
-@@ -312,15 +319,15 @@
+@@ -337,15 +344,15 @@
{
char *at;
char *ptr;
@@ -52,7 +52,7 @@
num_addr_slots += 1000;
if (address_list == NULL)
-@@ -544,12 +551,12 @@
+@@ -571,12 +578,12 @@
open_envelope ()
{
FILE *fp;
@@ -67,7 +67,7 @@
if ((fp = popen (command_buf, "w")) == NULL) {
fprintf (stderr, "can't open pipe to sendmail: %s\n",
-@@ -867,7 +874,7 @@
+@@ -927,7 +934,7 @@
{
struct tm gmt;
struct tm *lt;
@@ -76,7 +76,7 @@
int gmtoff;
char sign;
static char *months[] = {
-@@ -900,7 +907,7 @@
+@@ -960,7 +967,7 @@
sign = '-';
gmtoff = -gmtoff;
}
@@ -85,7 +85,7 @@
wdays[lt->tm_wday], lt->tm_mday, months[lt->tm_mon], lt->tm_year + 1900,
lt->tm_hour, lt->tm_min, lt->tm_sec,
sign,
-@@ -925,7 +932,7 @@
+@@ -985,7 +992,7 @@
copy_message (out, in)
FILE *out, *in;
{
@@ -94,7 +94,7 @@
char linebuf[32*1024];
int has_valid_approved_hdr = 0;
int has_resent_to_hdr = 0;
-@@ -1114,14 +1121,14 @@
+@@ -1218,14 +1225,14 @@
*/
lines = 0;
while (fgets (linebuf, sizeof (linebuf), in) != NULL) {
@@ -111,7 +111,7 @@
saw_command = 1;
++lines;
fputs (linebuf, out);
-@@ -1222,13 +1229,13 @@
+@@ -1326,13 +1333,14 @@
int argc;
char *argv[];
{
@@ -125,10 +125,23 @@
- char buf[1024];
+/* int c; */
+/* char buf[1024]; */
++ int fd;
while (argc > 1 && (*argv[1] == '-' || *argv[1] == '+')) {
if (strcmp (argv[1], "-comment") == 0 && argc > 2) {
-@@ -1396,4 +1403,5 @@
+@@ -1513,8 +1521,9 @@
+ exit (EX_OSFILE);
+ }
+
+- tempname = mktemp (template);
+- tmp = fopen (template, "w");
++ fd = mkstemp (template);
++ tempname = template;
++ tmp = fdopen (fd, "w+");
+ switch (copy_message (tmp, stdin)) {
+
+ case HAS_EMBEDDED_COMMAND:
+@@ -1592,4 +1601,5 @@
exit (EX_OK);
}
diff --git a/mail/bulk_mailer/pkg-plist b/mail/bulk_mailer/pkg-plist
index 80f2ba02c575..a091ab012add 100644
--- a/mail/bulk_mailer/pkg-plist
+++ b/mail/bulk_mailer/pkg-plist
@@ -1,2 +1,3 @@
bin/bulk_mailer
-share/doc/bulk_mailer.README
+share/doc/bulk_mailer/README
+@dirrm share/doc/bulk_mailer