aboutsummaryrefslogtreecommitdiff
path: root/mail/courier-imap
diff options
context:
space:
mode:
authorNeil Blakey-Milner <nbm@FreeBSD.org>2001-08-27 12:54:57 +0000
committerNeil Blakey-Milner <nbm@FreeBSD.org>2001-08-27 12:54:57 +0000
commit8188cfcbb16d7708fe00862685c8c4698f6a0947 (patch)
treedc542606caa806a650ffd9e1736046e3eeaeab21 /mail/courier-imap
parent6cec7f4955035c809a6c869ae45f7cefac3d55f3 (diff)
downloadports-8188cfcbb16d7708fe00862685c8c4698f6a0947.tar.gz
ports-8188cfcbb16d7708fe00862685c8c4698f6a0947.zip
1) Correct a type in PLIST_SUB entry for authpam.
2) Enable dependencies properly for vpopmail 3) Add an option WITH_MYSQL for mysql authentication Submitted by: dirk (1)
Notes
Notes: svn path=/head/; revision=46970
Diffstat (limited to 'mail/courier-imap')
-rw-r--r--mail/courier-imap/Makefile14
-rw-r--r--mail/courier-imap/pkg-plist1
2 files changed, 13 insertions, 2 deletions
diff --git a/mail/courier-imap/Makefile b/mail/courier-imap/Makefile
index 011676db0000..203a11938f49 100644
--- a/mail/courier-imap/Makefile
+++ b/mail/courier-imap/Makefile
@@ -28,7 +28,6 @@ PLIST_SUB= OPENSSLFLAG="@comment "
CONFIGURE_ARGS= --without-authldap --with-authldaprc=filename \
--without-authshadow \
--without-authcram \
- --without-authmysql \
--sysconfdir=${PREFIX}/etc/courier-imap \
--with-userdb=${PREFIX}/etc/userdb \
--datadir=${PREFIX}/share/courier-imap \
@@ -36,14 +35,25 @@ CONFIGURE_ARGS= --without-authldap --with-authldaprc=filename \
--enable-workarounds-for-imap-client-bugs \
--disable-root-check
+VPOPMAILDIR?= ${LOCALBASE}/vpopmail
.if !defined(WITH_VPOPMAIL)
CONFIGURE_ARGS+= \
--without-authvchkpw
PLIST_SUB+= VPOPMAILFLAG="@comment "
.else
+BUILD_DEPENDS+= ${VPOPMAILDIR}/lib/libvpopmail.a:${PORTSDIR}/mail/vpopmail
PLIST_SUB+= VPOPMAILFLAG=""
.endif
+.if !defined(WITH_MYSQL)
+CONFIGURE_ARGS+= \
+ --without-authmysql \
+PLIST_SUB+= MYSQLFLAG="@comment "
+.else
+LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+PLIST_SUB+= MYSQLFLAG=""
+.endif
+
.if !defined(WITHOUT_PAM)
CONFIGURE_ARGS+= \
--with-authpam
@@ -51,7 +61,7 @@ PLIST_SUB+= PAMFLAG=""
.else
CONFIGURE_ARGS+= \
--without-authpam
-PLIST_SUB+= PAMFLAG="@comment"
+PLIST_SUB+= PAMFLAG="@comment "
.endif
MAN1= maildirmake.1
diff --git a/mail/courier-imap/pkg-plist b/mail/courier-imap/pkg-plist
index 7a9c9dc3dc2a..76aa5a06efd9 100644
--- a/mail/courier-imap/pkg-plist
+++ b/mail/courier-imap/pkg-plist
@@ -10,6 +10,7 @@ etc/courier-imap/pop3d.cnf.dist
etc/courier-imap/pop3d.dist
etc/courier-imap/quotawarnmsg.example
libexec/courier-imap/authlib/authcustom
+%%MYSQLFLAG%%libexec/courier-imap/authlib/authmysql
%%PAMFLAG%%libexec/courier-imap/authlib/authpam
libexec/courier-imap/authlib/authpwd
libexec/courier-imap/authlib/authuserdb