aboutsummaryrefslogtreecommitdiff
path: root/mail/cyrus-imapd23
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2010-11-26 15:23:45 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2010-11-26 15:23:45 +0000
commitd97299712d8d73a58de21f06b16e8550d478f06d (patch)
treee98364a535d49ee87b03d58b1c7a5516031b7158 /mail/cyrus-imapd23
parent524624e83b39972f6db11420ee3f6ad348332a57 (diff)
downloadports-d97299712d8d73a58de21f06b16e8550d478f06d.tar.gz
ports-d97299712d8d73a58de21f06b16e8550d478f06d.zip
Use PCRE explicitly. If PCRE was installed, the header of PCRE was
picked upped. However, since there was bash-ism in the configure script, libpcre was not linked, correctly. As the result, the regex in our libc was used, but the header of PCRE was referred.
Notes
Notes: svn path=/head/; revision=265186
Diffstat (limited to 'mail/cyrus-imapd23')
-rw-r--r--mail/cyrus-imapd23/Makefile6
-rw-r--r--mail/cyrus-imapd23/files/extra-patch-configure.in13
-rw-r--r--mail/cyrus-imapd23/files/patch-configure13
3 files changed, 26 insertions, 6 deletions
diff --git a/mail/cyrus-imapd23/Makefile b/mail/cyrus-imapd23/Makefile
index 4e29fd41b301..f782c2a12945 100644
--- a/mail/cyrus-imapd23/Makefile
+++ b/mail/cyrus-imapd23/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cyrus-imapd
PORTVERSION= 2.3.16
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.andrew.cmu.edu/pub/cyrus/ \
http://ftp.andrew.cmu.edu/pub/cyrus/ \
@@ -17,7 +17,8 @@ MASTER_SITES= ftp://ftp.andrew.cmu.edu/pub/cyrus/ \
MAINTAINER= ume@FreeBSD.org
COMMENT= The cyrus mail server, supporting POP3 and IMAP4 protocols
-LIB_DEPENDS= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
+LIB_DEPENDS= sasl2.2:${PORTSDIR}/security/cyrus-sasl2 \
+ pcre.0:${PORTSDIR}/devel/pcre
CONFLICTS= cyrus-1.* cyrus-imapd-2.[^3].*
@@ -36,6 +37,7 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--with-com_err \
--with-openssl=${OPENSSLBASE} \
--with-perl=${PERL5}
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
MAKE_JOBS_UNSAFE= yes
OPTIONS= AUTOCREATE "Use autocreate INBOX patch (UoA)" off \
diff --git a/mail/cyrus-imapd23/files/extra-patch-configure.in b/mail/cyrus-imapd23/files/extra-patch-configure.in
index 7fd80581963c..28e3c0e8f462 100644
--- a/mail/cyrus-imapd23/files/extra-patch-configure.in
+++ b/mail/cyrus-imapd23/files/extra-patch-configure.in
@@ -1,7 +1,16 @@
Index: configure.in
diff -u configure.in.orig configure.in
---- configure.in.orig 2009-12-21 23:17:00.962723262 +0900
-+++ configure.in 2009-12-21 23:18:07.032701766 +0900
+--- configure.in.orig 2010-11-26 14:14:12.403327543 +0900
++++ configure.in 2010-11-26 14:14:47.834464148 +0900
+@@ -391,7 +391,7 @@
+ AC_CHECK_LIB(fl,main)
+
+ AC_CHECK_HEADERS(pcreposix.h rxposix.h)
+- if test "$ac_cv_header_pcreposix_h" == "yes"; then
++ if test "$ac_cv_header_pcreposix_h" = "yes"; then
+ LIBS="$LIBS -lpcre -lpcreposix";
+ AC_DEFINE(ENABLE_REGEX, [], [Do we have a regex library?])
+ else
@@ -1145,7 +1145,7 @@
dnl libraries will be compiled as PIC if perl requires PIC objects
dnl -- this is needed on NetBSD and Linux, but seems to cause problems on atleast Solaris --
diff --git a/mail/cyrus-imapd23/files/patch-configure b/mail/cyrus-imapd23/files/patch-configure
index df269d696b7a..744995260bf5 100644
--- a/mail/cyrus-imapd23/files/patch-configure
+++ b/mail/cyrus-imapd23/files/patch-configure
@@ -1,7 +1,7 @@
Index: configure
diff -u configure.orig configure
---- configure.orig 2009-12-21 23:20:56.817376076 +0900
-+++ configure 2009-12-21 23:21:49.196653299 +0900
+--- configure.orig 2010-11-26 14:08:32.950506060 +0900
++++ configure 2010-11-26 14:10:19.298911330 +0900
@@ -642,6 +642,7 @@
IMAP_COM_ERR_LIBS
LIB_RT
@@ -10,6 +10,15 @@ diff -u configure.orig configure
SNMP_CONFIG
LIB_WRAP
SNMP_SUBDIRS
+@@ -12402,7 +12403,7 @@
+
+ done
+
+- if test "$ac_cv_header_pcreposix_h" == "yes"; then
++ if test "$ac_cv_header_pcreposix_h" = "yes"; then
+ LIBS="$LIBS -lpcre -lpcreposix";
+
+ cat >>confdefs.h <<\_ACEOF
@@ -20173,7 +20174,7 @@
PERL_SUBDIRS="imap"
PERL="${with_perl}"