aboutsummaryrefslogtreecommitdiff
path: root/mail/cyrus-imapd24
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-12-21 08:25:50 +0000
committerWill Andrews <will@FreeBSD.org>2000-12-21 08:25:50 +0000
commitfae99bfc40c855836ae4873ab9e589a5b57ac1aa (patch)
tree229f5942465474689326694238f4b4ed036c56d8 /mail/cyrus-imapd24
parent64a29c4fcd8e60a228b42a0341395d55421e5bed (diff)
downloadports-fae99bfc40c855836ae4873ab9e589a5b57ac1aa.tar.gz
ports-fae99bfc40c855836ae4873ab9e589a5b57ac1aa.zip
Update to 1.6.24. Fix /var/pwcheck handling since that's moved to the
security/cyrus-sasl port. Fix deliver.c so it uses the correct location of sendmail (/usr/sbin/sendmail vs. /usr/lib/sendmail). Open the port up to the world after previous maintainer showed no interest in the port for nearly 2 years. PR: 22791, 22465 Submitted by: Martti Kuparinen <martti.kuparinen@piuha.net> Scot W. Hetzel <hetzels@westbend.net>
Notes
Notes: svn path=/head/; revision=36178
Diffstat (limited to 'mail/cyrus-imapd24')
-rw-r--r--mail/cyrus-imapd24/Makefile14
-rw-r--r--mail/cyrus-imapd24/distinfo2
-rw-r--r--mail/cyrus-imapd24/files/cyrus.sh27
-rw-r--r--mail/cyrus-imapd24/files/imapd.conf27
-rw-r--r--mail/cyrus-imapd24/files/inetd.conf.cyrus7
-rw-r--r--mail/cyrus-imapd24/files/patch-ae11
-rw-r--r--mail/cyrus-imapd24/pkg-deinstall47
-rw-r--r--mail/cyrus-imapd24/pkg-install30
-rw-r--r--mail/cyrus-imapd24/pkg-plist1
9 files changed, 125 insertions, 41 deletions
diff --git a/mail/cyrus-imapd24/Makefile b/mail/cyrus-imapd24/Makefile
index 5b1302c7f56f..a7db7ea5af3d 100644
--- a/mail/cyrus-imapd24/Makefile
+++ b/mail/cyrus-imapd24/Makefile
@@ -6,15 +6,13 @@
#
PORTNAME= cyrus
-PORTVERSION= 1.6.22
+PORTVERSION= 1.6.24
CATEGORIES= mail tcl82
MASTER_SITES= ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/ \
- ${MASTER_SITE_LOCAL} \
ftp://ftp.hanse.de/sites/transit/mirror/ftp.andrew.cmu.edu/pub/cyrus-mail/
-MASTER_SITE_SUBDIR= stb/mirror/ftp.andrew.cmu.edu/pub/cyrus-mail
DISTNAME= ${PORTNAME}-imapd-${PORTVERSION}
-MAINTAINER= stb@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
Y2K= http://asg.web.cmu.edu/cyrus/imapd/y2k.html
@@ -76,7 +74,6 @@ post-install:
${PREFIX}/etc/imap/proc \
${PREFIX}/etc/imap/log \
${PREFIX}/etc/imap/msg
- ${INSTALL} -d -m 700 -o cyrus -g cyrus /var/pwcheck
${TOUCH} ${PREFIX}/etc/imap/mailboxes
${CHMOD} 640 ${PREFIX}/etc/imap/mailboxes
chown cyrus:cyrus ${PREFIX}/etc/imap/mailboxes
@@ -89,18 +86,11 @@ post-install:
@${ECHO} "@exec chown -R cyrus:cyrus %D/etc/imap" >>${TMPPLIST}
@${ECHO} "@exec chmod -R g-w,o= %D/etc/imap" >>${TMPPLIST}
@${ECHO} "@mode u=rwx,go=" >>${TMPPLIST}
- @${ECHO} "@exec mkdir /var/pwcheck" >>${TMPPLIST}
- @${ECHO} "@exec chown cyrus:cyrus /var/pwcheck" >>${TMPPLIST}
- @${ECHO} "@exec chmod go= /var/pwcheck" >>${TMPPLIST}
@${ECHO} "@exec mkdir /var/spool/imap" >>${TMPPLIST}
@${ECHO} "@exec chown cyrus:cyrus /var/spool/imap" >>${TMPPLIST}
@${ECHO} "@exec chmod g-w,o= /var/spool/imap" >>${TMPPLIST}
@${ECHO} "@cwd /var" >>${TMPPLIST}
- @${ECHO} "@dirrm pwcheck" >>${TMPPLIST}
@${ECHO} "@dirrm spool/imap" >>${TMPPLIST}
- @${SED} -e "/%%PREFIX%%/s##${PREFIX}#g" ${FILESDIR}/cyrus.sh \
- >${PREFIX}/etc/rc.d/cyrus.sh
- @${CHMOD} 0755 ${PREFIX}/etc/rc.d/cyrus.sh
@PKG_PREFIX=${PREFIX} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.mk>
diff --git a/mail/cyrus-imapd24/distinfo b/mail/cyrus-imapd24/distinfo
index 6993ccc0d37d..6ad67e22eaa6 100644
--- a/mail/cyrus-imapd24/distinfo
+++ b/mail/cyrus-imapd24/distinfo
@@ -1 +1 @@
-MD5 (cyrus-imapd-1.6.22.tar.gz) = 1a0b4d466c8662a60313a0bb51a65ea2
+MD5 (cyrus-imapd-1.6.24.tar.gz) = 490a246e787581e0bbc558788ff5f562
diff --git a/mail/cyrus-imapd24/files/cyrus.sh b/mail/cyrus-imapd24/files/cyrus.sh
deleted file mode 100644
index 9248623a8fe2..000000000000
--- a/mail/cyrus-imapd24/files/cyrus.sh
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/bin/sh
-#
-PREFIX=%%PREFIX%%
-
-case "$1" in
-
-start)
- if [ -x ${PREFIX}/cyrus/bin/pwcheck ]
- then
- ${PREFIX}/cyrus/bin/pwcheck & && echo -n " pwcheck"
- fi
- ;;
-
-stop)
- if [ -r /var/run/pwcheck.pid ]
- then
- kill `cat /var/run/pwcheck.pid` && echo -n " pwcheck"
- fi
- ;;
-
-*)
- echo "usage: $0 {start|stop}" 1>&2
- exit 64
- ;;
-
-esac
-
diff --git a/mail/cyrus-imapd24/files/imapd.conf b/mail/cyrus-imapd24/files/imapd.conf
index f9ff5924f0af..8c657589f69f 100644
--- a/mail/cyrus-imapd24/files/imapd.conf
+++ b/mail/cyrus-imapd24/files/imapd.conf
@@ -108,5 +108,32 @@ partition-default: /var/spool/imap
#
#loginuseacl: no
+# If enabled, deliver wil look for Sieve scripts in user's home directories:
+# ~user/.sieve.
+#
+sieveusehomedir: false
+
+# If sieveusehomedir is false, this directory is searched for Sieve scripts.
+# The active Sieve script is s called "default", placed in the users sieve
+# sieve directory (ie. /usr/local/etc/imap/sieve/u/user).
+#
+sievedir: /usr/local/etc/imap/sieve
+
+# If enabled, the partitions will also be hashed, in addition to the hashing
+# done on configuration directories. This is recommended if one partition has
+# a very bushy mailbox tree.
+#
+#hashimapspool: false
+
+# The mechanism used by the server to verify plaintext passwords. Possible
+# values include "PAM", "kerberos_v4", "passwd", and "shadow"
+#
+sasl_pwcheck_method: pwcheck
+
+# If enabled, the SASL library will automatically create authentication
+# secrets when given a plaintext password. See the SASL documentation.
+#
+#sasl_auto_transition: no
+
#
# EOF
diff --git a/mail/cyrus-imapd24/files/inetd.conf.cyrus b/mail/cyrus-imapd24/files/inetd.conf.cyrus
index f2878fac7aa6..c3dbb754aec3 100644
--- a/mail/cyrus-imapd24/files/inetd.conf.cyrus
+++ b/mail/cyrus-imapd24/files/inetd.conf.cyrus
@@ -10,3 +10,10 @@ imap4 stream tcp nowait cyrus /usr/local/cyrus/bin/imapd imapd
# To be able to access the IMAP mailbox by POP-3, use this line.
pop3 stream tcp nowait cyrus /usr/local/cyrus/bin/pop3d pop3d
#
+# Program to upload user sieve scripts to the IMAP server.
+#
+# NOTE: you will need to add "sieve" to /etc/services.
+# timsieved uses port 2000.
+#
+sieve strean tcp nowait cyrus /usr/local/cyrus/bin/timsieved sieve
+
diff --git a/mail/cyrus-imapd24/files/patch-ae b/mail/cyrus-imapd24/files/patch-ae
new file mode 100644
index 000000000000..dde3c7177004
--- /dev/null
+++ b/mail/cyrus-imapd24/files/patch-ae
@@ -0,0 +1,11 @@
+--- imap/deliver.c.orig Tue Jan 4 17:49:02 2000
++++ imap/deliver.c Tue Oct 31 22:49:37 2000
+@@ -821,7 +821,7 @@
+ }
+ }
+
+-#define SENDMAIL "/usr/lib/sendmail"
++#define SENDMAIL "/usr/sbin/sendmail"
+ #define POSTMASTER "postmaster"
+
+ static char *month[] = { "Jan", "Feb", "Mar", "Apr", "May", "Jun",
diff --git a/mail/cyrus-imapd24/pkg-deinstall b/mail/cyrus-imapd24/pkg-deinstall
new file mode 100644
index 000000000000..ed567ca504b0
--- /dev/null
+++ b/mail/cyrus-imapd24/pkg-deinstall
@@ -0,0 +1,47 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Created by: hetzels@westbend.net
+
+#set -vx
+
+PKG_BATCH=${BATCH:=NO}
+
+PKG_PREFIX=${PKG_PREFIX:=/usr/local}
+
+checkfile() {
+ diff -bBqw $1 $1.dist >/dev/null 2>&1
+ case $? in
+ 0) # config file exists, but is the same
+ rm $1
+ ;;
+ 1) # config file exists and differs
+ ;;
+ *) # no config file exists
+ ;;
+ esac
+}
+
+# Uninstall timseived's Cyrus.conf file.
+
+cyrus_conf() {
+ if [ -f ${PKG_PREFIX}/lib/sasl/Cyrus.conf ]; then
+ echo "pwcheck_method: pwcheck" > ${PKG_PREFIX}/lib/sasl/Cyrus.conf.tmp
+ if cmp -s ${PKG_PREFIX}/lib/sasl/Cyrus.conf ${PKG_PREFIX}/lib/sasl/Cyrus.conf.tmp; then
+ rm -f ${PKG_PREFIX}/lib/sasl/Cyrus.conf
+ fi
+ rm -f ${PKG_PREFIX}/lib/sasl/Cyrus.conf.tmp
+ fi
+}
+
+case $2 in
+ DEINSTALL)
+ cd ${PKG_PREFIX}
+ cyrus_conf
+ checkfile ${PKG_PREIFX}/etc/imapd.conf
+ ;;
+ POST-DEINSTALL)
+ ;;
+
+esac
diff --git a/mail/cyrus-imapd24/pkg-install b/mail/cyrus-imapd24/pkg-install
index 93e91ebc4dae..8f935faef8de 100644
--- a/mail/cyrus-imapd24/pkg-install
+++ b/mail/cyrus-imapd24/pkg-install
@@ -2,6 +2,10 @@
#set -vx
+PKG_BATCH=${BATCH:=NO}
+
+PKG_PREFIX=${PKG_PREFIX:=/usr/local}
+
#
# create 'cyrus' user and group before installing
#
@@ -76,6 +80,13 @@ checkfile() {
esac
}
+# Install timseived's Cyrus.conf file
+
+cyrus_conf() {
+ if [ ! -f ${PKG_PREFIX}/lib/sasl/Cyrus.conf ]; then
+ echo "pwcheck_method: pwcheck" > ${PKG_PREFIX}/lib/sasl/Cyrus.conf
+ fi
+}
case $2 in
PRE-INSTALL)
@@ -84,6 +95,7 @@ case $2 in
POST-INSTALL)
cd ${PKG_PREFIX}
+ cyrus_conf
checkfile ${PKG_PREFIX}/etc/imapd.conf
if grep '^imap4' /etc/inetd.conf; then
echo "** Please check that your /etc/inetd.conf entry for \`imap4'"
@@ -91,6 +103,24 @@ case $2 in
else
echo "** Please add an entry for the imap4 protocol to /etc/inetd.conf."
fi
+ echo
+ if grep '^sieve' /etc/inetd.conf; then
+ echo "** Please check that your /etc/inetd.conf entry for \`sieve'"
+ echo " is suitable for the Cyrus timsieved daemon"
+ else
+ echo "** Please add an entry for timseived to /etc/inetd.conf."
+ echo " If you wish to have user's upload their sieve filter"
+ echo " scripts to the server."
+ fi
+ echo
echo " An example can be found in ${PKG_PREFIX}/etc/inetd.conf.cyrus."
+ if grep 'sieve' /etc/services; then
+ echo
+ else
+ echo
+ echo "** Please add an entry for the sieve protocol (2000/tcp)"
+ echo " to /etc/services"
+ echo
+ fi
;;
esac
diff --git a/mail/cyrus-imapd24/pkg-plist b/mail/cyrus-imapd24/pkg-plist
index 0bd7bbeedb62..8c62368fdf17 100644
--- a/mail/cyrus-imapd24/pkg-plist
+++ b/mail/cyrus-imapd24/pkg-plist
@@ -14,7 +14,6 @@ cyrus/bin/deliver
cyrus/bin/feedcyrus
cyrus/bin/timsieved
cyrus/bin/cyrquota
-etc/rc.d/cyrus.sh
etc/imapd.conf.dist
etc/inetd.conf.cyrus
etc/imap/mailboxes